User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

A place for users to discuss the Mac-based version of UltraEdit.
4 posts Page 1 of 1
How can I open multiple copies of UltraEdit? I can't seem to find anything in preferences.
I do not believe this is possible... and its not a fault or shortcoming of UltraEdit as much as it is the way OSX is designed...

May I ask under what circumstances you need multiple copies of the program open? You do realize you can edit dozens of documents at the same time within a single running copy of UE...right?
gillopez wrote: How can I open multiple copies of ultraedit?

It's designed to open as a singleton and use tabs to display the files. If you need to have multiple copies running (say that you have two monitors and want to keep a reference document open on one and edit on the other), then you can open a terminal and run

/Applications/ &

I'm not sure how wise this is, though. When I tried it looked like the copies weren't aware of changes that the other was making to settings or the recent files list.
I added /Applications/
to my .bashrc path env variable on my mac

Then tried "UltraEdit foo.txt &" in the mac terminal, which is something similar to what I would do if i was trying to use UltraEdit that was on a linux box and I wanted to open the UEX gui and display it on my windows machine via ssh.

For example when I use ssh to log into a linux server from a windows machine and I want to use the linux ultraedit from there to edit/create a file;
I would do something like [from ssh] "setenv host_ip"... i forget the exact syntax off the top of my head
Then uex foo.txt &
That would pop up the linux gui on my windows machine and I could fiddle with the file to my heart's content. Also the prompt was released and could keep working in the terminal, or I could open up a new file in the existing UltraEdit session as a tab (i.e. "uex bar.txt &" would have foo.txt and bar.txt in the same UltraEdit instance with both files having their tabs.

However, when I try the same thing with Mac;

1. The prompt doesn't release. If you use <control>+C. The prompt is released, but if I want to open up another file in the session...well "UltraEdit bar.txt &" doesn't do that. It opens up bar.txt as a separate UltraEdit instance.
2. For some reason, it doesn't recognize the version as registered (as opposed to if I would launch it from the docking bay).
3. I get the below error.

2011-10-18 00:32:17.641 UltraEdit[510:707] CFURLCreateWithString was passed this invalid URL string: '/System/Library/CoreServices/CommonCocoaPanels.bundle' (a file system path instead of an URL string). The URL created will not work with most file URL functions. CFURLCreateWithFileSystemPath or CFURLCreateWithFileSystemPathRelativeToBase should be used instead.

Any help with any/all of the 3 things to make it work like the linux exectuable would be greatly appreciated!!!!
4 posts Page 1 of 1