User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
4 posts Page 1 of 1
Good Day

My group just purchased a 10 user license for UltraEdit and UltraCompare and it appears that some of the ignore options are not working as I would expect.

I have 8.00.0.1010 installed and I tried to set UltraCompare to ignore lines that contain UTC, an example line is shown below. I've tried to ignore lines containing "UTC" and lines ending "UTC:", but when I perform a compare these lines are still marked as being different.

Am I missing something?


WED NOV 10 19:10:30 2010 UTC:
Where do you have added "UTC"? In Options - Configuration - Ignore Options - Text or in Session - Session Properties?

The settings in the configuration dialog are the default settings for new text compare sessions, but not for the active text compare session.
Best regards from Austria
I had it set in Options - Configuration - Ignore Options - Text and tried to restart a couple of times and it never picked it up.

I just now set it under Session - Session Properties and hit the Go button and it works as expected.

Any idea why the default settings for new sessions is not getting picked up?

Hmmm, it appears that after I set it once under Session - Session Properties and restarted that the settings in Options - Configuration - Ignore Options - Text are being picked up.
I entered "UTC" in Ignore lines which contain at Options - Configuration - Ignore Options - Text, closed the dialog with OK, exited UltraCompare and started a new text compare session by selecting two files in file manager, right clicking to open context menu and clicking on Run UltraCompare with the two selected files. The ignore option worked fine and I could see them also in Session Properties dialog. Also changing "UTC" in the configuration dialog to "XXX" and using Session - New Session - Text Mode resulted in taking over the changed default ignore settings for the new text compare session while the still opened first text compare session still ignored "UTC".

Note: By default the setting Reload sessions previously open on startup at Options - Configuration - Sessions is enabled and therefore exiting UltraCompare after changing the ignore options in the configuration dialog and just starting UC again with the shortcut on desktop or in start menu has no effect on the ignore options on the reloaded session(s). So if you change the default ignore options in the configuration dialog, you have to really start a new compare session via context menu in your file manager, by starting UC from command line with the files to compare, or using command New Session without or with closing first active session.

Just restarting UC with Reload sessions previously open on startup enabled does not result in using changing default ignore options. And if only a single text compare session is loaded and just switching the compare mode for example to Binary (Fast) Mode and immediately back to Text Compare in menu Mode does also not result in using modified default ignore options.
Best regards from Austria
4 posts Page 1 of 1