User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

A place for users to discuss the Linux-based version of UltraEdit, UEx
7 posts Page 1 of 1
Hi,
try to install UE on a fresh XFCE 4.8.0 Xubuntu. An error occurs,
Code: Select all
dependency is not satisfiable: libboost-regex 1.34.1-2.1 

which packages I need?
cheers
I do not have a "fix". I have additional information:

UEX install on Ubuntu 10.04 on amd64 hardware, using uex_2.1.0.5_amd64.deb :

dpkg: dependency problems prevent configuration of uex:
uex depends on libboost-regex1.40.0 (>= 1.40.0-1); however:
Package libboost-regex1.40.0 is not installed.
uex depends on libicu42 (>= 4.2-1); however:
Package libicu42 is not installed.
uex depends on libnspr4-0d (>= 4.7.3-0ubuntu1~); however:
Package libnspr4-0d is not installed.
dpkg: error processing uex (--install):

These packages ARE installed and should satisfy the requirements :
libboost-regex1.42.0
libicu42 4.2.1-3
libnspr4-0d 4.8.7-0ubuntu1

but the system doesn't seem to like them.

Any suggestions?
Lubuntu or Xubuntu (10.4 - 11.04)
the same error occurs:
Error: Dependency is not satisfiable: libboost-regex1.40.0 (>= 1.40.0-1)
the pre-installed version is:
libboost-regex1.42.0 ???

could you please fix this issue? :|
I'm having a related problem with Ubuntu 11.04 and uex_2.1.0.5_amd64.
Installing using dpkg -i I get this message:

uex depends on libicu42 (>= 4.2-1); however:
Package libicu42 is not installed.

libicu44 (4.4.2 something) is what is actually installed by ubuntu 11.04 on my machine. If I use the .tar.gz version and simply untar and stick it in the /opt/uex directory it will run but odd things happen. File and project menus disappear and won't come back without having to have the original files recopied (reinstalled) and some other strange behavior (no idea if this is related or not).
Same exact problem on linux mint 11 kataya
2.6.38-10-generic

amd64
I was able to resolve the libicu42 dependency on Ubuntu 11.10 using

wget http://mirror.pnl.gov/ubuntu//pool/main ... _amd64.deb
sudo dpkg -i libicu42_4.2.1-3_amd64.deb

On 32 bits system probably this one is needed instead: http://mirror.pnl.gov/ubuntu//pool/main ... 3_i386.deb

BTW, I found these links on http://www.filesharenews.com/2011/09/26 ... ntu-11-10/
I had this problem a while back and had the same problem with some other software as well.

The solution that worked for me was to install ia32-libs-multiarch.

I'm actually running Mint 12 (based on ubuntu 11.10) on amd64 hardware. Ubuntu claims that 11.10 doesn't have to have the ia32 compatibility libraries installed in most cases. This apparently isn't 'most cases'. Neither is Skype, wicd, or half a dozen other pieces of software that didn't work after I made the move to 11.10, the 3.0 kernel, and Gnome 3.
7 posts Page 1 of 1