User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
7 posts Page 1 of 1
Is anyone using column with Unicode characters in UTF-8 encoded file?

I unable to enter Russian letters in this case even in UltraEdit version 17.
Symbols with code point value 32 to 127 have no such problem.

UTF-8 encoded file with column mode active:

Code: Select all
----- DK20?@>;4 -------
----- DK20?@>;4 -------
----- DK20?@>;4 -------

What I expect to see:

Code: Select all
----- фывапролд -------
----- фывапролд -------
----- фывапролд -------

:cry:
I can see your Russian text stored in a UTF-8 encoded file in normal and column edit mode without any problem using Courier New for both editing modes.

I suppose you have set a different font for column mode editing in comparison to normal editing. Set a non proportional font at View - Set HEX/Column Mode Font which supports Unicode characters too.

There are two font settings because for normal editing a proportional font like Arial could be also used which can't be used in column mode or in hex editing mode.
Here is video explaining the problem

http://mendmaster.dyndns.org/4idm/UEdit ... deUtf8.swf (~4Mb)

>I can see your Russian text stored...
I can too. But I am unable to type them in column mode :cry:
Sorry, I don't have installed Shockwave player and therefore can't view this video and I don't want to install it just for helping you. Perhaps somebody else can help you finding out what is configured wrong. Or you contact IDM support by email for help.

But perhaps you try first following:

  • While no instance of UltraEdit is running, copy %APPDATA%\IDMComp\UltraEdit into the address bar of Windows Explorer and hit key RETURN to open this directory.
  • Rename file uedit32.ini to uedit32_bak.ini
  • Start now UltraEdit which creates a new uedit32.ini with every configuration option set to default. You will see the dialogs you usually see only on first start after a new installation or an upgrade.
  • Now open your UTF-8 file, enable column mode and test what happens on entering Russian letters.
If everything is working fine, the problem was caused by a wrong configuration and you can either try to find out which one by comparing new created uedit32.ini with uedit32_bak.ini, or you just take over what you need from the backup file (user tools, scripts, etc.) and use the new version of the INI file.

If you use the Clear History button in Toolbars / Menus - Miscellaneous configuration dialog, close UltraEdit and upload uedit32.ini packed with ZIP as attachment to next post, I can maybe also find out what could be the problem. Alternatively attach the INI file to email to IDM support.

By the way: Do you use English UE v17.10.0.1010 or a different version?
I've just downloaded latest UltraEdit, have removed %APPDATA%\IDMComp\UltraEdit, and installed it.

Here is sequence of images showing steps: http://mendmaster.dyndns.org/4idm/illustrations.html
You may see it with out any evil Macromedia flash player.

But result is the same :cry:
Instead of letters "абвгдеёжз" I have column with letters "012345Q67".
I followed your steps and needed to install Russian keyboard driver and enable it for UltraEdit to be able to enter Russian characters, but I could reproduce the problem now. This is definitely not a configuration problem. This is a problem in source code of UltraEdit. For Unicode files the script setting of the display font respectively the code page setting for the file are not important.

Pressing on a German keyboard the keys qwertzuiopü results with a Russian keyboard driver in entering the Russian characters йцукенгшщзЯ. Pressing these keys in column editing mode with multiple lines selected, the result is 9FC:5=3HI7/ which is definitely wrong. If just column mode is enabled without selecting multiple rows, the characters are correct inserted.

The string йцукенгшщзЯ is coded with Unicode (UTF-16 LE) as

39 04 46 04 43 04 3A 04 35 04 3D 04 33 04 48 04 49 04 37 04 2F 04

The wrong string entered in column editing mode with multiple lines selected is coded as

39 00 46 00 43 00 3A 00 35 00 3D 00 33 00 48 00 49 00 37 00 2F 00

It is quite easy to see what fails in UltraEdit. The high byte is omitted in this case resulting in inserting wrong characters.

Unfortunately selecting the lines with column mode on and using Column - Insert/Fill Columns can't be used as workaround because the result is even worser. For the string йцукенгшщзЯ copied into the dialog UltraEdit inserts ??????????.

Please report these issues by email to IDM support because that are bugs which the developers of IDM must fix.

A working workaround: Enter the string you want on multiple lines first just on one line (in normal edit mode or column mode). Select the string and copy it to clipboard. Enable column mode if not already enabled, position the caret on first line where you want to insert this string too, press Ctrl+V. The caret position does not change. Press key DOWN and again Ctrl+V and continue this key sequence up to last line. That's definitely not how column mode editing should work. But until the IDM developers have fixed Unicode multi-line column editing and Inserting/Filling columns with a Unicode string, it is the only workaround I could find quickly.
This issue is fixed with UltraEdit for Windows v24.00 and UEStudio v17.00. Insert/Fill Columns works now also for Unicode strings inserted into Unicode encoded files.
Best regards from Austria
7 posts Page 1 of 1