User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

A place for users to discuss the Linux-based version of UltraEdit, UEx
2 posts Page 1 of 1
I am running Mepis 11 with KDE and I have set up the menu item for UEX to load any files I select and right click via the following command:

Code: Select all
uex -- %f

This does not work there, nor does it work from the command prompt when feeding it a literal file. I generally have to drag and drop the files into UEX unless I want to go through the open dialog box.

Is anyone else experiencing this issue?

I had previously tried "uex %f", "uex %F", "uex %U".

The last parameter is what Kate and KWrite uses.

I got the idea to use "--" from UltraEdit for Linux Command Line Support

I'll keep trying to get it working.

Thanks.
Solved!

With the help of Troy from IDM, I found the issue.

I had used the IDM page instructions except that I installed to /usr/local/uex/ and created the new uex file in /usr/local/bin/.

Instead of the suggested uex shell script file contents:
Code: Select all
#!/bin/sh
export UEXROOT=/usr/local/uex/uex_2.3.0.9
$UEXROOT/bin/uex.bin

I read the bash shell scripting manual and changed the above to this:
Code: Select all
#!/bin/bash
export UEXROOT=/usr/local/uex/uex_2.3.0.9
$UEXROOT/bin/uex.bin $@

I was missing the $@ for any parameters that I pass to UEX.
2 posts Page 1 of 1