User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Project, workspace, and file management issues
4 posts Page 1 of 1
Hi Folks,
I'm using UltraEdit 17.30.0.1002. Combined with Windows XP everything works fine. But after installing it in a fresh Windows 7 environment my project tools stopped working. The Working Directory setting does not have any effect.
Either with Project Tools (Advanced/Project Tools Configuration) or with F9 (Advanced/Dos Command...) ...
regardless what I enter, the execution always starts in C:\
I've spend the last few hours searching the internet but didn't get any further. I hope someone of you can help.

Thanks in advance and regards,
Golo.
I don't have a computer running with Windows 7. So I can't verify if the working directory specification of a project tool is not working at all on Windows 7 in UE v17.30.0.1002. It might be helpful when you post what your project tools have defined exactly as working directory.

Most common mistake is to define the working directory with double quote characters. That does not work. In comparison to the command line where double quotes are necessary for file names and parameter strings with a space inside, the working directory must be always defined without double quotes even when the path contains a space character.

I suppose you call with your project tools console applications (real 16-bit DOS applications are rare nowadays) and not Windows GUI applications. So UltraEdit uses UEDOS32.exe. Do you have a 32-bit or a 64-bit Windows 7 computer?
Hi,
thanks for the answer. I'm using the windows 7 32bit OS.
Meanwhile I found out, that it's somehow my "local" problem. On an other machine the same set up works fine.
On my PC, when I press F9 and try to execute dir in c:\windows (or wherever else ;) I only get the listing from c:\.
Now I just ;) need to find out, what's the difference between my system and the other one.

regards,
Michael.
Hi,
I've finally sorted it out. And, just in case someone of you runs into the same trap ;) here comes the explanation:

I don't know how (and for sure not by intention), an 'autorun' key appeared in the registry under
HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor. This key had the value 'c:\ && cd\'
So, no matter what any user (and any software, including UE ;) set as a 'start in' entry, the shell always started with c:\.

After removing this key everything works as expected.

Regards,
Michael.
4 posts Page 1 of 1