User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

A place for users to discuss the Linux-based version of UltraEdit, UEx
8 posts Page 1 of 1

I am evaluating the latest,, 64bit tar version of UEX in RHEL, but an earlier version than you offer binaries form.

I am running it via Cygwin/X.

Copy and paste within UEX works fine. But copying from Windows and pasting in UEX and/or copying in UEX and pasting into Windows works intermittently at best.

I don't think it is a problem with my X environment because if I use jEdit (also running under X) copy and paste in app AND in and out of Windows works flawlessly. Similarily, when I copy and paste in and out of Firefox 3.6 which I have running under X it works without a problem.

Any help you can suggest would be greatly appreciated.

Most common reason when copying to other applications suddenly does not work anymore on any platform is that the user of UltraEdit has switched to one of the 9 user clipboards by key. Open Edit - Clipboards and check with clipboard is active. You can customize the hotkeys for the commands and remove the hotkeys from the commands switching to the user clipboards to avoid a switch by mistake in future.

See also the answer on frequently asked question Why does copy and paste sometimes stop working?

If the standard clipboard is active and copying text to another application nevertheless does not work, there must be another reason why it fails.

Please reply and tell us if the problem was caused by switching to one of the user clipboards.

I should have mentioned in my original message, I am aware of the multiple clipboard feature and use that. The first thing I checked on UEX/Ultraedit that the issue wasn't having the wrong clipboard selected. I rebooted my system this morning and tried again. My steps this morning were

  1. Start UEX
  2. Verify the clipboard is set to System Clipboard in UEX. In fact, to double check I changed to User Clipboard 1 and then back to System Clipboard.
  3. Copied some text.
  4. Pasted into another UEX window, no problem.
  5. Try to paste into UltraEdit/Windows (verifying System Clipboard is selected), nothing
  6. Try to paste into SecureCRT (my terminal program of choice), nothing
  7. Return back to UEX, paste works fine.

  8. Copy text from UltraEdit/Windows (verifying System Clipboard is selected)
  9. Paste into UEX, worked fine.
  10. Copy text from SecureCRT paste into UltraEdit/Windows, fine
  11. Paste that same text into UEX, NOTHING
  12. Copy the text from UltraEdit/Windows that I pasted in #9, paste into UEX, fine.
  13. Copying from Chrome. If I copy JUST TEXT, it will paste into UEX.
  14. If I copy something from Chrome that is more than text, often it won't paste into UEX.
To sum up: I have verified I am only using System Clipboard. Copying text in UEX only seems to allow for pasting in UEX. Copying from elsewhere will, in some cases, paste into UEX but sometimes not. All of the cases where text would NOT paste into UEX, it WILL paste into UEX.

My partial theory: When I paste into UltraEdit/Windows, any "non-text" stuff will be stripped out, so, often I have text with lots of formatting, etc. and I use paste into UltraEdit and re-copy to strip all the formatting down to just characters. I speculate that whatever UltraEdit/Windows is doing to strip out special stuff is tripping up UEX and when UEX sees these special things on the Clipboard, it refuses to paste. As to why when I copy FROM UEX it will never paste anywhere except UEX, I don't have a theory. Perhaps it is putting the data on the clipboard in an odd format that other programs see and assume they cannot handle for pasting.

It looks like you think the Windows Clipboard is a simple data buffer, but that is not true as you can read on Microsoft Developer Network article Clipboard Formats. UltraEdit supports all standard text formats and the formats for RTF and HTML formatted text.

I'm not using UEX nor Cygwin and therefore don't know how Cygwin interchange the data of the Linux system clipboard with the Windows clipboard. You might search for issues with data exchange via the Linux / Windows clipboards on using Cygwin. I entered in a WWW search engine cygwin windows linux clipboard and found lots of articles. You should do that also and look if there is anywhere an article which could be helpful on this problem.

If you can't find something helpful and no other user replies to this topic within the next 2 weeks I suggest to contact IDM support by email and ask for help. Your problem is definitely something very special.
I use UEX on RHEL 5 via Cygwin/X and also cannot copy from UEX back to Windows. If I want to do this so I can paste into an Outlook email I end up opening the file in Nedit. Copying from UEX to Windows has worked once or twice but I can never figure out what sequence of events made it work. I don't remember if I've ever reported this to IDM.
I'm running the latest version of UEX (v3.0.0.11) on RHEL 6.2 using GNOME and I'm facing the same problem (using the System Clipboard) when trying to copy text from the editor to a shell window (neither shift-ins nor ctrl-v nor middle-mouse works) or to an RDesktop session what is really a pain. I'd really be happy to get that working. Any advise / recommendations are deeply appreciated.

Thanks in advance!
I have also found something fun. I installed Parcellite to troubleshoot this and see for myself. If I double-clicked a word in UEX and did a right-click copy or ctrl-c it will not copy. If I actually select the word it will copy the word to the clipboard. Go figure. I watched the clipboard manager and checked to verify this.
The copy function seems to work better after the update to currently latest version
8 posts Page 1 of 1