User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

A place for users to discuss the Mac-based version of UltraEdit.
6 posts Page 1 of 1
The company I work for all use UltraEdit, though I'm the only one using UltraEdit on a Mac.

They've created their own template lists. I've tried to import using their instructions, but have been unable. I'm chalking it up to PC/Mac differences, but I wonder if a template file created for an UE running on PC is a different format than one that can be used on UEM. Does anyone have success in importing PC-created UE template files?

Secondly, if created own template (if push comes to shove, I'll just manually create all 100+ templates on my own), can you set a keyboard shortcut? I've found the keyboard shortcuts, and have made some of my own for HTML formatting, but I can't seem to find the templates entered in the keyboard shortcut dialog box anywhere. Would it come up as Template? Would it come up as the title? Again, if anyone has success, please share.

If I figure it out, I'll post a how-to.


(OSX 10.7.3 UEM
I apologize! I have easily figured this out.

I was putting the UETMPLT.dat file into the WRONG folder. I was going to Applications > UltraEdit> Show Package Contents > and dropping in Resources. I was incorrect. I had to go to user/Library/Application Support/UltraEdit. This is the correct way to do this. My apologizes if I'm confirming something that's already common knowledge.

In terms of mapping to custom templates, in Key Mapping, you just select User Template 0-9.

Unfortunately, this brings me to my new 'issue.' Is there no way to define a custom hotkey for templates 10 and up? I know there's a way to do it in the Windows UltraEdit (my coworker custom added InsertUserTemplate 11,12,13...... I can't figure out how to do this on a Mac?
It looks like UEM uses the same binary template storage file as UltraEdit for Windows up to v17.30.0.1016.

Starting with UE v18.00 an XML file is used to store templates (binary file on upgrade automatically converted) because the templates feature has been greatly enhanced to smart templates feature. I'm quite sure that this enhancment can be found sooner or later also in UEM.

In UltraEdit for Windows the directory containing UETMPLTE.DAT (binary for UE < v18.00) or UETMPLTE.TPL (XML for v18.00 and later) can be configured in Directories configuration dialog. If nothing is entered by the user, the application data directory is used by default.

The application data directory is on Windows %APPDATA%\IDMComp\UltraEdit and according to your post on MAC user/Library/Application Support/UltraEdit.

In UE for Windows the key mapping configuration dialog contains the commands InsertTemplate0 to InserTemplate49. If you don't see up to 50 insert template commands in key mapping configuration dialog of UEM, the number is more limited than on UltraEdit.

Prior UE v18.00 the number of templates was limited to 50. With UE v18.00 and later there is no limit anymore, but hotkeys can be used only for the first 50 templates in global template file. All others (environment and language templates) can be inserted with new auto-suggestion feature, auto-completion window now listing also templates with matching names or via the now hierarchical Template List view.
It looks like there are no InsertTemplates whatsoever. So there is no way to assign hotkeys to more than 10 user templates?

I'm also seeing User Tool and User Project Tool, 0-25. Can these be used instead of templates? Do they act the same way? If not, what is the best way to contact 'support' to let them know that us UEM users need more than 10 user templates to assign to hotkeys!!
User tools are for configuring external programs or scripts to integrate with UE. So, no.

You can contact support using the link at the top of the forums where it says, "you must email us directly". The "email us directly" part is a link to the email address.

The email is support at, converting at as appropriate of course.
Thanks Rhapdog.

I believe it may be an issue with my UEM. I just sent an email to IDM Support. I have a whole new issue now. Laying it out below in case anyone can help/experienced the same issue:


I was running into the issue that I'd set templates up, add them manually, up to about 20, then set the hot keys for the 10 that I can. When I quit UEM and then reopened, all the templates were gone. I did this about 3 times before I thought maybe there was an issue with the UETMPLTE.DAT file. So, I tried to open, reenter the templates, and before closing, opening up the user/Library/Appliation Support/UltraEdit file and creating a copy of the UETMPLT.DAT file, saving it on the desktop. Opened, UEM, no templates. Closed UEM, opened the UE file, dragged the backup copy into the folder, replaced the current one, and opened up UEM. Nada.

So, I deleted the UE app, deleted the UltraEdit Application Support file, and redownloaded, reinstalled. Opened the app, no templates. Checked the UE file in Application Support file, no UETMPLTE.DAT file at all. Decided maybe this is how it started: with no file. Added my templates, checked the folder agin, there it was. Voila! Problem fixed! Or so I thought. Closed UEM, opened UEM, no templates. Template file is still there.


Anyone else ever have this problem? Templates just don't seem to want to work with my UEM/machine.

Again, running UEM, and OSX 10.7.3. This is a 2010 MBP that just had the OSX completely reinstalled.
6 posts Page 1 of 1