User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
11 posts Page 1 of 1
Dear all,

In my main menu of UCm (v8.50.0.1018) the session menu is missing. So I can't do session->new session. How can I get it back?

With kind regards.
Click with right mouse button on the main menu and click with left mouse button on context menu item Manage Menu Configurations. Use the button Reset to restore the default menu. Then you can again customize the main menu if you want to do that.
Thank you for your reply. I did it but that doesn't work. Still no session menu. I think there is something wrong with the menu. When I start UCm I get the error

"The menu file is out-of-date. UCm will update it now"

But I get it every time I start UCm. Maybe it has something to do with it.
The directory containing the menu profile file and also other setting files of UCm is perhaps write-protected or just the file has read-only attribute set. Check write permissions of the directory and the file attributes.

I cannot tell you where the configuration files are stored by UCm as I'm using UC Professional for Windows. The menu profile file has the file name UCMNCmdsW32.mcf. You can search for *.mcf in all directories including those with hidden attribute to find the file and check its attributes and permissions.

It's also possible that there is a file system error on the storage media on which the menu profile file is stored. Run the command

chkdsk drive letter: /f

to let Windows check the file system and fix errors automatically. Information about the chkdsk tool can be found in the Microsoft article How to perform disk error checking in Windows XP. CHKDSK is also available on Windows 7 and just needs to be executed as administrator like on Windows XP.
Ok I looked at the attributes. The folder properties keep read-only, but it has the comment (only applies to files in folder) so I think that's normal. The files itself are not write protected. When I remove the file UCMNCmdsW32.mcf the file is created again, when starting UCm, but the file is empty.

This is realy strange because the file itself is created so I think it's not a permissions problem. I'm I right and what could cause this?
Be careful with advanced NTFS permissions. It is possible to define the permissions so that a file can be created in a folder and read, but updating file content is denied after initial creation, write and save. It is also possible to define the permissions in a manner that an application can create a file and also append data to a file, but cannot delete the file completely and recreate it once it exists.

Give the directory and all files and subdirectories full read/write permissions and the problem should be solved.

If you want to see why UCm fails to update/write to the file because NTFS denies some file accesses, you can use free tool Process Monitor from Sysinternals (Microsoft) with Filter configured to Path begins with full path of the directory then Include.
Ok, but my file system is FAT32. All files have read permissions. When I look with process monitor all calls to UCMNCmdsW32 are succesful of "END OF FILE".

Does these permissions also hold for FAT32?

I focus on the files UCMNCmdsW32. I think thats what you mean. I don't see strange things on other files.

B.t.w. I use Windows 7 enterprise and I set all UAC to disabled.
FAT32 file system does not support any permissions. If you right click on a directory on a FAT32 partition and choose Properties, there is no tab Security. If you see a Security tab for the directory containing the UCm configuration files, the drive is formatted with NTFS. You can right click also on the root of the drive, choose Properties and see on tab General the file system of the drive.

I logged with Process Monitor the file accesses on this file by UC Prof. v8.50.0.1017 if it is not present and on a Windows 7 x64 computer, see the attached CSV file (deleted later). It is interesting to see that UC writes and reads the file several times. It does this also if the file already exists on startup. Very strange. I will report this to IDM support by email as I don't see any reason to read and especially to write the menu profile file if already present and is up-to-date several times during startup.
Thanks I was already wondering the I didn't have a security tab. So that's right because I work with FAT32.

There is also something strange. When I remove the file and I start UCm the file is generated and 36KB in size before clicking away the messagebox "The menu file is out-of-date.....". Clicking on Ok the messabox disapears and the file becomes empty again ( 0KB ).

Making a copy of the file ( 36KB ) close UCm then rename the file to what is should be. Then open UCm again the file is set back to 0KB.

So I'm lost about how to solve this.

My logs are in the attachted file (tab separated and later deleted). Splitted before clicking away the messagebox and after.

I'm I right that the problem is now by the IDM support team and will I hear about it also (only on this forum or do I also make a request)?
It is really interesting that UC Portable just writes initially 36.546 bytes to the file while UC Professional writes 147.794 bytes.

And it is definitely an error that UCm creates the file after clicking on OK of the message box and immediately closes it resulting in a file with 0 bytes.

You should report this issue to IDM support by email. I think, you can't fix this problem.
Thanks for your great help. I reported it to the support desk and they could reproduce.
11 posts Page 1 of 1