User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Syntax highlighting, code folding, brace matching, code indenting, and function list
6 posts Page 1 of 1
Hi

I found that the syntax highlighting is not working correct on some Unicode words on editing a UTF-8 encoded *.cpp file, but other Unicode words are highlighted correct.

What can I do to make the left bracket or left brace syntax highlighting correctly?
Are ( and ) both listed in the wordfile on the line starting with /Delimiters = ?

And is the wordfile an ANSI file with DOS line terminators?

The wordfile cannot be encoded in any Unicode format. So words with Unicode characters cannot be defined in the wordfile.

If the parentheses are defined as delimiter characters and the wordfile is an ASCII/ANSI file with DOS line terminators, you should report this issue to IDM support by email with attaching in a ZIP file the wordfile, the example file opened in UltraEdit and the PNG screenshot. Write also which font you have set as display font.
I use all the setting by default did not change anything, and I have tried every syntax to display my file for example C/C++, Python, and have tried to change my file into different format. It all has the same error not only parentheses but other delimiters.
I cannot reproduce the issue exactly as your already deleted screenshot shows using your CPP file, but the syntax highlighting is nevertheless not correct as it highlights also some Unicode characters with a color not being normal text color which should not be highlighted.

As this is a user-to-user forum and I'm also just a user, you need to report this issue by email to IDM support as stated at top of every forum page. Click on email us directly.
I have reported this to IDM support by email and they have confirmed it. This error only occurs when you set your Windows system language to Chinese or other Unicode language.
The issues with wrong syntax highlighting of Unicode encoded files were fixed with UltraEdit for Windows v24.00 and UEStudio v17.00.
Best regards from Austria
6 posts Page 1 of 1