User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
10 posts Page 1 of 1
I recently upgraded to UEStudio v13.10.0.1004 and found my windows clipboard integration is broken. I can copy from UES to the windows clipboard, but not paste from the windows clipboard. I have tried switching from to a user clipboard and back, with the same results. I can copy / paste to / from a user clipboard but not the Windows Clipboard (Ctrl-0) (Edit -> Clipboards -> Windows Clipboard).

I am running UEStudio on Windows 7 64bit.

Has anyone else encountered this difficulty?
I am using UEStudio v13.10.0.1004 as well, on Windows 7 Ultimate 64-bit.

I am unable to reproduce the issue you describe.

You may want to look at the topic, Copy command sometimes stop working. The last few posts in this topic point to a possible culprit and solution.

It could be an antivirus, or it could be a browser issue. Check the thread and see if it helps. It talks about the paste command stopping working.
To clarify the issue a bit:

It is not a copy issue. I can copy text from my UEStudio window and paste it into other applications (like notepad). However if I attempt to paste the text into the same window or even a new Edit window, it fails using both the Ctrl-V (not mapped to any macro) OR the Edit -> Paste menu command. As soon as I switch to a User Clipboard, Ctrl-C + Ctrl-V works as expected. It seems to be some issue when pasting from the windows clipboard, regardless of the text format.

This was not an issue prior to the upgrade. I regularly copy from other applications into UEStudio so use this feature a great deal.

I did a complete re-install and still get the same result.
You didn't read my entire post. The topic I pointed you to doesn't talk about just copy, it also talks about where copy continues to work and paste stops working.
I did read your entire post and read the mentioned link. I tried many of the suggestions that pertained to paste issues. None of those suggestions have helped so far (Hence me mentioning that the text formatting didn't make a difference). The simplest test is to try copy and paste from a new edit window. Windows clipboard does not work, but the user clip boards do. I will continue to try and figure out the issue. I even ran system file checks for file errors as suggested in other online posts related to copy / paste issues (the system file check command: "sfc /scannow"). I have tried many other applications and none of them exhibit this behavior. I have verified no macro commands are intercepting the Ctrl+V or even the EditPaste command from the window. I have checked that I don't have any other suggested applications running that might intercept the paste command. It smells to me like a strange permissions issue, but have not been able to verify it. It could also be a bad windows clipboard hook due to some registry setting that I have not been able to locate.

The one thing I was reluctant to try was the AutoHotKey solution. I didn't want to try and muddy the waters by installing additional software.

If I do locate the culprit I will be sure to reply and inform all who may suffer the same issue of my fix.
Alchemys wrote: It smells to me like a strange permissions issue, but have not been able to verify it. It could also be a bad windows clipboard hook due to some registry setting that I have not been able to locate.

Come to think of it, I do have UAC turned off. Not sure what difference that would make, but perhaps a quick test on your end would verify if that is the culprit. If so, it would need to be corrected by IDM. I really don't see that being the issue, however.

As far as the bad windows clipboard hook, that's a possibility, depending on what other software you have installed.

Alchemys wrote: The one thing I was reluctant to try was the AutoHotKey solution. I didn't want to try and muddy the waters by installing additional software.

AutoHotKey has been valuable to me for so many things I cannot count them all. However, it's not a solution to this problem, it is a workaround. I'd rather we fix the issue and not just find a workaround.

Alchemys wrote: If I do locate the culprit I will be sure to reply and inform all who may suffer the same issue of my fix.

That would be great.

You may want to contact IDM Support by email. Link to their email at the top of the forums. They don't regularly monitor the forums, so a heads up to them may give them the opportunity to assist you in resolving the issue, which, you could in turn report back to us.


If you're going to go with a workaround for now, I would suggest something besides the AutoHotKey, because I find the tool so valuable in every day pasting, especially when I copy something from the internet, and need to paste it into an Office product, and I don't want the HTML, just plain text. It's called "Paste Like Text". It's a simple utility that sits in your system tray, and any time you want to do a paste, use the Windows Key + V instead of Ctrl+V, and you get a menu to select how you want it pasted, whether as plain text, text that mimics typing (slower), convert to upper case, convert to lower case, Proper Case (like titles), or it can invert the case of the text you've got copied (like when you had the CAPS lock on and didn't realize it, you can copy, then paste back inverted.)

You can get the tool from https://sites.google.com/site/pastetextlike/
I will check out the paste like text tool. Thanks for the heads up on that one. I actually use UEStudio often to "sanitize" text to make it plain text without the formatting for exactly the same reasons. Sometimes I want to have word apply the existing formatting instead of adopting the formatting from the source document.

I will also send an email to IDM as well, thank you!

The matter has been forwarded to developers to see what may cause this behavior. I have been trying to further isolate the condition, but have not found any way to get the windows clipboard to work with UEStudio. I am tempted to write my own application to play with the windows clipboard just so I can see what it takes to move text into and out of the clipboard. I might be able to find a sticking point in my own code that leads me to the solution for UEStudio.

I have isolated it to some application that becomes active when I launch a browser. I'm attempting to isolate the application or plug-in now. If I shut down all browsers, the problem goes away. I have been running the Clipboard Format Spy and the problem only exists when applications put all the text into CF_OEMTEXT instead of CF_TEXT. Apparently UEStudio does not look for text in CF_OEMTEXT and ONLY in CF_TEXT. When I shutdown all browsers (I have tested Firefox, Chrome and IE), text gets placed into CF_TEXT normally, and suddenly the windows clipboard works fine. I'm not sure why text copied from within UEStudio itself does not go into CF_TEXT, but I'm guessing it's some service / application that is intercepting the text prior to it hitting the clipboard that only exists when a browser is running. There is also some time based element to this. After a while it does not matter if the browser is up or not, the text always goes into CF_OEMTEXT and CF_TEXT is null. Apparently something gets loaded and then does something stealthy that prevents text from going into CF_TEXT. I am pretty sure it's not malware, but have not ruled that out either. I will continue to update as I find out more information.
I have conclusively isolated the offending application. It's the Webroot Secure Anywhere, malware protection application. I have had this application for a while so am not sure why it suddenly started "behaving" badly. It could be a recent update or some setting I activated recently. If I shut down this application, the clipboard functionality returns to normal. I will be taking this issue up with the Webroot folks since I think it's bad form to prevent applications from writing properly to CF_TEXT or CF_UNICODE text when they allow CF_OEMTEXT with no problem. I suspect a bug on their part.

I had not looked at this application closely before since I have been running it for some time now without an issue. It took some tedious application removal, application shutdown experimentation to isolate this as the culprit. I hope this helps anyone else that may encounter this particular problem in the future.
Thank You!!!!

I installed UltraEdit 21.20.0.1014 on 3 laptops today. Worked fine on 2 of them, but on one I had the same issue of the PASTE command not working with the Windows clipboard selected and trying to copy / paste within UltraEdit.

Been scouring the Net seeking solutions and what you discovered "WSA" was the culprit on mine also. Strangely I have Webroot Secure Anywhere on all 3 laptops and it isn't causing an issue on the other 2 laptops, but it is indeed the problem on this one laptop. After temporarily
disabling WSA UltraEdit's PASTE function is working properly now.

Next I'm going to see if I can find the precise blocking problem in WSA.

Thank you again!
*** FOLLOWUP ***

Here is the FIX for the UltraEdit Copy / Paste problem:

  • Open Webroot Secure Anywhere Control Panel

  • On the right side middle click the settings button for IDENTITY PROTECTION

  • Go to the APPLICATION PROTECTION tab

  • Scroll to the line with uedit32.exe respectively uestudio.exe and CHANGE the setting FROM DENY > TO PROTECT
Voila! Success!!
10 posts Page 1 of 1
cron