User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

A place for users to discuss the Linux-based version of UltraEdit, UEx
3 posts Page 1 of 1
In UEX, I can't use the mouse to select text. Positioning the cursor then clicking the mouse and attempting to drag over any text causes the entire UEX application to move (it's like the click is "grabbing" the entire UEX application and moving it's window in coordination with how the mouse is moving). I can use keyboard commands (position cursor, shift + arrow keys) to highlight and select text but not the mouse.

It's probably some KDE setting (although selecting/highlighting text works in every other application like kate, Thunderbird or DbVisualizer).

I'm using Kubuntu 13.04 64 bit.

Any suggestions for how to fix this would be greatly appreciated.
I'm using only UE for Windows which has the setting Disable drag & drop at Advanced - Configuration - Editor - Miscellaneous.

Does UEX for Linux have also such a setting in the Preferences which is maybe enabled?

If UEX has such a setting and the setting has no effect on the behavior with selecting text with mouse, please forget my post.

What I read in other forums is that Left Alt + Left mouse button is responsible for moving an application window instead of selecting text in the window. Perhaps this information is somehow useful for you and your problem.
Best regards from Austria
Thanks for your reply.

I found this post on an Ubuntu forum (Left click drag moves window in KDE, can I stop it; turns out to be a setting specific to the oyxgen theme) and nearly thought I had it solved... but no, this wasn't my problem either.

But your suggestion was excellent!

There is a similar setting in UEX (Preferences -> Editor -> Misc -> Disable Drag and Drop). After unchecking this setting and fully restarting UEX, click + dragging is now doing text selection just like expected. Thanks!
3 posts Page 1 of 1