User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

FTP, SFTP, FTPS, and SSH/telnet console issues
7 posts Page 1 of 1
Hi

I use UltraEdit Portable (v18), on a USB stick, and connect to various servers over SSH using UE's FTP component. I have just got a new Windows 7 PC in the office and on first attempting to connect to a server got the message about registering the FTP dll. I did that (in a command prompt as administrator) and it registered successfully, however I still get "Error connecting...".

Have tried rebooting UE and Windows but to no avail. Any ideas?

Thanks
Spencer
Do you have read FTP functions disabled in UEP / UE3 and followed the instructions by IDM?

The mistake you made was most likely doing the registration manually and using Run as Administrator as this registers not both DLLs and or not in HKLM, but in HKCU of local administrator account.

But I'm not sure that the "error connecting ..." message is caused by not registered FTP components. Usually the FTP features are disabled if not registered. So the error message is most likely caused by a real problem to the FTP server.

Have you executed once via Advanced - DOS Command the command ping yourftpserver.com to check if the network path to FTP server can be find out at all?

Or do you have a firewall running other than the Windows firewall which blocks also outgoing messages?

If only the Windows firewall is running, you need to allow UltraEdit to pass it for the data channel established from FTP server to your computer (incoming connection) after your computer establishs the control channel to the FTP server (outgoing connection), or you enable in the FTP Account Manager dialog on tab Server the option Passive transfers (for firewalls).
Best regards from Austria
Thanks for the reply. It is definitely not a problem with the servers I'm trying to access as I can access them in another code editor. I also have no problem using the same portable UE here at home. I am not in the office again until Monday, but will check out which registry keys have been set by my command line activity. You mentioned "both DLLs" - I thought it was just the one "wodFtpDLX.dll"?
swarhurst wrote: I thought it was just the one "wodFtpDLX.dll"?

No, there are 2 DLLs - wodCertificate.dll and wodFtpDLX.dll - and 1 OCX - wodTelnetDLX.ocx at least what I recorded on changes made in registry by installer of UltraEdit for Windows (non portable version).

But you do not need to register those 3 files manually via the command line. As IDM wrote in the topic I referenced in my first post, portable version of UltraEdit should have a command in submenu FTP/Telnet of menu File (or somewhere else as location is not mentioned in the post of IDM) to register the FTP/Telnet components. You perhaps need to start UEP as Administrator, but I'm not sure if this is necessary as I'm not using UEP. Of course the drive letter of the USB stick should not change as this would require a new registration of the files.
Best regards from Austria
Perhaps as part of any support request regarding this problem someone might suggest that IDM consider using registration-free COM binding techniques. Basically a manifest file deployed in the application directory can enable COM to find the DLLs without them being registered in the registry (the normal case for COM components).

See http://msdn.microsoft.com/en-us/library/ms973913.aspx

Registration-free COM is a mechanism available on the Microsoft Windows XP (SP2 for .NET-based components) and Microsoft Windows Server 2003 platforms. As the name suggests, the mechanism enables easy (for example, using XCOPY) deployment of COM components to a machine without the need to register them.

On the target platforms, one of the stages of initializing a process and its dependent modules is to load any associated manifest files into a memory structure called an activation context. In the absence of corresponding registry entries, it is an activation context that provides the binding and activation information the COM run time needs. No special code is required in the COM server or in the client...

It looks like it should be possible for an enterprising end-user to create an appropriate manifest that will do this. However, I'm not well versed enough to give this a try myself right now.
Mofi wrote:
swarhurst wrote: I thought it was just the one "wodFtpDLX.dll"?

As IDM wrote in the topic I referenced in my first post, portable version of UltraEdit should have a command in submenu FTP/Telnet of menu File to register the FTP/Telnet components.

There is no such menu entry (UEP v21.00)
OK, got it now thanks. I needed to register the SSH component via that menu option in UE portable.

Thanks for the help
7 posts Page 1 of 1