User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

A place for users to discuss the Linux-based version of UltraEdit, UEx
8 posts Page 1 of 1
Hello all,

I have the oddest issue, I am required to type every character twice to get the text to show up properly.

So, if I type "This" I get "hs"

I am running UEX Version 4.0.2.5 under Ubuntu server 14.04 LTS - 64-bit

Please don't hit me for installing gnome on a server :)

This was not an issue when I first installed UEX. So I am under the impression that I have fumbled some key combo to make this happen.

I have been using UE under Windows for over 10 years and I have never seen this issue pop up.

I attempted a few things to correct the issue but had no luck.

Has anyone seen this issue before?

Thank you in advance.
Do you have tried resetting the key mapping of UEX by opening Preferences - Key Mapping and clicking on button Defaults?

Further I suggest to check the hotkeys of scripts and macros.

Last check which keyboard is configured for input.
Best regards from Austria
Hi Mofi

Ya know. Those simple solutions are the embarrassing ones :)
Somehow I changed the keyboard config, or at least resetting it fixed the issue.

I should have thought of that.

Thank you.
Hi folks,

I experience the same problem on Lubuntu 14.04 (Trusty Tahr) x86 with LXDE and UEX 4.2.0.11. I have to type characters twice to get them written down. Resetting the Key Mapping to Defaults did not work for me!

When I run uex as root (gksu uex), the problem disappears, but this is no good solution for me. I tried deleting the .idm folder in my home directory, but also did not work. I also disabled my lxde shortcuts, but that also did not help.

I'm looking forward to any suggestions.

Kind regards,
Mike
DavidBurton fixed the issue with resetting keyboard configuration of Linux and not by setting hotkey configuration in UltraEdit to default.

As there is no problem with using another user account (root), there is most likely also a problem with keyboard configuration in Lubuntu 14.04 for your user account.
Best regards from Austria
Hi,

reconfiguring the Keyboard "in Linux" (dpkg-reconfigure keyboard-configuration) also did not work for me! In other editors like leafpad / jEdit / Geany everything works fine.

NOT SOLVED for me.
I'm 100% sure that the problem is not UEX, it is a keyboard configuration issue.

Also on Windows it is possible to use for application A keyboard layout X and for application layout B keyboard layout Y. And this change in input language can be done with a system wide hotkey. Pressing left Shift+Alt and leaving them without any further key pressed results in switching the input language for active application. I have read here that it is possible to switch also on Ubuntu the input language with left Shift+Alt if configured accordingly. My suggestion for solving switching input language by mistake is to simply remove all input languages (keyboard layouts) which should not be used to have finally only one suitable to real keyboard making the shortcut to switch input language inactive automatically.

Look for solutions on other websites. See for example

As I don't use for myself whether Ubuntu 14.04 nor Lubuntu 14.04 nor Linux at all, I cannot give a step by step instruction on how to fix wrong keyboard configuration for UEX. There are not many UEX users active members on this forum and those who are have most often not deep knowledge on system settings for various Linux distributions. Therefore I could take quite a long time if you only wait here for an answer. So I suggest to use Ask Ubuntu search and search for solutions for this problem there.
Best regards from Austria
Hell YEAH,

killing the ibus-daemon
or uninstalling it (apt-get purge ibus)
finally did it!

Thanks for your hint, Mofi!!! :lol: :D :)
8 posts Page 1 of 1