User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Project, workspace, and file management issues
12 posts Page 1 of 1
Hi,

just downloaded version 21.20.0.1004.

Now, when I open a different project, the files all show up maximized, even though I left them in the normal state (not maximized). Is there a new option for this. I cannot find it.

Thanks,
Jeff
After right clicking on any file tab and looking in context submenu File Tabs, is first item Dockable not checked?

The window states normal, maximized and minimized are possible only with dockable document windows.

See also: How to configure the appearance of the open file tabs bar in UE v15.00 and later?
Best regards from Austria
Hello,

Yes, "Dockable" is indeed checked, and I have reviewed the links you suggested.

Again, this new behavior just showed up with the latest upgrade. The tabs are auto hidden, this is fine. However, when I open a project, the files in the project are all maximized, so I can only see one file at a time. I have to click the center icon on the upper right of the menu bar to restore un-maximized viewing of the files, where I can position them how I like manually. I prefer this style of windows, and would like this to be my default. However, they are now always maximized when opening a different project.
You are right, the behavior on displaying project files on opening files changed from UE v21.10.0.1032 to v21.20.0.1004 as I have verified now.

I suggest to report this issue to IDM support by email. The files opened in normal document window state on last close of the project are reloaded always with maximized document window if

  1. dockable file tabs are used, and
  2. the open file tabs bar is set to auto-hide.
The problem does not exist with open file tabs bar being permanently visible.

I suggest to disable at the moment the auto-hide feature for the open file tabs bar as workaround until the IDM developers fixed this issue after your report.

Update: That is not the complete story. Read below my next post for more details what is the reason of this issue and how to workaround it.
Best regards from Austria
Thanks for your assistance and suggestions.

I have emailed support and received an answer from them. (I am always impressed at the quick responses I have gotten over the years for this product.)

So this issue is now on their to-do list.

Thanks again,
Jeff
When I open/reopen a project, or restart UltraEdit after closing it with a project still on the workspace, the last project's file window is opened in a maximized state. The behavior is very similar to what was written above.

The difference is that I don't use file tabs (because I'm old school). I'd like the project's file windows to open in the same state they were left in, essentially tiled across the main application window. Are there any settings I can fiddle with?

I'm on the Windows 21.30.0.1010 build.

Thank you,
Brian Ray
Hi Brian, you are right, this issue is not fixed yet.

Hotfix information published by IDM for UE v21.20.0.1009 (next public release after v21.20.0.1004) contained the line

  • Addressed issues with workspace when reloading a project
But this issue is still not fixed even in currently latest public version 21.30.0.1016 (and private user verification build 21.30.0.1019 which I use at the moment).

I needed more than 90 minutes to find out the real reason and how to workaround it.

The current state for active files is saved into ProjectName.pui correct on closing a project/workspace. The entry is Active File Display Mode= in section [Open Files] which can have following values:

  • -1 ... window state could not be defined on closing project/workspace because no active document window.
  • 1 ... window state for the active document window is normal on closing project/workspace.
  • 2 ... window state for the active document window is minimized on closing project/workspace.
  • 3 ... window state for the active document window is maximized on closing project/workspace.
But UltraEdit does not load this information from ProjectName.pui on loading a project/workspace. Instead UltraEdit applies always the window state according to Active File Display Mode= in section [Open Files] in file uedit32.ini which stores the window state for active file on closing UltraEdit and no project/workspace is currently loaded.

So to avoid getting the reloaded files of a project/workspace reloaded in maximized state, it is necessary to get either value 1 or value -1 written into uedit32.ini for Active File Display Mode= in section [Open Files].

This can be done as follows:

  1. The setting Reload files previously open on startup must be enabled at Advanced - Configuration - File Handling - Load.

    Otherwise Active File Display Mode= is not updated in uedit32.ini on exiting UltraEdit as no need to do it.

  2. The currently loaded project/workspace must be closed (with active window being in normal state).

  3. If there is no document window opened anymore, fine. Exit UltraEdit and value -1 is written into uedit32.ini for Active File Display Mode=.

    Otherwise set window state for active file to normal, or close all opened files, open a new file with Ctrl+N and set it's window to normal state. Exit UltraEdit and value 1 is written into uedit32.ini for Active File Display Mode=.

  4. Restart UltraEdit and open project/workspace and the document windows are opened in normal state.
It does not matter if open file tabs bar is not visible at all, automatically hidden at the moment, or permanently visible.
Best regards from Austria
Hmmm, I tried several times but still get the same behavior. If I open the project within UE or just restart UE after closing UE with the project still open, the last window is still maximized upon reopen.

I even tried manually changing the uedit32.ini file's Active File Display Mode setting to 1 before starting UE, but still no luck.

Thank you for the help. Even if it takes another hotfix, that's OK. If you need any more information about my configuration settings to help troubleshoot, let me know.
Brian Ray
Do you have also opened the *.pui file of your project in UltraEdit and verified that Active File Display Mode=1 is stored in this file, too?

It would be interesting for further investigation of this issue by me or by IDM support to have your uedit32.ini (UltraEdit configuration), uedit32.in0 (UltraEdit workspace), project.prj (project settings) project.pui (project workspace).

Best would be to close the project with window in normal mode, close all document windows in case of some are still opened, open Advanced - Configuration - Toolbars / Menus - Miscellaneous and click there on button Clear history, click on Cancel and exit UltraEdit. Then the 4 files are either packed with ZIP or RAR. The archive file can be attached to your next post if you want that I investigate them or you send the file by email to IDM support as attachment to a bug report.

I have of course reported the issue I found and described above by email to IDM support.
Best regards from Austria
Here you go. Host names, paths, and user ID(s) have all been scrambled but everything else is as it was following closure of UltraEdit.

Active File Display Mode is 1 in the project file and -1 in the *.ini file.

Thanks again.

Attached ZIP file deleted by Mofi.
Brian Ray
Hi Brian,

I could find out the reason for always maximized document windows after opening a project with your configuration, workspace and project files.

The solution is very easy: open Advanced - Configuration - Application Layout - File Tabs - Operation and enable setting Dockable tabs.

You have this setting not enabled in configuration and therefore you would use not dockable tabs where document windows are always maximized and a normal or minimized window state does not exist at all.

But you have closed the file tabs bar which is not possible with not dockable file tabs. Therefore UltraEdit internally overrides the dockable tabs configuration setting and uses dockable tabs because in this mode it is possible to hide the open file tabs.

The bug is that this internal overriding of the "not checked" dockable tabs bar setting is not taken into account by UltraEdit on opening a project. Therefore the files are displayed after loading always maximized as with not dockable tabs a different display mode would not be possible at all.

I have reported this issue by email to IDM support, too.
Best regards from Austria
It worked! Since I don't use file tabs, naturally I typically ignore these configuration settings.

But now my project windows reopen at the size they were when the project was closed.

Thanks again
Brian Ray
12 posts Page 1 of 1