User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

FTP, SFTP, FTPS, and SSH/telnet console issues
6 posts Page 1 of 1
Is there anyway to use UE in a two-factor authentication environment?
Do you want to connect to an FTP/SFTP server using already a two-factor authentication environment?

As far as I know two-factor authentication is mainly required by a server to increase security because of users always saving user name and password and let the applications (browsers, FTP clients) automatically connect using the stored data. The applications do not support automatic answering on second authorization (most likely because not standardized) which increases the security. The same security can be reached if the user does not save user name and password and instead always enter it. But users often don't like that if there is the possibility to let the application pass this authentication information automatically.

UltraEdit supports standardized methods for authentication like user name, password, SSL certificate, public key and private key in nearly all combinations with or without storing the data according to what the user prefers.
Best regards from Austria
So the answer is no. There really needs to be an 'interactive' mode to allow input of multiple password\passcode entries. This is going to become an increasingly common request.
The answer is NO for FTP/SFTP.

The answer is YES for SSH/Telnet sessions as once the session is established, a script on server side executed automatically on session logon can request whatever the author of this script finds useful for additional security on user authentication. If the user who established the session does not reply to the questions like an additional code or password of the script correct, the script on server side can disconnect the session and block the access for some time for the used user account.

Which features are added to UltraEdit is based mainly on how many users request a feature by email to IDM support.
Best regards from Austria
I use 2FA with all of my servers and am trying to get a persistent connection to a Linux server. I'm using the OS X version of UltraEdit v4.1.

When I try to setup an account in the Account manager, I'm not exactly sure of the settings for SSH.

Under General tab I have the following setup:
  • Protocol = SFTP
  • Hostname = mysite
  • Port = 222
Under Protocol:
  • Server = UNIX
  • SSH = I've tried all options
Any advise?
It is not clear for me if you want to download, edit and upload files via SFTP (or FTPS) using SSH/SSL as additional security, or you want to work with a SSH console.

UltraEdit for Windows has under File - FTP/Telnet the FTP Account Manager and the SSH/Telnet Account Manager.

The administrator of the server should have given you the technical information how to access the server with using SFTP connections for downloading, editing and uploading files. We cannot really help you as we don't know those technical information. The authentication method to use is defined by server administrator and should be known by you and not found out by trial and error.

Most firewalls block the incoming data channel connection from server to client (your Mac). Therefore most often either the firewall must be configured to accept incoming connections from a specific server or on tab Server the option Passive transfers (for firewalls) must be used if server supports passive transfers. You may also need to use Send after login if your server request additionally to SSH/SSL authentication a second authentication.

Also the port number on tab General could be a different one than 22 as usually used for SFTP. But all that data should have been provided by the server administrator to you.

In UltraEdit for Windows there is at Advanced - Configuration - FTP the option Show FTP log in output window which helps to find out what is the problem if something is not working. So take a look in UEM if in menu Tools in Preferences dialog there is also an FTP branch with such an option. Of course the output window must be opened when using this option to see the log on connecting to the server.
Best regards from Austria
6 posts Page 1 of 1
cron