User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
3 posts Page 1 of 1
For this latest version, UES is slow to respond when it is brought back to the foreground after being minimized for a while. Slow to respond means that the window is restored but it is completely blank and it takes 5 to 10 seconds before the content of the window is restored.

This does not happen unless the program is minimized "for a while", lets say 10 minutes or more.

I suspect that the cause is a Windows setting, but this does not occur with any other programs, nor with older versions or UES.

Cheers!
Bill

UES v14.20.0.1003
Windows 7 (64 bit)
Nvidia Geforce 8400 gs
AMD Phenom II (4 cores)
8 GB RAM
A delay of several seconds has usually always the same reason: network access

Do you have unchecked Load/restore printer settings at Advanced - Configuration - Editor - Advanced in UEStudio?

Do you see heavy hard disk activity (LED flashing rapidly or is more or less permanent on) while UEStudio restores?

Do you have files opened from a network drive?

Or do you have opend Explorer tab on Workspace Manager window containing network drives or FTP folders?

The reason for such a delay can be usually find out using the free tool Process Monitor from Sysinternals (Microsoft). Start this tool while UEStudio is minimized shortly before restoring UEStudio. After UEStudio is restored completely and showing the file contents again, stop in process monitor the logging of all registry, file/directory and network accesses and look which action requires several seconds for completion. See Random long delay when starting up UltraEdit on how to analyze the log of Process Monitor.
Best regards from Austria
Thanks for the response and information.

Problem "solved". You were right, it was a slow-to-respond network connection.

I tried leaving files of several different connection types open. Hard disk, usb connected hard disk, internet disk, and a standard network connection to a Samba based file server.

The file server had one disk that was spinning-down after a 10 minute inactivity period, and when it had to spin-up, this was causing the time lag in UES. I don't know why I have never noticed this before.

Cheers!
Bill
3 posts Page 1 of 1