User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

General and specific configuration/INI settings
11 posts Page 1 of 1
At work I use a dual monitor display setup. When I use a single instance of UltraEdit it opens on the left desktop and covers about 80% of the screen, which is what I want. When I open a second instance of UltraEdit it always opens with a small window about the size of an index card in the center of the left display. No matter how much I resize it or move it nor whether I close the main instance first or the new instance first the next time I open it I get the small window again.

So I checked the configuration menu and under Application Layout - Advanced there is the check box for Store windows/menu/toolbar placements and configurations for multiple instances of application - which sounded like it was just what I needed. But when I checked it and then opened and resized my second instance of UltraEdit, the new size still didn't become the default. Because once I closed that instance and then restarted it I ended up with a window that was about 7in x 5in or about 70% of the size I used in the previous session. At least it opened in the right side screen where I had moved the previous session, but centered on the screen instead of where I had the previous session placed.

So I unchecked the box, saved settings and tried the open and close of the second session again. Now the new instance went back to opening on the left side screen, centered there but in the 7in x 5in size. So if I have the box checked the correct screen is used but not the correct application size or location.

So I know that the screen settings must be saved somewhere although the screen location and size of the second instance is apparently not saved, defaulting to centered on the screen and a size that is not what was selected.

UltraEdit 21.20.0.1004 on Windows 7 Enterprise
I suggest following to find out the reason for the issue and perhaps fix it:

  1. Exit all running instances of UltraEdit.
  2. Open in file manager directory %APPDATA%\IDMComp\UltraEdit.
  3. Select all files starting with Uedit32 in file name EXCEPT the following:

    • Uedit32.in0 ... workspace file for first instance or all instances depending on configuration settings.
    • Uedit32.ini ... configuration settings file for all instances.
    • Uedit32.mb0 ... main menu profile file for first instance or all instances.
    • Uedit32.pb0 ... pop-up menu profile file for first instance or all instances.
    • Uedit32.tb0 ... toolbar profile file for first instance or all instances.
    • Uedit32.uek ... custom keyboard assignments file for all instances.
    The files for second instance start with Uedit321.
  4. Move the remaining selected files to a different directory like to parent directory IDMComp.
  5. Start first instance of UltraEdit.
  6. Start a second instance of UE and change window position to secondary screen.
  7. Exit second instance of UE.
  8. Exit first instance of UE.
  9. Start first instance of UE.
  10. Start second instance of UE.
Is the workspace now correct restored for second instance of UltraEdit?

Yes, then delete the moved files and configure workspace for second instance as you like it.
Best regards from Austria
Mofi - tried your suggestions but the results were the same.

I even went as far as copying all of the Uedit* files out of the directory to start UE to reconfigure from scratch. The second UE application window still opens up in a smaller size and different location than it was when closed.

As a test I opened and closed 4 concurrent instances and windows 2-4 reopen in the same location at the same size even after I resized and moved all of them.

I'm open to trying other settings if you have more suggestions. For now I just move and resize the second windows manually.
My next suggestion is opening in first instance Uedit321.in0 while second instance is not running and editing in section [Settings] the entry WindowPos.

The last 4 values of WindowPos are top left x, y and bottom right x, y.

One more question: Is the secondary monitor left or right of primary monitor?

With secondary monitor on left side all x-coordinates are negative which in many applications causes wrong window behavior like negative values interpreted as wrong and therefore default x-position is used. Similar problem with secondary monitor above primary monitor resulting in y-coordinates are negative. Top left corner of primary monitor has always the x/y-coordinates 0/0.

PS: I'm currently working on a laptop with no secondary monitor and therefore can't try my suggestions by myself.
Best regards from Austria
Setup is left monitor is #1 primary desktop, right monitor is #2. All coordinates are positive. Both monitors are 1680 x 1050 so the effective desktop runs from 0,0 top left to 3359,1049 bottom right

UltraEdit instance 1 opens on the right monitor. In Uedit32.in0 the window position values are 1745,28,3325,1027
UltraEdit instance 2 opens on the left monitor. In Uedit321.in0 the window position values are 63,64,1591,981

I did a full screen capture and loaded the resulting image into MS Paint and then recorded the actual pixel locations of the windows.

UE Instance 1 1744,28,3325,1027 Matches file
UE Instance 2 168,130,1505,878 Doesn't Match file
That is very interesting because I can't reproduce this issue whether with UE v22.10.0.10 nor with UE v21.20.0.1004 on a Windows 7 x64 machine with two 24" screens with a resolution of 1900x1200.

The first instance of UltraEdit closed/opened its window on secondary screen which was the right screen. The second instance of UE closed/opened the primary screen which was the left screen. I verified with screen shots that the windows opened after restart really exactly on the same positions as on the exits before. I wrote even your values into the 2 workspace files with UEStudio, started and exited the two instances of UE v21.20.0.1004 several times. But the coordinates changed never in the workspace files and the two windows opened always exactly on correct x/y coordinates and had the right width/height.

So I don't have any explanation why on your machine the window of second instance on primary (left) monitor always opens smaller and more centered than on previous exit.

Do you have any application running which remembers application window positions and dimensions on screens and force the configured position/dimensions on starting of the application?

I think of HydraVision or ATI Catalyst or something similar. I don't have used those applications ever which usually are installed together with the graphic driver.
Best regards from Austria
Was working on a production issue so I had to step away from this problem for a week. Now I have some bits of free time again so I'm looking for a solution.

System is Xeon based with a Radeon 3900 FireGL workstation card. No Catalyst or other special software is loaded, just the minimum AMD drivers and those are now 3 years out of date (v9.11) but we are not allowed to touch the O/S in any way, cannot download anything, and most of the commands that require admin rights are locked so we can't use them. As an example, even though we paid for the full lifetime licensing for our UltraEdit software I am only allowed to request through IT Support that the software be upgraded every 18-24 months. That is why we went from v17 to v21.00 (I actually asked for the upgrade when v19 came out but IT was so busy it took months to fill my request and v20 came out only a few days before IT scheduled the update). The only reason I got v21.20 on my computer was that we activated a couple of unused licenses for new employees and they wanted us to be uniform so they moved all of the accounts to v21.20 instead of having a mix of v21.00 and v21.20 We'll most likely not have V22 on any of our computers ever, but I hope that we will catch up with v23 when it comes out.

So I did some more tests and created up to 5 extra instances of UltraEdit running at the same time. The original UE window opens on the right side monitor in the same size as it was the session before. The second UE opens on the left monitor, centered and about 800x600 resolution. Third, fourth, and fifth windows all open on the right side, same size as the second UE and each is mostly centered on the right monitor but four is 20 pixels to the right and 20 pixels down from three while five is 20 more pixels to the right but 40 pixels up from four.

So just for a test I closed all instances of UE, opened the uedit324.in0 file and manually changed the values for the window position, making it larger and moving it to the left monitor. When I opened 5 extra instances of UE, the fourth window opened on the left hand monitor but still in the small size it had before. But after closing and reopening it was back to the right side monitor and centered again.

So I did another test. I deleted all of the UEdit321-325 files and then created 5 extra UE sessions. Again the second UE opened on the left monitor while all of the rest opened on the right monitor. The screens were all 800x600 size and sessions 2 through 5 all opened in the same place without any pixel offset. So I closed them all again. Reopened - all exactly appeared in the same place and size as before. Resized them to various sizes and moved them around. Closed all of them and then reopened them. All of the extra sessions went back to 800x600 size, but for sessions 2 through 5 the upper left location was where I moved the windows to the time before.

So I can get UE to remember where to place the window on the right side monitor, I just can't get UE to remember the size of the window for any instance except the first session, and I can't get the second session to load anywhere on the left monitor except centered. If I move the second session to the right side monitor, then the next time it opens up it opens at the height of the previous session but centered side to side and once again at 800x600.
I am going to re-open this older thread. I am having another display issue with the second instance of UE, this time with the find/replace window. As before my second instance of UE doesn't remember where it was when I closed it so I have to move it from on top of the first instance to the other monitor. I am bothered that the find/replace window opens up on the monitor where the second UE started, not where it is now. This puts it on top of the first UE edit window, even though it belongs to the second UE. The List lines containing string result window also pops up on the wrong monitor. The only way to fix that is to click on Recover floating windows under the menu View->Views/Lists. But that only works until the next time I use UE.

On the second UE I also made the mistake of docking the List Lines results window and then closing it with the X in the corner. Now it doesn't appear anywhere and I haven't found a way to get it back.
Mick, is it possible for you to close all files and projects, use the Clear history button in configuration, exit UltraEdit, compress with RAR or ZIP the file uedit*.ini and all your workspace files into an archive and upload the archive file as attachment to your next post?

It would be interesting for me which window data your files contain and if I can reproduce the issues you have with your files.

You could use the My 2 Cents forum limited to registered and logged in users to keep your files more private. Of course best would be to report the issues to IDM support by email with adding entire UltraEdit application data directory compressed into an archive file and added as file attachment to the email. If there are issues as it looks like caused by mistakes in code, only the developers of UltraEdit could fix them.
Best regards from Austria
I'll see what I can do. Permissions to do anything are being limited for the summer due to resource issues.
I did manage to fix one problem. I went into my configuration files and deleted all of the Uedit321.xx0 files. When I opened a second instance of UE after that I got my List lines containing string results window back. So that is solved. Still have the location and size of the second UE wrong. The second, and any additional instances of UE, still open on the right monitor only and without any windows size changes I made in the prior sessions.
11 posts Page 1 of 1
cron