User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
14 posts Page 1 of 1
Hello,
I'm new here and having some problem configuring uestudio and git. The problem description is given below.
I have set uestudio as default editor and ultracompare as default diff from uestudio configuration. But still it doesn't change anything (even tried as admin).
Finally ran the command "git config --global core.editor uestudio" , but the problem is it doesn't work if uestudio is already running and I still didn't figure out the command for diff. I will be glad if someone can give me some instructions or comment here if you need more info.
If I am posting in the wrong forum or something else notify me.
Thanks

Details:
Latest Uestudio ( 15.20.0.8 )
Windows 8,1
Git 1.9.5
Do you have read already power tip Getting started with Git in UEStudio?
Best regards from Austria
I've read that. My question is after setting UEStudio as default editor and UltraCompare as default diff, when I type "git diff" in cmd it doesn't open UltraCompare, nor does it open UEStudio when I type "git commit" in cmd.
I do not have Git installed and therefore can't really help with verified suggestions.

I read a little bit in manual about Git configuration file and in diff-config.txt.

UEStudio should have modified the file .gitconfig in directory %USERPROFILE% according to those 2 text files. %USERPROFILE% references value of Windows environment variable USERPROFILE which contains the path to home directory of the used user account on Windows.

Do you see something UEStudio and UltraCompare related in file %USERPROFILE%\.gitconfig?
Best regards from Austria
nothing related to ultracompare in .gitconfig, I manually changed editor to uestudio, but the problem with it is uestudio , but I think I should add some flags to uestudio there, else it won't be detected properly by git.
If you need quick help on this issue, I suggest to contact IDM support by email. I don't know how many users of UEStudio are using Git and visit the user-to-user forum frequently.
Best regards from Austria
thank you for your help and patience. I will contact the support people.
git commit opens UEStudio correctly for me. It also works if UEStudio is already open. My .gitconfig looks like this:

Code: Select all
[filter "lfs"]
   clean = git lfs clean %f
   smudge = git lfs smudge %f
   required = true
[user]
   name = xxxxxxxxxxxxxx
   email = xxxxxxx@xxxx.xxxx
[gui]
   recentrepo = D:/Users/xxxxx/xxxx/xxxxx/xxxx/xxx

[core]
   editor = uestudio

Also, add this for UltraCompare support:

Code: Select all
[mergetool "uc"]
    path = "C:/Program Files (x86)/IDM Computer Solutions/UltraCompare/uc.exe"
    trustExitCode = false
[mergetool]
    keepBackup = false
[merge]
    tool = uc
[difftool]
   prompt = false

Now when you do git difftool <filename> it will open in UltraCompare.
I tried your config but it says difftool uc unrecognized. Can you post the entire .gitconfig file. If possible please state your git version and UEStudio version. Thanks.
UEStudio version 15.20.0.8
Git version 1.9.5.msysgit.1

Code: Select all
[filter "lfs"]
   clean = git lfs clean %f
   smudge = git lfs smudge %f
   required = true
[user]
   name = Bradley Smith
   email = foo@bar.com
[gui]
   recentrepo = D:/Users/XXXXX
[core]
   editor = uestudio
   
[diff]
   tool = uc
[mergetool "uc"]
    path = "C:/Program Files (x86)/IDM Computer Solutions/UltraCompare/uc.exe"
    trustExitCode = false
[mergetool]
    keepBackup = false
[merge]
    tool = uc
[difftool]
   prompt = false
I tried your .gitconfig, when I try git commit (uesudio runs in background) it says "Aborting commit due to empty commit message", if no instance of uestudio runs it opens new uestudio and works fine. if I try difftool the output is something like unknown tool uc. I tried reinstalling git. Will try to reinstall uestudio.
vylet, perhaps it helps to check at Advanced - Configuration - Application Layout - Miscellaneous the setting Allow multiple instances or alternatively check setting Maintain separate process for each file opened from external application.

Do you have UltraCompare Professional installed at all?
Best regards from Austria
After allowing multiple instances, git commit works now. I have UltraCompare Pro installed on my PC. I don't think git supports UltraCompare manually and for some reason my UEStudio doesn't change the .gitconfig file. In settings I have set git binary to "C:\Program Files (x86)\Git\bin" and also tried "C:\Program Files (x86)\Git\cmd".
You have to edit .gitconfig manually to match mine. UES doesn't update the .gitconfig file as far as I know. Then you can do:

Code: Select all
git difftool <filename>

from a git shell and it will open in UltraCompare.
14 posts Page 1 of 1