User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Two- and three-way folder compare and merge issues.
4 posts Page 1 of 1
Is there a way to do a Folder Compare in Smart mode, ignoring the difference in datestamp?

I want to Compare text in all the RTF files of a folder. Text is supposed to be the same but the document was saved later so the date is different. Currently if I'm using Smart mode the check box for ignoring datestamp is disable (I can't select it) so even if the text in my files are the same, it says they are different because of the date.
Different file dates should be ignored automatically on using smart folder compare which is the reason why Ignore timestamp differences is disabled automatically on selecting smart folder compare method.

I created 2 folders each with 4 plain *.txt files for testing this with UC Professional v15.10.0.12.

  1. File1.txt have in both folders identical file size, file date and file contents (binary identical).
  2. File2.txt in both folders have same file size and contents (binary identical), but different last modification date.
  3. File3.txt in folder 1 has a different file date and file size in comparison to File3.txt in folder 2 because in folder 1 the line terminators are DOS and in folder 2 modified later the line terminators are UNIX.
  4. File4.txt in both folders have identical file size and file date, but contents are different because of 1 character modified in file in folder 2.
The smart folder comparison with the text ignore option for ignoring line terminators enabled listed correct File1.txt, File2.txt and File3.txt as being equal and only File4.txt as being different.

But you compare RTF files. Therefore I deleted the text files in those 2 folders and added to the folders:

  1. File1.rtf have in both folders identical file size, file date and file contents (binary identical).
  2. File2.rtf in both folders have same file size and contents (binary identical), but different last modification date.
  3. File3.rtf in folder 1 has a different file date and file size in comparison to File3.rtf in folder 2 because I inserted with UltraEdit one more blank line in the RTF file between 2 text paragraphs.
  4. File4.rtf in both folders have identical file size and file date, but contents are different because of 3 characters modified in file in folder 2 with UltraEdit in text.
The smart folder comparison with the text ignore option for ignoring blank lines enabled listed correct File1.rtf, File2.rtf and File3.rtf as being equal and only File4.rtf as being different.

Even with differences made in formatting tags of File3.rtf in folder 2 the two File3.rtf are indicated as equal in the smart folder comparison result.

So I could not reproduce what you wrote. Are you using also UC v15.10.0.12?
Best regards from Austria
I guess I have an old version: 8.20.0.1012
In my folders, I have cases like your file2.rtf and file4.rtf. When I run the folder compare with smart mode, it gives the list of files in both folder, both they are all in green in folder 2, which mean they are the "newest". If I click on each file I can see if they are different or equal with the text compare, but I would like to see which one are the equals and which one are different on the list page. The different are supposed to have the red star and equals are supposed to be in blue. I don't mind having them in green because of the different dates, but I don't have the star for those with different contents on those with differences.
I restored UC v8.20 from archive and executed the 2 smart folder compares like done before with UC v15.10.

The smart folder compare with *.txt files produced with v8.20 same correct results as with v15.10.

But the smart folder compare with *.rtf files produced with v8.20 the results as described by you. I could see that v8.20 does not convert the RTF files to TXT files in directory %TEMP% and run a text compare with the enabled text ignoring options like v15.10 does. This is the reason why the results are different for a smart folder compare on *.rtf files.

There is no workaround for this different behavior of UC v8.20 regarding smart folder compare on *.rtf files.

I can only suggest to upgrade to currently latest version of UC if you need to run such a compare often.
Best regards from Austria
4 posts Page 1 of 1
cron