User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
2 posts Page 1 of 1
Sometimes, when I paste a long text into UltraEdit, I get a single, very long line of text. The formatting (tabs, newlines) are gone.

How do I preserve the formatting of the original text?

Thanks.
UltraEdit does not remove horizontal tab characters on paste or remove line breaks. The only modification made on paste is converting for example a block using line-feed only as line terminator to a block with carriage return + line-feed on paste if configuration setting On paste convert line endings to destination type (Unix/Mac/DOS) is enabled as by default and active file uses DOS line terminators.

I suppose you copy the text from a source which does not have tabs at beginning and newline characters at end of every displayed line like a HTML file displayed in browser window or email application, or a PDF file, or a Microsoft Word document. In this case the text copied into clipboard in the other application does not have tabs at beginning and newline characters at end of every displayed line at all.

Of course the same happens when in UltraEdit Wrap at window edge or Wrap after column # is active for a file (soft word wrap) with indenting also the displayed lines automatically based on previous displayed line because of Auto indent wrapped lines being also enabled. Coping the soft wrapped and soft indented paragraph and pasting the paragraph into another file with word wrap not active results in getting the block displayed as it really is and stored in text file.

Activate in menu View the options Show Spaces/Tabs and Show Line Endings to see which indentations are because of real spaces/tabs and which displayed lines have really a line termination.
Best regards from Austria
2 posts Page 1 of 1