User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Building, compiling, or debugging issues
3 posts Page 1 of 1
This question is very simple. Every time I build a console application and test run it inside UEStudio, the console output always shows the file name first, and then the content of the app. For example, say I am building Foo.exe which only has one line: std::cout << "Print Foo " << std::endl; (of course I also have #include <iostream> etc. ); when I run this app inside UEStudio, I get the following output:

Code: Select all
Foo.exe
"Print Foo"
Press any key to continue ...

Is there anyway to turn off the display of Foo.exe to print out in the console?

I know this is so simple that almost feel like stupid to ask, but I look and look and couldn't find the option to turn this off. Of course, if I run the app from my regular DOS prompt session via cmd, I would not see Foo.exe to print out.

I don't believe this can be done as in the default run configuration box under compile option this is the command line arguments the user must provide, this option cannot be left blank. But I ask the question anyway in case someone know how to turn off the displaying of the file name.

Thanks in advance.
You have to do what must be done in batch files to prevent also output of the executed command. The built application must be started with @ at beginning.

  1. Click in menu Build on Select Compiler.
  2. Click on button Edit configuration.
  3. Search for section MakeCommands which contains the line run = usually with value Execute Application. Get the string assigned to run command.
  4. Search for a section [Execute Application] or whatever string was assigned to command run.
  5. Look for line starting with Cmd0 =.

    1. If this line is Cmd0 = $T $(Command Line Arguments) with $T being a placeholder for target full name as listed at top of configuration in comments section, change the line to Cmd0 = @$T $(Command Line Arguments) and use button Save configuration.

    2. But if this line is just Cmd0 = $(Command Line Arguments), close the dialog with button Cancel, and click in menu Build on Set Compiler Options. In section DEFAULT RUN CONFIGURATION look for Command Line Arguments where you should see name of the created executable as value (and perhaps additional parameters). Double click on this line, insert at beginning @ and click twice on button OK to save modified compiler options.
That's it. The built executable is now started on running application without command being output to console because of @ at beginning of command line.
Best regards from Austria
Hi Mofi,

Thank you so much for your respond. Option B : Cmd0 = $(Command Line Arguments) without the &T was my case, and I was actually playing around with the DEFAULT RUN CONFIGURATION before asking this question. Putting the @ at the beginning indeed does the trick, I would have never thought of that! Thank you!
3 posts Page 1 of 1