User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
7 posts Page 1 of 1
Today my function list is empty, I had no idea why, I disabled the anti-virus scanner, same problem. I use UES 15.30.0.18

What can I do to find the reason?
Best regards from Austria
Markus
  1. What language has active file, C/C++, C#, Xbase++, Java, JavaScript, PHP, etc.?

  2. Tell us your function list configuration. While in UltraEdit the function list is always filled with the strings found by the regular expression strings in applied wordfile, UEStudio has two input sources for the function list: the regular expressions in the wordfile or the symbol database of integrated parser.

    The source depends on setting Use function tips data (if available) for function list at Advanced - Configuration - IDE - IntelliTips - Function Tips.

  3. Which options are enabled in context menu of function list?

    Sort List, List for all Project Files, Flat List, ...

  4. Is currently a project loaded?

    If the answer is yes, verify the list of project files, especially if a filter is used to find project files.

  5. If the regular expressions in the wordfile are used, which regular expressions do you currently use?

  6. If the symbol database of integrated parser is used, is the cache of the parser currently empty?

    Check list of files in directory %APPDATA%\IDMComp\UEStudio\Cache. If the directory is empty, there is definitely no symbol database available.

  7. If the symbol database of integrated parser is used, do you have switched the project before?

    Yes, have you also started the parser manually or was it executed automatically to create the symbol database for now active project?

  8. If the symbol database of integrated parser is used, what is your parser configuration?

    In other words, what is configured at Advanced - Configuration - IDE - Parser?

  9. Is the active file or are the project files encoded in ASCII/ANSI or in Unicode?
Best regards from Austria
1) Xbase++
2) Function tips are enabled.
3) Tried different options (all project files).
4) Yes, I use a project.

I have found the reason: If there are more than 38 files open in the editor, the function list does not work. But with having 38 or less files open, the function list works fine.
Best regards from Austria
Markus
Weird. I just opened 54 Java files and the functions show in all of them.
I tried it several times (open/close). Always exact the same. Maybe Xbase++, file size, length of file name, ...

I now know this limitation and can live with it.
Best regards from Austria
Markus
I bet if the IDM guys had your files they could solve it. Any way to obfuscate them and send them to IDM for them to try to reproduce the bug and fix it?
I tried to reproduce the issue by using UES v15.20.0.8 on Windows XP.

I opened a C++ project with exactly 500 project files by pure. 243 project files are *.cpp files, some more are *.h files and a few are *.rc files.

I opened next 43 *.cpp files and although using also the function tips data for the function list, the function list worked fine and always displayed immediately the functions for active file.

But then I clicked with right mouse button into the function list view and enabled option List for all Project Files. This was no good idea. UEStudio started the background thread collecting the data indicated by an sand glass mouse pointer, but UES never finished the task and displayed all functions from all project files. UEStudio was still responsive, I could run a Find in Files listing all project files in output window and make also changes in the opened files. But UES executed everything very slow.

So I started Process Explorer from Sysinternals and looked on the process data of UEStudio. It consumed permanently less than 0.4% CPU power. So UES did not run into an endless processing loop. The working memory consumption first increased in small pieces until 37.4 MB memory was used. Number of handles, threads, user and GDI objects were constant. I exited Process Explorer and started Process Monitor to watch registry and file system activities. But the only activity I could see was the periodic check on modifications on the 43 opened files done by UES using another thread. There were no accesses on symbol database files in cache directory. Well, the symbol database should be already in memory of UEStudio and therefore there is no real need to read the cache. I started writing this post in the meantime and as I looked again on UEStudio process in again started Process Explorer, the working memory valued was decreased in the meantime to 32 MB and started again in increasing in small pieces. I clicked on exit icon of UES as after several minutes I did not want to wait longer for the list, but UES did not terminate. I needed to kill UEStudio.

Conclusion: It looks like UEStudio with using function tips data for function list has a thread management problem when number of project files is quite large and List for all Project Files is enabled for the function list.

There is no problem with usage of List for all Project Files when having Use function tips data (if available) for function list not checked in configuration. In this case UES searches in all project files with the regular expressions in the wordfiles for the function strings which is indicated on left side of the status bar. That took several seconds for my project with exactly 500 project files, but the sorted function string list was displayed finally.
Best regards from Austria
7 posts Page 1 of 1
cron