User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
5 posts Page 1 of 1
When I invoke the command Copy all bookmarked lines I do not get the desired outcome. Sometimes I get just 1 line copied.

Often I get the error message: Error: Selected text too large for clipboard

I was getting this with UE 22.20.0.49. Just upgraded to latest 23.00.0.59 and same result.

Any ideas?
I executed with 32-bit UE v22.20.0.49 on Windows XP a Perl regular expression find with search string add|issue|of with List lines containing string also checked on English file changes.txt opened before from program files folder of UltraEdit and get 451 files lines listed in Find String List.

I could copy the found lines now directly to clipboard, but right clicked into the list and left clicked on Bookmark All Lines. Next I executed the command Copy All Bookmarked Lines and there was no error message. I pressed Ctrl+N to open a new file and Ctrl+V to paste the 451 copied lines.

So I could not reproduce the issue you have. I made the copying additionally also with user clipboard 1 instead of Windows clipboard and it worked, too.

I could run this procedure also with 32-bit UE v23.00.0.59 on Windows 7 x64 without any problem. Also converting the ASCII/ANSI file changes.txt to Unicode and executing now Copy All Bookmarked Lines worked without any error message.

Is it possible for you to describe step by step how to reproduce this issue which most likely can be solved only by the developers of UltraEdit when it can be reproduced at all by us with your instructions?

BTW: The error message is definitely from UltraEdit itself and not a used library as I could find the string in uedit32.exe.
Best regards from Austria
Step to reproduce in UE 23.00.0.59 x64 / Windows 7 x64 SP1

Enter three-five lines of any text, e.g.

Code: Select all
12345.
67890
ABCD
qwe5643

  1. Find . with Perl regexp and list lines containing string
  2. bookmark all lines
  3. copy All bookmarked lines
I get either "Error: Selected text too large for clipboard" or "An error has occurred. The application will be shut down.
Would you like to save an error report?
"

I have saved report and I'll send it to IDM later.

Attachments

It's impossible to lead us astray for we don't care even to choose the way.
Thanks, Ovg for testing with 64-bit UE. It looks like this is only an issue of 64-bit version of UltraEdit which should be definitely reported to IDM support by email. I can't reproduce it with 32-bit UE.
Best regards from Austria
I have send crash dump and my test file to IDM support, but unfortunately they can't reproduce issue. BTW this info was logged and sent to development team.
It's impossible to lead us astray for we don't care even to choose the way.
5 posts Page 1 of 1