User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
6 posts Page 1 of 1
Every time I start UltraCompare on a Mac running OS X El Capitan 10.11.6 there is a popup that says "Locale nb_NO cannot be set". I had this problem for a long time also with previous releases of El Capitan (10.11.x) so this is not a new problem after the last update. OS X is setup with English language, but the date/time and format is setup with Norwegian. Anyone seen this problem and know how to fix it?

Here is a screenshot of the dialog box shown every time I start UCX:

I don't have a Mac and therefore can't really help on this Mac system configuration related issue.

However, I searched some minutes in world wide web, read some found web pages and here are some suggestions based on what I could quickly find.

I suppose that when you run in a terminal locale you get something output like below:


And on your Mac there is nothing installed for locale nb_NO, i.e. there is no directory /usr/share/locale/nb_NO or the directory is empty.

Take a look on OS X El Capitan: Language & Region preferences, How can I install es_AR locale on OSX El Capitan? (Apple StackExchange) and How can I install es_AR locale on OSX El Capitan? which I quickly found searching in www. Of course you need to install the locale package for nb_NO and not for es_AR, but the necessary steps to execute should be more or less the same. I suggest further to look on locale search results on if you can find something helpful regarding this Mac Language & Region related configuration issue.
Best regards from Austria
Actually most of them are not set. It looks like this:


And as you said there is no nb_NO directory. I do have a "nb", "no" and a "no_NO" directory, but no "nb_NO". This goes for all of my Mac's so i guess this directory isn't there by default in El Capitan. Maybe UE shouldn't look for the directory if it doesnt exist. I will look at the links you provided and see if that solves the problem, but I believe the main problem is that UltraCompareX need a update to fix this issue with El Capitan since that folder doesn't exist by default.

Thank you for your help so far. I'll post the results when i tried what's suggested in the links provided.

Okay, I read the links you posted and i guess the solution could be simple. If I copy the no_NO folder to nb_NO that might solve the problem. The only problem is El Capitan and SIP (rootless feature) that won't let me make changes to that directory. In that case i would have to disable SIP make my changes and then re-enable SIP. Everything else is setup correctly on my Macs. A better solution would of course be if IDM could change UC so it will search for the proper folder. Since this folder is protected by SIP it's not really meant for anyone to make changes directly in that folder.

Seems like this is a bug in UC and since the application is updated very seldom I guess it might not be 100% compatible with El Capitan. The locale cannot be set to nb_NO because there is no nb_NO on a Mac I guess.

Well, I suppose Norwegian Bokmål (Norway) (= nb_NO) is not often used on Mac (or Debian/Ubuntu) and therefore this locale package is not installed by default, especially when using English OS.

It is interesting for me that most of the locale variables are not defined on your Mac. As far as I know this is not the case on Linux distributions. I don't know not set locale environment variables is default on Mac OS X.

I suppose the warning message is output not by UCX itself, but a library used by UCX like the Unicode library ICU. But it could be also that UCX access environment variable LC_TIME as the date/time format is needed for output of folder compare results on screen and in file.

You could easily check this by opening a terminal window, run first the command export LC_TIME="en_US.UTF-8" and then start from within the terminal window UCX. If there is no warning message, the environment variable LC_TIME is indeed used by UCX or a used library.

Well, I'm using only Windows and for that reason I don't give here verified hints. If you think that the UCX developers of IDM Computer Solutions, Inc. should investigate this issue for better handling your language and region configuration in a future version of UCX, please report the issue by email to IDM support. You should also add as much as possible about your language and region configuration on your Mac.
Best regards from Austria
Seems like Norwegian Bokmål is not installed on a Mac even if I selected Norwegian under language settings. It's a small country so you are probably right it's not that common combination :) I tried to Google, but seems like there is no official way to install nb_NO on a Mac manually.

Seems like the locale variables that is not defined is the same on all of my Macs so I guess they are not used like with Linux.

I tried like you described with the export command and then started UC from the same terminal window, but I still get that error message.

I can contact IDM and ask for help. Maybe they can help me out. I didn't use to have this problem with the previous version of UC on the same Mac.

To bad the IDM support staff do not use this forum like a lot of other companies do where their engineers use the forum and talk to the customer directly. I believe that would not only benefit the customers, but also IDM. Lenovo, Vandyke and Norton is a couple of companies where the support staff use the forum and talk to the customer directly.

Anyway thank you for your reply and help. Maybe IDM should pay you since it seems like you are doing their job in this forum and you do a good job as well :)

6 posts Page 1 of 1