User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

A place for users to discuss the Linux-based version of UltraEdit, UEx
6 posts Page 1 of 1
I upgraded from UEX v15.10 to v16.1, but while I can choose from a selection of nice eye-pleasing themes, I cannot select from the View As (Highlighting File Type). It is disabled/grayed out.

I read through the portion of Mofi's syntax highlighting sticky on that forum, as to the latest changes for UE 20, but UEX is different isn't it?

Anyhow, any help on getting my C wordfile formatting back (especially the colors) in proper use would be appreciated. It doesn't seem like they transferred their settings over to the themes during the upgrade, as I understood they would.

Thanks.
I'm not using UEX and therefore shoot into sky with what I wrote below.

As UEX v16.1 supports now also themes, the syntax highlighting color/style settings are most likely not read/stored anymore from/to the wordfile, but from the used theme file as done also by UltraEdit for Windows v20.00 and later versions. So the syntax highlighting colors and styles for the various used syntax highlighting languages must be configured in Manage Themes dialog on tab Syntax which I suppose also UEX offers now.

If UEX uses a *.ue-theme file in XML format like UltraEdit, you may be able to use my script WordfileColorsToTheme.js from Extract color and font style settings from wordfiles and convert to theme format and copy the created XML block into your theme file. But I really don't know if this script works with UEX and if the format of the theme file of UEX is the same as for UE.
Best regards from Austria
FWIW (I'm not sure any of this will be of much help):

UEX 16.1 does look for various *.ue-theme files in ~/.idm/uex/DefaultThemeFiles/ (I determined this by looking at strace output for UEX), but on my system that directory is empty. There is another empty theme related directory: ~/.idm/uex/CustomThemeFiles/

I can't find any evidence in the strace log of a *.ue-theme file being opened successfully. UEX tries to open the various default theme files, but since they don't exist the open() call fails with ENOENT (No such file or directory).

In spite of those directories being empty, themes work.

I also have no problem with the View/View As (Highlighting File Type) menu - it is not disabled and it works fine. I'd expect that this would have more to do with missing wordfiles (stored in ~/.idm/uex/wordfiles). Note that even if I remove the wordfiles, UEX recreates them with some default set. If I prevent that (by removing the wordfiles directory and creating an empty file named wordfiles), I no longer get syntax-highlighting but the View/View As (Highlighting File Type) still works - it just has the single entry of No Highlighting.
That's interesting. Now they are showing.

I had selected Twilight theme already, when I posted this thread, but the View As was disabled. After fooling around with replicating my color schemes, I must have in inadvertently turned them on.

My wordfile is where it originally was before the upgrade /home/jetimms/.idm/uex/wordfiles.

I can confirm that the ~/.idm/uex/DefaultThemes or CustomThemes are empty. I exported a copy out after making my syntax changes. Maybe that's what activate View As.

Thanks Mofi and mwb1100 for the insight and help.
I suppose the directory ~/.idm/uex/CustomThemeFiles/ won't be empty anymore if in themes manager dialog the currently used theme is saved with a custom name before or after making changes. That's what I have done on Windows. I have a Mofi.ue-theme file in subdirectory themes in application data directory of UltraEdit on Windows. A custom theme file is not updated automatically in future.

If a standard theme is modified, UltraEdit for Windows creates a special override theme file containing only the items different to standard theme to apply. Such a override theme for a standard theme is the better choice if just a few theme settings are modified as the not modified settings are always updated with the standard theme on upgrade of UltraEdit in future.

My custom theme is for a Spartan user interface and therefore far away from a standard theme.
Best regards from Austria
I didn't know IDM that sort of snapshot file (so to speak) of the themes.

So when IDM updates the prior unmodified settings in the standard template file, the user using a modified standard will see their own modified changes (as before) and the other IDM changes in the newly modified standard settings? That's nifty.

I run UEX on Linux, mainly, so I haven't paid much attention to my Windows installation. I'll compare both and try to see how they relate.

Thanks Mofi.

Update: 2016-09-01_2152 EDT
FWIW:
I was wrong about my post early this morning. The files in default themes all seemed to have been created this morning at 7:44 am, prior to my second post. Perhaps it was the second time that I ran UE and that's when it creates them. Could be why "View As" worked. I don't know.

My Windows 10 box is running UEW 23.20.0.28. It doesn't have the CustomThemes or DefaultThemes any more. I only see my own theme there and a copy of a Default theme Slate.ue-theme in a folder called overrides. That may be the snapshot file that you mentioned, Mofi. It's contents look like a partial.

Anyhow, it looks like UEX doesn't do the default theme snapshot like UE for Windows. That's fine. As long as I have UC, I can keep mine updated.
6 posts Page 1 of 1