User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Two- and three-way text compare and merge issues.
7 posts Page 1 of 1
Dear Sir,

I don't know why, but sometimes when I start a compare session from UltraEdit in the current German UltraCompare (v16.00.0.44) the option Relational Lines Mode is not ON. And I don't know why. I can set it manually and it works.

The attachment is a screen shot of the "German" menu with the option Zeilenbezug ein/aus.

My problem is, I can not reproduce it. Sometimes it works, sometimes not. This option is very important for me, it is/should be always ON.

Did you know something about the phenomenon?

Regards, Mario

Attachments

This comparison mode/view option can't be set by UltraEdit nor can it be set via a command line option. Relational Lines Mode option for a 2 or 3-way text comparison is set always like it was set before in last text comparison. This option is also available in session properties of a text comparison session. So it can be toggled off/on individually for each text comparison session currently active in UltraCompare. In this case it depends on which session is closed last for the state of this option on next text comparison session.

I'm not aware of an automatic disabling of Relational Lines Mode depending on the two or three compared files on start of a text comparison session.

I suggest to do following next time this option is disabled after start of a text comparison session either directly from within UltraCompare or from within UltraEdit.

  1. Enable Relational Lines Mode.
  2. Exit UltraCompare.
  3. Restart the text comparison session like just done before.
Is the Relational Lines Mode option again not enabled after start of the text comparison session?

Yes, then please report this issue to IDM support by email with attaching the compared files compressed into a ZIP or RAR archive and a detailed step by step description on how to reproduce this issue.

Of course you could also ask IDM support by email if Relational Lines Mode is disabled automatically under certain conditions on starting a text comparison session which I'm not aware of. I usually don't use this text comparison mode and therefore don't have much experience with it. I could not find any note on help page for Relational Lines Mode about an automatic disable of that option under certain conditions.
Best regards from Austria
Dear Mofi,

thanks for information, when I've got the same experience, and I can reproduce it, then I'll contact the support directly by mail.

Regards, Mario
Dear Mofi,

okay, I can reproduce it. When I start a compare session from UltraEdit, and UltraCompare isn't running, then the Relational Lines Mode is off. When I start a second compare session from UltraEdit and UltraCompare is already running, then the second session opened in a new UltraCompare tab (that I've configured) and the Relational Lines Mode for this session (tab) is on. "On" is my default and should it be all the time.

I send a bug report to the support team.

Regards, Mario
I first could not reproduce this issue.

The two tried test cases are as follows step by step.

1. Relational Lines Mode disabled

  1. Start 32-bit UltraCompare Professional v16.00.0.44.
  2. Close all comparison sessions reloaded on startup.
  3. Click in menu Session in submenu New Session on menu item Text with using Toolbar/Menu Mode.
  4. Make sure the menu item Relational Lines Mode is not enabled in menu View.
  5. Close the text comparison session without running a text compare at all and exit UltraCompare.
  6. Start 32-bit UltraEdit v23.20.0.43 and open two nearly identical text files.
  7. With using Toolbar/Menu Mode - Traditional Menus click in menu File on menu item Compare and run the compare without changing any option.
  8. The two files are compared in started UltraCompare Prof. with Relational Lines Mode being still disabled as expected.
  9. Switch with Alt+TAB back to UltraEdit and open two more files being nearly identical.
  10. Click in menu File on menu item Compare and run the compare without changing any option.
  11. A second text comparison session is opened in already running UC comparing files 3 and 4 opened in UltraEdit, too.
  12. Again Relational Lines Mode is not enabled.
So both text comparison sessions use what was set for Relational Lines Mode on last exit of UltraCompare which was status OFF for this option.

2. Relational Lines Mode enabled

  1. Start 32-bit UltraCompare Professional v16.00.0.44.
  2. Close all comparison sessions reloaded on startup.
  3. Click in menu Session in submenu New Session on menu item Text with using Toolbar/Menu Mode.
  4. Make sure the menu item Relational Lines Mode is enabled now in menu View.
  5. Exit UltraCompare without closing explicitly the text comparison session before which was not really used.
  6. Switch with Alt+TAB to UltraEdit, make second file active and then make first file active.
  7. Click in menu File on menu item Compare and run the compare without changing any option.
  8. The two first files are compared in started UltraCompare Prof. with Relational Lines Mode being enabled as expected.
  9. Switch with Alt+TAB back to UltraEdit, make fourth file active and then make third file active.
  10. Click in menu File on menu item Compare and run the compare without changing any option.
  11. A second text comparison session is opened in already running UC comparing files 3 and 4 opened in UltraEdit, too.
  12. Again Relational Lines Mode is enabled.
So both text comparison sessions use what was set for Relational Lines Mode on last exit of UltraCompare which was status ON for this option.

3. The real issue existing only in UC v16.00.0.xx

But I detected also the real problem. Relational Lines Mode is always disabled when UltraCompare v16.00 is exited with no text comparison session still opened and UC is next started with two text files to compare in text mode. So closing first all text comparison sessions and last exiting UltraCompare results in Relational Lines Mode being disabled on next start of UltraCompare with -t and the files name of the text files to compare.

I have just sent following bug report by email to IDM support:

Mofi wrote: I'm reporting an issue of 32-bit UC v16.00.0.44 on Windows 7 SP1 x64.

Relational Lines Mode is not active anymore after exit of UltraCompare Prof. when no text comparison session is opened anymore on exit and next start of UltraCompare Prof. is with 2 text files to compare in text mode.

The steps to reproduce this issue are as follows:

  1. Start UltraCompare and close all reloaded comparison sessions.

  2. With using Toolbar/Menu Mode open in menu Session the submenu New Session and click on menu item Text.

  3. Open menu View and enable Relational Lines Mode if this mode is currently not active.

  4. Close the text comparison session by clicking on X symbol of the tab.

    This is a very important step. The issue is not reproducible if this step is omitted and UC is exited without closing first the session.

  5. Exit UltraCompare not having any comparison session opened anymore.

  6. There are two options for the next step:

    1. Open in UltraEdit the files changes.txt of UE and changes_ues.txt of UES and run a compare of the two files from within UltraEdit.

    2. Run the command line

      Code: Select all
      "%ProgramFiles%\IDM Computer Solutions\UltraCompare\uc.exe" -t "%ProgramFiles%\IDM Computer Solutions\UltraEdit\changes.txt" "%ProgramFiles%\IDM Computer Solutions\UEStudio\changes_ues.txt"
    This is another very important step. The issue is not reproducible if UltraCompare is started without parameters, a new text comparison session is started and the two files are opened in UltraCompare.
The result is a text comparison of the two text files with Relational Lines Mode not being active anymore as it was on last close of a text comparison session which was closed before UltraCompare was exited last time.

BTW: The configuration option Reload sessions previously open on startup is not enabled in my UC configuration as I detected this issue.

I looked on differences in uc.ini as stored on

  1. exiting UltraCompare while the text comparison session is still opened with "Relational Lines Mode" also active in this session

    and on

  2. exiting UltraCompare after first closing the text comparison session with Relational Lines Mode also active in this session.
In both cases RelationLines=1 can be found in uc.ini in [Settings]. But in first case there is Mode=0 in section [Settings] while in second case there is Mode=8 in uc.ini after exit of UltraCompare. This different mode value makes the difference on next start of UC with the parameters to run a text compare with the two text files specified on command line, too.

This issue with the six steps above is not reproducible with UltraCompare Professional v15.10.0.20 running on Windows XP.
It is also not reproducible with UC v15.20.0.11 on Windows 7. But it is reproducible with UC v16.00.0.27 on same Windows 7.

In other words this issue was introduced with UC v16.00.

This issue could be reproduced by IDM support and was added to the database as bug to fix in a future version.
Best regards from Austria
Dear Sir,

today the bugfix release UC 16.0.0.50 is coming. I try to reproduce the bug and it seems that it was solved.

Thanks a lot,

Regards, Mario
Yes, it is definitely fixed with UC v16.00.0.50. I could reproduce the issue again with UC v16.00.0.44 on my computer. But the Relational Line Modes option was always correct set as expected after updating to v16.00.0.50 and running the steps with this build. Thanks for letting us know about this fix.
Best regards from Austria
7 posts Page 1 of 1