User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

General and specific configuration/INI settings
5 posts Page 1 of 1
I created a new text file and saved it to my desktop. After the weekend, when I came in, there were about 1500 copies of this file on my desktop. For the life of me, I cannot find why this is happening. It's a new install, and a new problem, so I know it is just a setting I can't find.

Thanks for your thoughts,

Open Advanced - Settings/Configuration - File Handling - Backup and look if you have enabled On save for Version backup and have additionally enabled Automatic save at Advanced - Settings/Configuration - File Handling - Save with a minute value greater 0.
Best regards from Austria
On Save is checked. Save time is set to 5 minutes.

Default backup directory is set to: D:\UETemp\

I was just prompted to save File(540).

I don't see why it is saving to my desktop. OR why it is at version 540, when there have been no changes since the original (unsaved version). Yes, it is a new file that has not been saved.

With your settings UltraEdit saves every opened file every 5 minutes independent on being modified or not in the last 5 minutes. As version backup is enabled with Maximum number of backups having default value -1 there is no file limit defined and each save every 5 minutes creates a new version backup.

The version backup is not automatically saved in the default backup directory. It depends on what is configured for Format. The default is $n$c$e which results in creating the version backup in same directory as the file. It can be read with a click on button with question mark that $b can be used in Format (at beginning of course) to specify the default backup directory as target folder for the version backup.

To get more help on the backup and save configuration settings click on button Help in the configuration windows.

I have never investigated how version backup works on a new file not yet saved ever and saving new files every X minutes is also enabled. I don't use version backup because I have no need for it.
Best regards from Austria
Thank you very much!!!

I have edited my "format" to be: $b\$n\$n($c)$e

and now I have a sub folder for each file under the default backup directory. Within each subfolder, I have the versions.

All I have to do now is find my happy place regarding max number of backups based on how far back the undo command works.

Thanks again!

5 posts Page 1 of 1