User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
7 posts Page 1 of 1
Somehow, when I'm using Ctrl+F to find, UltraEdit has several times now increased the font size massively on every single open file. I can see the font size increase rapidly over a second or two. It's not and instantaneous change - I can see them all growing - but it happens very fast.

I can fix this by View - Reset Fonts (default), but ... I 'd like to prevent this from every happening as I don't ever want to change my fonts accidentally - or ever really? Is there a setting where I can turn this off?

Also, resetting the fonts only fixes the current file. How do I reset the fonts for All my open files?

One other thing. Somehow when all this happened, UltraEdit changed my tab stops so that a single tab moves to column 20, then to 40. Is there a command to 'reset tabs' to the default?

Thanks!
Ctrl+F opens by default the Quick Find window. It can be configured that Ctrl+F opens the regular Find window instead, see Quick Find versus Find and how to customize the usage of both (Ctrl+F behavior).

So if you don't have assigned this hotkey to another command like ViewFontIncreaseSize at Advanced - Settings/Configuration - Key Mapping, it is unlikely that UltraEdit changes the font size. Click in this configuration dialog on button Defaults to reset all hotkey assignments to default.

There is also the setting Disable mouse wheel zoom at Advanced - Settings/Configuration - Editor Display - Miscellaneous to enable (default, not checked) or disable (optional, checked) font size change on holding Ctrl key while using mouse wheel.

But I suppose that you have a special application running in background which on pressing Ctrl+F changes the size of the font in currently displayed document window of any application which supports that. For example video adapter drivers are often installed with additional applications started on Windows start automatically and one of them controls some display settings by global hotkeys. For that reason I suggest to open the advanced display settings and look there for a hotkey setting which changes the font size on pressing Ctrl+F. For example the computer I'm currently using has an Intel video adapter and the driver installed also an application for changing display settings by hotkey. I disabled all hotkeys in advanced settings of video adapter as I don't need them. And additionally I started msconfig.exe once in the past, selected tab Startup, unchecked hkcmd (hotkey commands application) which the driver installed and configured to start on Windows start and restarted Windows to avoid running this not needed background process at all.
Best regards from Austria
Perhaps you were using the scroll wheel on your mouse in conjunction with the Ctrl key. That changes the font size up or down depending on the direction of the scroll.

EDIT - I see Mofi mentioned that as well.
I haven't changed any hotkeys in a very long time. ViewFontIncreaseSize was not associated with a hotkey.

I have dual nVidia Titans, and haven't setup any hotkeys there.

This Windows 7 box has been quite stable for years. I did just change to a new Logitech MX Master mouse with it's new 'Options' software, but ... never setup any hotkeys there. I've never seen this happen before.

I did find that if I scrolled with the main scrollbar (there is a side scrollbar also) while the control key is down, the fonts change. I don't remember doing this, and this time, they only changed in the single file I was editing, not for All files. I believe I would have noticed if I was using the scroll bar as there is a taptic notched clicking feel when the scroll bar is moved - and the fonts much faster last night.

I'm running UltraEdit 16.30.0.1001 so I don't have a 'disable mouse wheel zoom' setting. I guess I may have to upgrade if this would fix the issue?

If this happens again, and to all my open files, is there a way to reset them all back to normal?
The hotkey support of display adapters must not be setup by a user. That is setup during installation of the driver and the user have to disable the hotkey support if not wanted/needed.

However, it looks like you are holding Ctrl key and spin mouse wheel unintentionally for example because of a too sensitive mouse wheel or use by mistake an extra mouse button which also results in a font increase. It is also possible that a special mouse movement (gesture) is interpreted as font increase. Look on ALL your mouse options as many applications support font increase/decrease by Ctrl+mouse wheel spin.

The UltraEdit configuration setting Disable mouse wheel zoom is available since UE for Windows v16.20 as it can be read in History_ConfigSets as well as in UltraEdit16_20__ConfigSets in the self-extracting archive UE_UES_ConfigSets.exe offered for download in sticky Configuration/INI Settings topic Help for finding settings in Settings / Configuration. There is no extra file for UltraEdit v16.30 as all configuration settings are identical to v16.20.

To reset the font for all files to preferred size open View - Set Font and change the size value as this setting is modified by Increase Font Size and Decrease Font Size which can be also found in menu View.
Best regards from Austria
Thanks! After find the 'Disable mouse wheel zoom' setting, I haven't had a repeat of the font size issue! Must have been the new mouse.

One last small question, is there a setting to disable the transparency on the very top of UltraEdit, where the UltraEdit program name and the currently edited file are displayed? It makes it harder to read the file name.
The window title style is controlled by Windows, not by the applications. Change the Windows desktop settings.

I prefer the Windows Classic desktop theme with having additionally configured that first and second color of active and inactive window title bar have the same color which disables color fading in window title bars and which is the Windows 95 look as it makes screen shots saved as PNG file and optimized as much as possible using free console version of PNGOUT very small in file size. A stylish look is not important for me on my Windows computers. Important for me is a clear look easy to process by my brain and a very quick display refresh because of no transparency, fading and shading effects to calculate by Windows before refreshing the display. Of course I have disabled also all other graphic effects which means configured Windows GUI for best performance.
Best regards from Austria
7 posts Page 1 of 1
cron