User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Syntax highlighting, code folding, brace matching, code indenting, and function list
9 posts Page 1 of 1
Hi all,

I have a word file for OpenEdge 11.3. OpenEdge knows a keyword OR, which is correctly upper cased.
But when I use table name orr it is always corrected to ORr. Very annoying. I use this table all the time.

Is there any way to overcome this without turning off auto-correct completely?

I found some sort of solution...

The number of chars type with auto-complete configuration was set to 4. The moment I set this to 3 or less, the problem does still exist, but I can escape it by choosing orr from a list.
This is definitely not what I would like. A keyword should only be upper cased when it is a whole word, not part of a word.

Thanks in advance.

An auto-correction can be undone by executing Undo command, for example with pressing Ctrl+Z.

I downloaded the wordfile openedge113.uew from user-submitted wordfiles downloads page and put it into the wordfiles directory. Next I started UltraEdit and saved the newly created ANSI encoded file as Test.p which enabled OpenEdge 11.3 syntax highlighting for the file.

Then I typed or and a SPACE and it was corrected to OR as expected. Next I typed orr and a TAB and it was not corrected as expected. I tried other combinations of orr and or with non word characters like comma, semi-colon, colon, angle brackets, etc., but UltraEdit only auto-corrected or, but never orr.

Last I converted the file to Unicode and made the same tests as before and auto-correction worked always perfect and as expected.

Do you have read already all posts of topic Upper case keywords?

What is a word delimiter for the auto-correction feature is determined by a Windows function depending on Windows region and language settings or font, I'm not really sure which one. Therefore some questions?

Which version of UltraEdit do you use on which operating system?

Which encoding is used for the edited file (indicated in status bar)?

What do you have configured in Windows region and language settings?

Which font do you have configured?
Best regards from Austria
Thank you for your reply.

I think I have read most posts about upper case keywords, but they did not match my situation as far as I could see.

I use version of UltraEdit on Windows 7 Pro. ** UPDATE ** I just updated to version Same problem.
I am not sure what you mean with encoding, but I'll give you what I see in the status bar. I can see DOS and 1252 (ANSI -Latijns I).

My windows settings are Dutch, decimal sign , thousands separator . list ; metric, currency €. Keyboard is English US.

I use the default font I think. Consolas 10.

Pretty default I guess.

I found out that when I use an alternate name for buffer orr, in this case borr, the problem does not occur. It may have something to do with the keyword starting any word?
Please read the introduction chapter of power tip Working with Unicode in UltraEdit/UEStudio to understand text encoding, i.e. how characters of a text are stored in a text file with bytes (or more precise - a sequence of zeros and ones).

Your file is ANSI encoded (1 byte per character = max. 256 different characters) using Windows code page 1252.

There should not be any problem with auto-correction with your Western European (Dutch) region and language settings and with ANSI encoded file.

Could you post a code snippet on which the issue can be reproduced by you?

In the topic I referenced I wrote about an issue with auto-completion having an effect on auto-correction which should not be the case. Is there a difference with toggling Do not auto-correct structure members (items following "." or "->") at Advanced - Settings/Configuration - Editor - Auto-complete?

During my tests this option was checked, but I just typed or and orr without having real OpenEdge code and therefore nothing from file was parsed for auto-completion feature during my test.
Best regards from Austria
I already tried toggling (items following "." or "->"). There is no difference.

Code: Select all


FOR EACH orr WHERE orr.ord-code = ipiOrder NO-LOCK:
  DISPLAY orr.ord-code orr.klr-code.

FOR EACH borr WHERE borr.ord-code = ipiOrder NO-LOCK:
  DISPLAY borr.ord-code borr.klr-code.


Here orr is a database table, borr is the same database table, but just declared with another name.
Thanks for the code snippet. I could reproduce this issue with UE v24.00.0.49, v23.20.0.43 and v22.20.0.49 with the code snippet when

  1. Show auto-complete dialog automatically is enabled at Advanced - Settings/Configuration - Editor - Auto-complete (not enabled by default)
  2. Auto-correct keywords is enabled at Advanced - Settings/Configuration - Editor Display - Miscellaneous (not enabled by default).
I could not reproduce this issue in my initial tests with my configuration as I have Auto-correct keywords enabled, but have not enabled Show auto-complete dialog automatically. I use Ctrl+Space when I want to make use of auto-completion.

It is definitely a bug which I reported to IDM support by email. You should do the same. The more users report an issue, the higher becomes the priority for fixing it.

The best workaround I could find is having not enabled Show auto-complete dialog automatically and use Ctrl+Space to invoke auto-completion window.

Another possibility is using Ctrl+Z to undo the auto-correction after typing or before typing r to get the word orr. Auto-correction can be always undone with Undo command, not only in UltraEdit, but also in other applications (Internet Explorer, Microsoft Office applications, ...).
Best regards from Austria
Thanks again for all the work you put in.

I will contact support.

In the meantime I have turned off Show auto-complete dialog automatically.

I noticed (after your reply) that ctrl-z may undo auto-correct, but this is not very effective when typing much and fast...
This issue is fixed in public hotfix build of UltraEdit.
Best regards from Austria
Definitely so :D
9 posts Page 1 of 1