User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

General and specific configuration/INI settings
7 posts Page 1 of 1
I am used to have "UltraEdit" as an entry in the context menu for individual files and groups of files in Windows Explorer, using UltraEdit 13 under Windows XP and Windows Server 2003 (which is on the XP code base). This context menu is also visible in FreeCommander, my favorite file manager.

Having installed UE 13 on Windows 7, UltraEdit does not appear in this context menu.

Now, after having migrated to UltraEdit 24 (because of its native UTF-8 mode), I thought that this newest and latest version of my favorite editor would install itself again in the Explorer context menu. But nope. And I see no way in the UE configuration or elsewhere in its many menus to add UE to this context menu.

Please tell me how to get it there!
L.Willms
Advanced->Configuration->File associations
Check "Integrate with Explorer as:" in right pane
It's impossible to lead us astray for we don't care even to choose the way.
Thank you, that did help.

It was activated already ... I have to say that this is Windows 7 64-bit

So I had to look closer and found that the old FreeCommander 2009.02b does still not show UltraEdit in the context menu, but the newer FreeCommanderXE 64-bit does. I still use more the old one than the XE one because of some quirks in the XE's configuration.

I just needed a push to look at the right place.
> the old FreeCommander 2009.02b does still not show UltraEdit in the context menu, but the newer FreeCommanderXE 64-bit does

This might be an issue about the extension not being configured in the 32-bit registry properly. You might want to contact IDM support, as I think it might be fixable. I have a 32-bit UE that is in both 32 and 64-bit context menus, while my 64-bit UEStudio is only in 64-bit context menus.

In my opinion, a 64-bit app should register itself in both.
It is a known issue for me which I have not yet reported to IDM support by email that 64-bit UltraEdit registers only 64-bit shell extension, but not the 32-bit shell extension. Only 32-bit UltraEdit registers 32-bit and 64-bit shell extensions.

But that is not the only problem because ue32ctmn.dll installed with 64-bit UltraEdit is the same file (with exception of compile time) as ue32ctmn.dll installed with 32-bit UltraEdit and therefore does not work as it would try to run uedit32.exe instead of uedit64.exe. ue64ctmn.dll of 32-bit UltraEdit starts uedit32.exe while ue64ctmn.dll of 64-bit UltraEdit is different because it starts uedit64.exe.

So at the moment it is not possible to register 64-bit UltraEdit in context menu for 32-bit applications, except editing ue32ctmn.dll in hex edit mode with replacing UEDIT32 by UEDIT64 and registering this ue32ctmn.dll manually if the "hack" in DLL does not make the DLL invalid for Windows Explorer which I have not tested yet.

Now with first user missing 64-bit UltraEdit in context menu for 32-bit applications I have reported this issue to IDM support by email.
Best regards from Austria
Mofi wrote: Now with first user missing 64-bit UltraEdit in context menu for 32-bit applications I have reported this issue to IDM support by email.

Thank you.
I'm experiencing the same issue but on Windows 8.1 64-bit Enterprise Edition.

Great information from Mofi.

This has been officially reported as a bug and has been added to their issue tracking system for the developers to investigate and correct it.

In the meantime here's the contents of a .reg file you can use to update the registry so that it will work.

Code: Select all
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\*\shell\UltraEdit]
"Icon"="C:\\Program Files\\IDM Computer Solutions\\UltraEdit\\uedit64.exe"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\*\shell\UltraEdit\Command]
@="C:\\Program Files\\IDM Computer Solutions\\UltraEdit\\uedit64.exe \"%1\""



And here's the PowerShell code I'm using in my deployment script...

Code: Select all
$key = [Microsoft.Win32.Registry]::LocalMachine.OpenSubKey("SOFTWARE\Classes",$true)
$subKey = $key.CreateSubKey('*\shell\UltraEdit', $true)
$subkey.SetValue("Icon", "C:\Program Files\IDM Computer Solutions\UltraEdit\uedit64.exe", 'String')
$subKey = $subKey.CreateSubKey('Command', $true)
$subkey.SetValue($null, "C:\Program Files\IDM Computer Solutions\UltraEdit\uedit64.exe `"%1`"", 'String')
$key.Close()


You can change this from HKEY_LOCAL_MACHINE to HKEY_CURRENT_USER if you prefer.

Cheers,
Jeremy
7 posts Page 1 of 1
cron