User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Projects, workspaces, solutions, file management and CVS/SVN issues
7 posts Page 1 of 1
Even though I specified the password in the CVS configuration dialog, when I try to do CVS checkout, it hangs on the login command. When I execute the same command manually on the command line, it asks for the password, so I assume that something doesn't work in that area. Anyone encountered this problem? It seems to be doing this irrespective of the type of server I select.
Unfortunately, it seems that CVS support in UEStudio doesn't work correctly with SSH. I've tried both password authentication and valid private/public keys (had been checked in other app), but still I receive an error:
Executing CVS update command...
C:\Program Files\UEStudio\GNU\cvsnt\cvs.exe update "FILENAME_HERE"
cvs.exe update: warning: unrecognized response `'ssh' is not recognized as an internal or external command,
' from cvs server
cvs.exe update: warning: unrecognized response `operable program or batch file.
' from cvs server
cvs.exe [update aborted]: end of file from server (consult above messages if any)

Could it be fixed?
I hope ssh cvs access within UEStudio is fixed very soon. I too have the same issues as above.
I can login fine using the command line cvs.exe, but UE hangs when trying to login.

Built in CVS support was one of the main reasons why I bought UEStudio.
Dido I just do not get it, I do not mind that my hard earned money is helping develope an app that go's far beyond anything Microsoft has ever done,
as in MS FP 03 yet I have gone back to it to build yet another site, I do not have time to sit around waiting for this team to work out the bugs in what seems to be still in Beta stages, I have clients waiting ...... come on guys
is there a printed manual avaliable yet ???
Until Friday afternoon I couldn't figure out what you guys were taking about and why you had problems. I don't know if this is the same but here is what I'm having:

1) I downlaoded the trial version and have been using it for about 15 days. CVS integration worked perfectly. This is and awsome IDE and I thought, man I have to buy this.

2) Friday I purchased a copy and downloaded the latest version that the email link with my license key pointed to.

3) Installed it, put in the license key and now UEStudion uses nearly 100% CPU whenever it launches CVS. CVS cannot get any (or very little) CPU to even run. After about 10-15 minutes it will manage to login and then another 10 minutes it will checkout or update or whatever I asked for. When it is done UEStudio stops using CPU time and everything goes back to normal.

4) I did an experiment this morning and after starting a cvs update or commit I used task manager (have it running already) and lowered the priority or UEStudio and up the priority of cvs. It logged-in in about 15 seconds. UEStudio launches another CVS process to actually do the update/comment/etc... so you have to do it again, but then everything works. UEStudio is still using all avilable CPU, but CVS gets ahead of it for what it needs. After CVS is done then UESutdio goes back to using no CPU.

I'm guessing this is a process creation problem with UEStudio. I just don't know why it worked fine before I purchased it and why it is broken now. I installed it on another comptuer to check it out and it does the same thing.

Get incontact with the support team.
We were sending emails back and forth for a couple of weeks over this issue, and they sent me a hotfix which resolved my issues.

I suggest you do the same. Just mention 'Martin and his unix cvs issues' and they should know (ask for bradley..)


Update !

Seems the hotfix is now offical...

7 posts Page 1 of 1