User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Display customization and font issues
3 posts Page 1 of 1
I am sure this is a simple item I am missing in the configuration, but I want be able to disable the italics on some lines are shown in. I work with Typescript files and items in single quotes are italicized in the editor. This leads to UltraEdit not matching where I highlight, select with the mouse cursor, and the actual text line. This causes me to replace text I did not intend to, or to be in the wrong part of the line.

For instance, a text line looks like the following in the editor
import { Statistics } from '../DataStructure/Statistics';

Quite often, when I click at the slash before the S in Statistics, it appears to be properly highlighted in the italic text, but when I type, the cursor is actually in the word DataStructure, usually be 2-3 characters from the end, or the last u.
It is possible to change the font style of syntax highlighting groups on tab Syntax in Manage Themes dialog introduced with UltraEdit for Windows v20.00 and UEStudio v14.00 opened

  • in ribbon mode by clicking on ribbon tab Layout in ribbon group Look and feel on Themes item (second from left) or on down arrow below Themes and next on popup menu item Manage themes,
    or
  • in toolbar/menu mode with contemporary menus (the only toolbar/menu mode in UE v23.00 and v23.10 respectively UES v16.00 and v16.10) in menu Layout in submenu Themes on menu item Manage themes,
    or
  • in toolbar/menu mode with traditional menus (available since UE v23.20 and UES v16.20) in menu View in submenu Themes on menu item Manage themes.
The big advantage in comparison to former color configuration dialogs is that each change is immediately applied to underlying windows even without clicking on button Apply or OK with magnifying glass button in bottom left-hand corner being enabled as by default.

Select the language as displayed in status bar at bottom of UltraEdit window. Then select Normal instead of Italic of the appropriate syntax highlighting group.
Best regards from Austria
Thank you very much. That is exactly what I was looking for.
3 posts Page 1 of 1