User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Help with writing and playing macros
3 posts Page 1 of 1
I'd like to assign CTRL+SHIFT+SPACE to a macro (so that it matches the editor I've been using since '97), but UEStudio won't allow me to do it. I press the keys, but the "space" character is immediately removed after the key has been pressed.

I've deleted the mapping to "Display/redisplay function tip" and I'm still unable to do it. Is there anything preventing this from working?

I'm using UEStudio '17 Development Environment (x64) Version 17.10.0.15.

Thanks.
I have absolutely no problem to assign Ctrl+Shift+Space to a macro by clicking on ribbon tab Advanced in group Macro on down arrow right of item Configure and click next on popup menu item Configure macros.

UEStudio v17.10.0.15 displayed a message prompt asking me if I really want to assign this hotkey to the macro because of being assigned already to a command which is by default the command Display/redisplay function tip. I confirmed this and UEStudio assigned Ctrl+Shift+Space to the macro and as I could later see removed this hotkey from Display/redisplay function tip.

The macro was also executed on pressing Ctrl+Shift+Space. Assigning Ctrl+Shift+Space works also when being already assigned to an UltraEdit script on which UES also displays the message prompt. But the hotkey Ctrl+Shift+Space is in this case not automatically removed permanently from script, just temporary for this session.

I suppose another process running in background on your computer prevents the usage of Ctrl+Shift+Space in UEStudio at all. Do you also get nothing displayed after opening Advanced - Settings or Configuration - Key mapping when you try to assign Ctrl+Shift+Space to any command?

Open Windows Control Panel - Region and Languages, click on tab Keyboards and Languages and click on button Change keyboards. Is more than 1 keyboard installed? Yes, you may remove all you never use. But more interesting is what is configured on tab Advanced Key Settings. Is Ctrl+Shift+Space configured for an input language switch?

Also look on the advanced settings of display adapter. There is installed usually together with the display adapter driver a tool like hkcmd.exe executed automatically on startup of Windows and running as background process which defines hotkeys for quickly changing display properties like rotating the display or switching display from primary to secondary monitor for presentations, etc. Those hotkeys can be configured or completely disabled on not using them ever.

There could be also some other applications running in background which define Ctrl+Shift+Space as global hotkey and therefore UEStudio gets never the appropriate keyboard event message when Ctrl+Shift+Space is pressed on keyboard.
Best regards from Austria
Ahhh! Thank you for confirming. I didn't have anyone else to bounce this off of. I just realized that it was due to an AutoHotKey extension, i.e. my fault.

In an effort to have most of my favorite editor shortcuts (from HomeSite) work anywhere (NotePad++, Word, text area fields, etc.), I use AutoHotKey. Since CTRL+SHIFT+SPACE (";^+space::") was already globally/universally assigned, it was entering the mapped result instead of the "space" when pressing all the keys to assign the macro.

BTW, I've almost removed all "#IfWinActive" key bindings from AutoHotkey for UltraEdit as I'm surprised at how easy it is to reassign & customize everything. I was in the process of migrating to ColdFusion Builder, but syntax coloring (for multiple inline code types) and remapping is very difficult (if not impossible).

Thanks for getting back to me so quickly!
3 posts Page 1 of 1