User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
3 posts Page 1 of 1
When I compare two .CSV files, UltraCompare does not properly recognize fields defined in quotes which may contain commas. It separates the data in the field based on the comma(s) instead of treating it as a single field. Is there some way to adjust this?

JohnD
I have never used this feature of UltraCompare before. But I could see now that you are absolutely right. Interpreting the data in CSV files is not complete according to basic rules as described on Wikipedia page about comma-separated values. I can't see any session property or general configuration option to change this.

Please send an enhancement request email to IDM support to get in a future version of UltraCompare a CSV table comparison interpreting a separator within a double quoted field value as literal character, a double quote escaped with a double quote inside a double quoted field value as double quote and also line breaks within double quoted field values correct.
Best regards from Austria
Thanks, enhancement request sent.

JohnD
3 posts Page 1 of 1