User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
3 posts Page 1 of 1
Hello,
nearly every time I work with files I get an error msg when a backup file should be generated.
2017-08-18_09h26_49.png
2017-08-18_09h26_49.png (6.86 KiB) Viewed 134 times

First I thought this problem has something to do with access rights in the backup folder, but I get this problem in any folder.

Then I recognize I get more often this msg when I work on a network, it doesn't matter if I use the UNC path or it is mapped with a drive letter.

Can anybody reproduce this or has a similar problem?

Here my settings for the backup generation:
2017-08-18_10h07_48.png
2017-08-18_10h07_48.png (20.29 KiB) Viewed 134 times


Thanks for you support.
I cannot reproduce such a problem with 32-bit English UltraEdit v24.10.0.35 running on 64-Bit Windows 7 independent on editing a local file, a file opened from a mapped network drive, or a file opened from a network share using UNC path with default settings of UltraEdit with exception of file backup settings. I used the same folder path as you.

It perhaps help to enable the option Copy file instead of using rename when creating backup file at File Handling - Advanced in configuration, i.e. third option at Umgang mit Dateien - Fortgeschritten. As the backup file is always created in a configured backup directory and not in directory of the file, this setting should have no effect at all on backup operation, but I suggest nevertheless to change it.

And I suggest to run Windows Disk Cleanup (German: Datenträgerbereinigung) and let Windows cleanup the folder for temporary files.

You could find out why the UltraEdit can't create the backup file by using free Process Monitor from Sysinternals (Microsoft). Download the ZIP file, extract it to a temporary folder, run procmon.exe as administrator, confirm the license agreement (Microsoft!) and configure the filter with Path begins with C:\tmp\UltraEdit_Backup then Include and press the buttons Add and OK. Then click on last 5 symbols on toolbar with the exception of briefcase symbol with tooltip Show File System Activity to toggle off the other monitors and press Ctrl+X to clear the existing log. Now start UltraEdit, open and edit a file and save it. When the error message appears, switch back to Process Monitor and look on the lines if you can see an error because of a denied access.
Best regards from Austria
Hello Mofi,

Sorry for the late reply.

I tested the setting:

Mofi wrote: It perhaps help to enable the option Copy file instead of using rename when creating backup file at File Handling - Advanced in configuration, i.e. third option at Umgang mit Dateien - Fortgeschritten. As the backup file is always created in a configured backup directory and not in directory of the file, this setting should have no effect at all on backup operation, but I suggest nevertheless to change it.

And the problem doesn't appear again. Seems this is the solution :D

Thanks a lot.
3 posts Page 1 of 1