User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Syntax highlighting, code folding, brace matching, code indenting, and function list
7 posts Page 1 of 1
Hello

I cannot select the No Highlighting option from the dropdown on the bottom bar or from the Coding tab. Anyone have any ideas? It just reverts to the previously selected option.

Attachments

Do you have some more information for us on your problem selecting No highlighting from status bar or the Coding ribbon tab?

What version of UltraEdit do you use?

What is the name of the file (file name + extension)?

Has the file a shebang?

Would you please compress the entire folder displayed at Advanced - Settings or Configuration - Editor Display - Syntax Highlighting into a ZIP or RAR archive file and upload the archive file to your next post as attachment. If the file opened does not contain confidential data, add the opened file also to the archive. Transact-SQL is definitely not a syntax highlighting language installed with UltraEdit.
Best regards from Austria
Hello Mofi

UE version 24.10.0.24.

It does not matter which file type I try with, it will not allow the No Highlighting option to be selected.

ZIP archive file with wordfiles and sample *.sql file deleted by Mofi.
Can you change the highlighting to any other language? If so, can you then go from there to No Highlighting?
I can select another language, although sometimes I have to select it twice before it works. I cannot select No Highlighting no matter which language is selected first.

I have also just noticed that the language shown on the bar doesn't always correspond to the highlighting currently in use!
Okay, I could reproduce this issue with UE v24.10.0.24 with your *.uew files in wordfiles directory as well as with the standard *.uew files in wordfiles directory.

This is a bug of UE v24.10.0.24 as I could find out with next public released v24.10.0.32 which does not have this issue. And this issue also does not exist with currently latest public available version 24.10.0.35.

So the solution is updating UltraEdit. Click on ribbon tab Avanced on Check for updates or download the appropriate UltraEdit installer from UltraEdit Downloads page and run it.



I looked also on tsql.uew and improved it. Nothing was really wrong. But there was the invalid keyword END-EXEC containing the delimiter - and some duplicate words. a-zA-Z in function string can be optimized to a-z because UltraEdit runs the searches with the regular expression always case-insensitive. And the keywords (and delimiters) are better sorted in improved tsql.uew attached to this post.

Attachments

Best regards from Austria
Thanks Mofi, you are the best.

It was a standard tsql uew that I installed, so I hope your changes can be made available to other users.

What a great forum this is.
7 posts Page 1 of 1