User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Display customization and font issues
3 posts Page 1 of 1
Hi,

I've just used the latest UltraEdit Text/Hex Editor (x64) (Version 24.20.0.27) to open a PowerShell file, and I can't read it 8O
Basically, the main function keywords are black, with the background as dark grey, so there is minimal contrast difference making it nearly impossible to read.
I have used the Slate theme for countless years, and not had this problem before.
If I change to any other theme, then the colours/colors become readable.
If I change back to Slate theme, then the colours become unreadable again.
As far as I know, this isn't anything I can alter myself: the PowerShell syntax reading is in-built, and the colour selection is automatic based on theme.
Something must have changed in the last release, as I didn't have this issue before.
Can someone please verify this, or tell me how to resolve it? [Yes, I know selecting another theme "resolves" it :roll: :wink: ]

Thanks.

Edit 20 minutes later:

Okay, I have worked out I can edit the Theme's colours :oops: however, my Theme settings are all default, so I guess something has changed to the default theme/syntax colours recently.
Also, I was mainly looking at a Microsoft Exchange PowerShell file, so the commands were not being picked up by the syntax highlighter (default colour is red), so become Normal Text (default colour is black).

However, even with plain PowerShell commands, things like equals signs (=) are black on dark grey, which is challenging to read :?
PowerShell syntax highlighting is not built-in.

With having theme Slate selected:

  • With using ribbon mode select ribbon tab Layout and click on first group Look and feel on second item Themes or on the down arrow below this item to open the popup menu and next on first menu item Manage themes.
  • With using toolbar/menu mode with contemporary menus open in main menu Layout the submenu Themes and click on menu item Manage themes.
  • With using toolbar/menu mode with traditional menus open in main menu View the submenu Themes and click on menu item Manage themes.
Click in Manage Themes dialog on tab Syntax, select language PowerShell and customize the colors and font style settings.

It is advisable to have a PowerShell script file open on configuring its highlighting as every modification in this dialog is immediately applied on the underlaying windows without pressing Apply (save and keep window open) or OK (save and close window) as long as the magnifying glass button at bottom of the Manage Themes dialog window is enabled.

It is even possible to change the syntax highlighting definition for PowerShell itself. Open Advanced - Settings or Configuration - Editor Display - Syntax Highlighting, select language PowerShell if not already preselected, click on button Open and close configuration dialog window with button Cancel.

The opened file contains the syntax highlighting definition for PowerShell which can be modified now. On each save of this file UltraEdit reads the definition and applies it to the PowerShell file(s) opened in same instance of UltraEdit. So it can be immediately seen how the syntax highlighting changes with making modifications in the opened file powershell.uew.

The equal sign is blue with using Slate as installed with UE v24.20.0.27, see attached image. I suppose the theme Slate was modified by you already in the past. Click on top right button with tooltip Revert theme to defaults in Manage Themes dialog window.

The PowerShell syntax highlighting looks with theme Slate also good when clicking on tab Syntax after selecting PowerShell on button Reset to apply the All Languages color and font style settings also to language PowerShell.

Attachments

Best regards from Austria
Hi Mofi,

Yes, "built-in" was inaccurate, as I found I could edit the colours myself :oops:
What I really meant was that both the Slate Theme and the PowerShell Syntax are bundled with UE, and have default settings (you can even revert any changes you make back to default in the GUI, it appears).
However, the default colour scheme for PowerShell in the Slate theme has changed in the latest release, and this change makes it unreadable (in my opinion). :?
Now, I now know I can go through and change the colours to whatever I want, but that really doesn't address the issue of the defaults being whacky. I have always used the default colours up until now.
It appears to have been a change from v24.10 to v24.20, where a lot of changes to highlighting were done in the main program.

Thanks.

Update 5 minutes later

I've just found out that if you click the "Reset" button in the PowerShell colour selection under the Slate theme, then all the colours revert to pre-v24.20 colours :)
So v24.20 is defaulting to a "bad" set of default colours (the same selection as your screenshot above), and you have to manually click "Reset" to get the "good" set of colours.

Update 15 minutes later
I've found a few things out
1) The latest UEW files were not being copied to my APPDATA directory, which meant I had an old PowerShell UEW file and it didn't offer the same Highlighting "sections" as the new one. So I renamed my "wordfiles" directory, re-launched UE, verified a new "wordfiles" directory was created with the latest UEW files (from under Program Files). However, the colour issue still persisted
2) I could correct the issue by using the "reset" button next to the PowerShell colour syntax, and then saving the modified Slate theme. This then created a "themes/overrides" directory in my APPDATA area, with a "Slate.ue-theme" file.
3) Looking in the new default Slate theme file (under UltraEdit\default data\themes in the Program Files directory), then I can see that the PowerShell section has a whole bunch of colours defined, whereas none of the other languages does. This is different than the theme file from v24.10 (verified on another computer), so I can only assume IDM have pushed this out by mistake in the latest build v24.20.

Update 2 hours later
I reported the issue to IDM via the support form.
I have received an email back (in under 2 hours! very impressive!) acknowledging that the they have re-produced the issue and they will ask the devs to look in to it :)

Update 2 weeks later
IDM have fixed the issue in v24.20.0.33, so update when available :)
[You will need to remove you "themes/overrides" file for the Slate theme, to go back to defaults]
3 posts Page 1 of 1
cron