User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Help with setting up and configuring custom user tools in UltraEdit (based on command line input)
4 posts Page 1 of 1
Hi I am trying to use UltraEdit as the default editor for iPython.

The problem is that in order for it to work correctly iPython must be able to start UE from the command line with a new file and then wait until UE closes that particular file. Is there a command line option to do this? Preferably I would like to be able to leave UE open and have it return control when just that file closes.

Thanks,
Stephen
It's no problem to run UltraEdit with a new file from command line. Just specify the full file name of the new file although it does not exist. You must have the option Create a new file if file specified on command line does not exist checked at Configuration - Editor - New File Creation (by default it is checked).

But I think, leave UE open and just close the file will not work. I guess, iPyhton waits until the application it has started is terminated. That's the Windows standard when an application calls (not starts) another application.
Best regards from Austria
Resurrecting this thread because I have the same problem. To clarify, opening UE from iPython (and git and probably any other external shell application) works, but in this case the purpose of opening the application is for the user to edit and save a file then close it, after which the external application does something with that file.

For example, iPython has an %edit function, where it opens an external editor for the user to alter a block of code. When the user is done making changes, the file is saved and closed. After the file is closed, iPython kicks in and executes that code. What in reality is happening is that iPython will open UE, but will not wait for the user to make changes, save and execute. It will execute the unaltered code immediately, and even after changes are made, saved, and closed, the altered code is not executed.

Maybe a command line argument could fix this?
For the complete answer read MongoDB - EDITOR variable - MongoDB shell - Windows 7.

Short answer: With setting Allow multiple instances not enabled, the setting Maintain separate process for each file opened from external application should be checked at Advanced - Configuration - Application Layout - Miscellaneous. This feature/setting is available since UltraEdit v18.10.
Best regards from Austria
4 posts Page 1 of 1
cron