User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
15 posts Page 1 of 1

I'm using UltraEdit 11.20b.

Whenever I open a file in UltraEdit, it opens instantly. However, when I try saving documents, it takes ages, and UltraEdit appears to freeze (the user interface goes blank white except the title bar and the Start Menu bar). It does actually save, and UE does come back to life and work fine until the next save.

When I say ages, I mean 54 seconds for a 400 line PHP script.

It has been doing it for a while, so much so that I decided to reformat my hard drive (due also to other reasons) in the hope that it would be fixed. However a fresh install of windows and UE hasn't worked. Still long save times. This same file in notepad saves instantly.

It is very frustrating when, say, I want to just update my 'latest news' page on my website, which isn't so big, and UE freezes for a minute every time I save my changes.

Does anyone know a solution?

I don't have any of the backup options set, or 'delete original file before save' etc. Disabling code folding doesn't make any difference. Nor does highlighting it as 'no highlighting'.


54 seconds for saving a local file? Are you sure that not another program like an anti-virus program is causing this long delay. I'm pretty sure that this long delay is not caused by UltraEdit. I suggest to use free Filemon or Process Monitor from Sysinternals (Microsoft) to look what is happening when you save a file.

Have you tried to save your PHP script with Save As with the extension .tmp just for testing if this long delay exists only for PHP files?

Extra hint: Even if you have installed everything new, use the Windows defragmentation tool now (better once per month).
Hi Mofi,

Resaving to .tmp didn't work. I've just cleared all my .tmp files out while I thought about it since you mentioned .tmp - 2.8 GB of tmp files in my profile. That didn't help.

I've just run Filemon but I can't see anything wrong as such.

Would you be willing to take a look at the results? (Link to file deleted.)

As you can see, at line 229, the system appears to stop between 41.05 and 41.42 seconds. (I ran the test twice and iexplore didn't show up first time; I think it just happens to have run last on that log.)

I've terminated all terminable running processes, to no avail. I've also disabled Norton which made no difference.

As I mentioned in my first post, this only happens in UltraEdit; all other programs are fine, saving files of varying sizes in their respective formats.

What's the sharing violation on line 225?
Software For Metalworking
Hi mrrainey56,

That is a very good question, and one which I don't know the answer to at this moment.

The files are on a network drive, mapped to our 'server' which hosts the files, printers, intranet etc for my house. Apache is running on the server, but that shouldn't have the files held open every time I try and save should it? No-one else touches the files.

I'll try such things as restarting Apache tonight; being on the server, that won't have been rectified with the reformat of my hard drive.

I'll let you know what happens.

The sharing violation seems to be the problem. If you look on the time difference from line 225 to 230 you can see that it is 43 seconds.

And I thought that you save it locally which means on your hard disk and not on a network drive on a server. Long timeouts are often caused by network configuration errors because network timeouts are set to several seconds in comparison to local file access timeouts which are only a few milliseconds.

I'm not an Apache or PHP expert but I guess, the Apache server is caching a PHP file requested once by a user to use the already compiled version for speed improvement and so locks the PHP file to disallow changing the cached PHP file. But it could be also simply a PHP or Apache configuration error.
Best regards from Austria
Hi again,

I've just restarted the Apache service, having been working on PHP scripts, including the same one several times, this evening. It has just started the delayed saving again, yet notepad and any other software saving files to the network does not have this delay.

I still believe that this is an UltraEdit problem.

Verify in the configuration dialog of UltraEdit following settings:

File Handling - Miscellaneous - Lock file for write while editing should be NOT checked.

Select at File Handling - Temporary Files either Use temporary file for editing (normal operation) or one of the other 2 options with a large enough value at Threshold for above (KB) so you open your PHP files always with a temp file.

File Handling - Advanced - Check short names against files already loaded to prevent loading two copies of same file should be NOT checked.

At File Handling - Backup either select No Backup or specify a Default Backup Directory on your local hard disk or if you want backups in the directory of the file see next suggestions below.

Try it with File Handling - Advanced - Copy file instead of using rename when creating backup file checked.

Try it with Delete original file before saving the file checked.

See help of UltraEdit for details about all these file handling settings.
Best regards from Austria
Hi Mofi,

The only one of those options which was set differently was 'check short names against those already open...' - i've now unchecked it.

I'll see what happens and report back.


I have been using UltraEdit for HTML/CSS files for many years now and have always been pleased with it.

After my recent upgrade - I don't know what I did, but it was giving me errors. I had to rename the IDMComp directory on my computer to put things right.

But since then I have a problem with files requiring several seconds for save. These are not large files at all. I looked in the forum and found this topic. I changed what was suggested in the configuration, but still it is very slow on file save which takes 12 seconds for an 80 KB file. Sometimes with a large file the program says "not responding" but eventually saves.

Can anyone give me an idea of what I need to do to put it right? I have uninstalled the program and started again, but it has not worked.

This issue is definitely caused by a network delay or a device not responding quickly.

First, as written several times in forum, the setting Load/restore printer settings should be unchecked at Advanced - Configuration - Editor - Advanced when the default printer is a network printer or a local printer not always turned on.

Second, if that does not help, we need to find source of the delay by using free tool Process Monitor of Sysinternals (Microsoft).

  1. Start UltraEdit (or UEStudio), open a file where saving takes long time, make a change like inserting a space, and removing it immediately with key BACKSPACE.

  2. Download ZIP file of Process Monitor and unzip it to any directory.

  3. Double click on procmon.exe to start it and accept the EULA (Microsoft).

    Note: Administrator privileges are required for running this tool.

  4. It is advisable to use a display filter on first approach as otherwise the log could be very large and therefore difficult to analyze.

    So select Path contains name of file without file extension and path then Include and press button Add.

    Close filter configuration dialog with button OK.

  5. Process Monitor can log

    • registry activity,
    • file system activity,
    • network activity,
    • process and thread activity and
    • profiling events.
    We are first interested in file system activity only for finding out what causes a several seconds delay on file save.

    Therefore from toolbar of Process Monitor the last 5 symbols from right side should be clicked to toggle them all off with one exception: the symbol with a filing cabinet with a magnifying glass with tool tip Show File System Activity. This must be kept enabled.

  6. There are 2 useful columns available for this task which are by default not enabled. So right click on header row of the columns to open context menu and left click on Select Columns context menu item. Check Relative Time (time since starting log) and Duration (time an operation needed) and close dialog with button OK.

    The two additional columns are appended to end of list which is not practical for evaluating results of the log as not visible without horizontal scrolling.

    So left click on header of column Relative Time, hold left mouse button and move the column to left in column header row as far as possible. Then move horizontal scroll bar to left and move column Relative Time once again to left between Date & Time and Process Name column.

    Redo this column moving with column Duration to put it also left of Process Name column.

  7. Click now on fifth symbol from left in toolbar of Process Monitor to clear the log (see status bar about number of records) or press Ctrl+X.

  8. Next switch with Alt+TAB or mouse to UE/UES and save the modified file without real modification.

  9. Switch back with Alt+TAB or mouse to Process Monitor and stop capturing by clicking on third symbol from left on toolbar or pressing Ctrl+E.

  10. Most interesting is now a line with a large value in column Duration or where a large gap is between two lines in column Relative Time. This operation is responsible for the long delay.

    Is the operation visible (large duration value) and is the process UltraEdit?

    Is the operation causing the long delay not visible (large gap between two relative time values)?
The log can be saved with File - Save into a *.pml or *.csv file. The *.pml file can be opened only by another user using same version of Process Monitor whereby a log from 64-bit Windows can be viewed only with Process Monitor running on 64-bit Windows. The CSV file format can be opened on any machine with Excel or UltraEdit. So you could save the log to a CSV file, compress the CSV file with ZIP or RAR and upload the archive file as attachment to your next post for analysis by me or somebody else if you can't see by yourself what is causing the long delay.

It is possible that the long delay is not caused by a file operation on the file included in display filter. In this case it would be necessary to press Ctrl+L or click on sixth symbol from left on toolbar and Remove the initially defined include filter. After pressing button OK in filter dialog and perhaps re-enable the display of the registry and network activities by clicking on their symbols in toolbar, the reason for the long delay on file save should be found in the log.

Please report back what you could see in log of Process Monitor and we can perhaps suggest which setting to change in configuration of UltraEdit to avoid the long delay on file save.

Finally two important questions:

Is the file stored on a local drive, a network drive with a drive letter, a network share using UNC path, or a remote server using FTP/SFTP/FTPS?

Is backup feature enabled and where are the backup files stored?

PS: Read also forum post about Disk Cleanup, especially if never done it on current machine.
Best regards from Austria

Thank you very much for your reply and for going into so much detail.

I've been through and there have been a number of problems: the longest process was the searchindexer which I have now switched off, but it didn't at first make any difference.

I have always had backups without any delay in saving, but I switched it off and now it's all working fine.

thank you once again!

It would be interesting for me why creating the backup causes a long delay. I remember now that another user has had the same issue months ago. But it was not further analyzed with Process Monitor what exactly was responsible for the long delay caused by another process as UltraEdit created the backup file.

Does it make a difference if Copy file instead of using rename when creating backup file at Advanced - Configuration - File Handling - Advanced is checked with backup feature also enabled?

What happens when running msconfig, switch to tab Startup, uncheck ALL applications being configured for automatic start on Windows start, press OK, restart Windows, open UltraEdit, edit a file and save it with backup feature enabled?

If there is now no delay anymore on file save, one of the applications automatically started is responsible for delay and it would be interesting which one and if it is possible to configure this application different to avoid this delay. The applications can be enabled again for automatic start with Windows using again msconfig - Startup.
Best regards from Austria

This problem has raised it's head again but this time whenever I do a SaveAs. I'm using a template file and then copy/pasting information, there are lots of these files so I can't get away from using a SaveAs.

I've been through the Process Monitor and it appears to be the CreateFile and WriteFile process that is taking it's time.

I've also been through the other suggestions in this thread and it's made no difference.

The log file for one of the CreateFile entries says:

Desired Access: Generic Read/Write, Disposition: OpenIf, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, AllocationSize: 0, OpenResult: Opened

Does this help?

Sorry if it's not much information, but I'm not sure where else to look.
I'm quite sure another process is causing the delays on save.

Do you have changed something on UltraEdit (version, configuration)?

No, then something other must have changed on your machine causing now the delays on save. My first suspicion would be an anti-virus application which updated and intercepts each file access especially creation and write accesses and causes the delay.

The only reasons for an unexpected local (on own hard disk) file loading/saving behavior of UltraEdit not caused by another running process I'm aware of are:

  • Folder for temporary files is full.
    The solution is cleaning up this folder as suggested on Cannot create/open new file. I suggested this already once before.
  • Environment variable TEMP did not exist as UltraEdit was started.
    This can be verified with opening Advanced - DOS Command, entering set temp and click on button OK. Environment variable TEMP is not defined if an error message is captured by UltraEdit instead of a line with TEMP=...
  • There is a file system error.
    The solution is opening a command prompt window using Run as administrator, enter chkdsk C: /F (fast, secure also for SSD) or chkdsk C: /F /R (can take hours, run over night, don't use on SSD) and confirm running check disk on next boot of Windows. Then restart Windows and let 10 seconds countdown run out to run Windows check disk tool. The result can be found after check disk finished and Windows restarted in application event protocol of Windows. (Type is Information, Source is Winlogon.)
Best regards from Austria
15 posts Page 1 of 1