User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
6 posts Page 1 of 1
How do I configure UEStudio 6.40+2 to work wth Microchip C30 v3.01?
I am using Windows XP Pro SP2.

I think the UEStudio menus are obvious. I selected Build, Select Compiler; Build, Set Compiler Options; Build, Set Compiler Paths.

As you can see from the output something is wrong. For starters, what is MPLINK and how do I get rid of it?
Why is the pic30-gcc.exe compiler in the lib path?

--------------------Configuration: ZSE - Debug--------------------
C:\PROGRA~1\MICROC~1\MPLABC~1\BIN\\MPLINK --heap=512 /m ZSE.map /o ZSE.EXE /l C:\PROGRA~1\MICROC~1\MPLABC~1\BIN\pic30-gcc.exe\lib C:\PROGRA~1\MICROC~1\MPLABC~1\BIN\pic30-gcc.exe\LKR#ZSE.EXE`
'C:\PROGRA~1\MICROC~1\MPLABC~1\BIN\\MPLINK' is not recognized as an internal or external command,
operable program or batch file.
C:\PROGRA~1\MICROC~1\MPLABC~1\BIN\\MPLINK --heap=512 /m ZSE.map /o ZSE.EXE /l C:\PROGRA~1\MICROC~1\MPLABC~1\BIN\pic30-gcc.exe\lib C:\PROGRA~1\MICROC~1\MPLABC~1\BIN\pic30-gcc.exe\LKR#upload`ZSE.EXE
'C:\PROGRA~1\MICROC~1\MPLABC~1\BIN\\MPLINK' is not recognized as an internal or external command,
operable program or batch file.
Z16080Upload.exe ZSE.EXE
'Z16080Upload.exe' is not recognized as an internal or external command,
operable program or batch file.
ZSE.EXE - 0 error(s), 0 warning(s)
I don't have Microchip C30, so I can write only about something general.

Have you specified the correct path to the compilers directory at Build - Set Compiler Paths for Microchip C Compiler?

If you click on Build - Set Compiler and click on Microchip C Compiler you can fine tune the configuration and adapt it to your Microchip installation. Best is to save a modified configuration local and do not modify the standard in the UEStudio program directory because the standard configurations are normally updated during UEStudio updates too.

Note: Most configurations for the various compilers supported by UEStudio are written by users of UEStudio and not IDM. Therefore it is possible that a standard configuration works perfect for the user who has created it, but not for you with your environment.

It's also possible that a newer version of a compiler is installed with a different directory structure or needs different command line switches. In such cases it is necessary that you adapt the configuration with the help of the manual of the compiler.

I have done that for DJGPP v2.03 too because the CPU switches defined in the standard DJGPP Application configuration are obsolete for this version and therefore I got always 2 warnings on every compile until I changed the CPU switches to what this version of DJGPP requires (and saved it in a local configuration).
Best regards from Austria
Thanks Mofi.

I didn't notice that Edit Configuration button the first time,
What A MESS! It will take at least 2 months to figure it out, which I might have time next year to do it. ARRG! Does anyone know where there documentation on this stuff?
Or better, someone can post a *working* version of their configuration.
Hello,

I've been using UEStudio to work with Microchip's C30 compiler. Below is the configuration I put together (modified from the C18 settings that come standard). There's a space to specify the processor but I have just hard coded it all in for the moment. (I'm compiling for a PIC24FJGA004.)

I will likely post a new file without the hard coding and with more of the configuration handled in the compiler options dialog but for the time being this should get you going.

Hope this helps. If anyone finds this useful and makes more progress on tightening the whole thing up before I get a chance please post your changes & improvements. Thanks!

|Andrew|

-------------------------------------------

# ----------- Microchip C30 configuration ------------
# --- general --------------------------------------
# $P - project name
# $Pp - path to project directory
# $Pn - project name
# --- compile --------------------------------------
# $I - input full name
# $Ip - input path
# $In - input name
# $Ie - input extension
# $O - output file
# $Op - path to output file
# $On - output filename (without path)
# $Oe - output extension
# $R - release/debug setting for compiler
# --- build ----------------------------------------
# $T - target full name
# $Tp - target path
# $Tn - target name
# $O - output file
# $Op - path to output file
# $On - output filename (without path)
# $Oe - output extension
# $R - release/debug setting for linker

[Settings]

Target =
Category&01 = DEFAULT RUN CONFIGURATION
Working Directory =$Pp
Category&02 = COMPILER OPTIONS
Memory Model = s|l
Linker Script = p24FJ64GA004.gld
Processor =
Compiler = pic30-gcc
Linker = pic30-ld
Excluded Files = Excludes
Compiler Options = -Opa-
Linker Options =
Debugger=

[SettingsInfo]
Target = Provides a space for you to specify an output file and location of the program that the linker creates.
Working Directory = Provides a space for you to specify the directory in which executing occurs. If you do not specify a directory, executing occurs in the directory where the executable is located.
Excluded Files = This will exclude the file(s) included in this UE project group from the build.
Compiler Options = Provides a space for you to specify an additional compiler options.
Linker Options = Provides a space for you to specify an additional linker options.
Memory Model = s-small, l-large.
Debugger=Provides a space for you to set the debugger you want to use to debug application.

[Variables]

CPATH =C:\Program Files\Microchip\MPLAB C30
MCC = $(CPATH)\bin\$(Compiler)
MCL = $(CPATH)\bin\$(Linker)
LINKSCRIPT = $(CPATH)\support\gld\$(Linker Script)
UPLOADER = Z16080Upload.exe

[Environment]

[General]

TargetExt = .cof
ReleaseOut = Release
DebugOut = Debug
UseFullPaths =1
UseDosNames = 0
Excludes = $(Excluded Files)

[MakeCommands]

upload = Upload Application
debug=Start Debugger
makef=Show Makefile

[Upload Application]

Title = Upload $T
Cmd0 = $(UPLOADER) $T
Depends = $T
ShowWindow = 1
DisplayConsole = 1

[InsertFiles]

[FileGroups]

FGO = .o;

[GroupFormats]

FGO = %s

[Build]

Out = $T
Depends = $FGO
Cmd0 = ""$(CPATH)\bin\$(Compiler).exe" -mcpu=24FJ64GA004 $FGO "$(CPATH)\lib\libpPIC24Fxxx-coff.a" -o"$T" -Wl,-L"$(CPATH)\lib",-Tp24FJ64GA004.gld,-Map="$Tn.map",--report-mem
Cmd1 = ""$(CPATH)\bin\pic30-bin2hex.exe" "$T""

[.C]

Out = $In.o
ReleaseFlag = -O
Cmd0 = ""$(CPATH)\bin\$(Compiler).exe" -mcpu=24FJ64GA004 -x c -c "$I" -I"$Ip" -o"$(Out)" -g -Wall

[.s]

Out = $In.o
ReleaseFlag = -O
Cmd0 = ""$(CPATH)\bin\$(Compiler).exe" -mcpu=24FJ64GA004 -c "$I" -I"$Ip" -o"$(Out)" -g -Wall

[Start Debugger]
Title=Debug $T
Cmd0=$(Debugger) $T
Depends=$T
ShowWindow=1

[Show Makefile]
Title=Show makefile
Cmd0=uestudio makefile
ShowWindow=1
DisplayConsole=0
Thanks Andrew.v2, that worked. I just had to change to short filenames for some reason. Otherwise it would complain that it could open C:\Program. I even tried to put quotes around the statement but that didn't work.

CPATH = C:\PROGRA~1\MICROC~1\MPLABC~1


Now if UEStudio would NOT move my mouse to the OK button when I open up the Select Comiler dialog box. If I wanted that feature I would have set it in the mouse settings in the Control Panel.
Hi Andrew,

Thank you for your post, it is very helpful. I am using UEStudio'09 with Microchip compiler C30 and copy all your configurations posted apart from changing the chip type to 24HJ256GP206. I've got it compiled but without generating the *.cof file so that pic30-coff-bin2hex.exe complains the cof could not be found. I can't figure it out. Can you help?

Best regards

Vincent
6 posts Page 1 of 1
cron