User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

General and specific configuration/INI settings
12 posts Page 1 of 1
Hello!

Is it possible auto-complete the word like test:nValue?

If I write tes, auto-complete proposes test.

When I write test:nV, auto-complete proposes test and not test:nValue.

Regards Maurizio
If character : is specified in the syntax highlighting wordfile for your language as (word) delimiting character the answer is no.

Well, with active IntelliTips support it maybe works for *.cpp files, but I don't have experience with C++, only with C.
Best regards from Austria
Thanks Mofi

I use Windows XP Prof, UEStudio 06.40a setting for Harbour (ex clipper).

I modify the delimiter in wordfile.txt and erase the character : but that doesn't work.

Regards Maurizio
You are right and I was wrong. After playing a little it looks like for finding words for auto-completion in the current file the delimiters for syntax highlighting are not used. It looks like the delimiter characters for auto-completion are all characters which in normal text are used as word delimiters (space, tab, ...) or as punctuation marks like .,;:! and the quotes and math symbols, i.e. all non word characters according to Unicode standard.

I think you have to contact IDM support by email and ask if there is a possibility to specify the delimiters for auto-completion.
Best regards from Austria
Hi all,

I'm working with an old fashioned, not so much structured programming language. There are a lot of normal function names and variables with dots in it, like "my.first.variable". This is no structure, just a variable.

If the following option is not set: "Do not auto-complete structure members (items following "." or "->")"

I thought that something like the variable above would be completed in one go. But UE stops at every dot. Is there a way to autocomplete words regardless off any dots?
--> I'm not talking about keywords, I have this problem with buffered text. Maybe in keywords dots are no problem!

cu
Richard
I have already looked once if it possible to specify which characters are interpreted as delimiters for the auto-completion - see the posts above. And nothing has been changed since I have posted this. I think the help for this setting is not detailed enough to really understand the purpose of this setting.

I can't see any difference caused by this setting on auto-completion by Ctrl+Space for my 'C' files. Maybe this is because I have the . NOT in the list of delimiter characters in the wordfile at the language definition for 'C' files.

I think there is no possibility to get something like "my.first.variable" displayed at once in the auto-completion dialog after entering "my." and press Ctrl+Space which I honestly also miss in some cases.



Update on 2012-07-12: To get into auto-completion list also strings containing a . it is important that the . is not specified as word delimiting character in the wordfile used for syntax highlighting the active file. To verify this open a file where . should be not interpreted as word delimiter and which is syntax highlighted. Open now Advanced - Configuration - Editor Display - Syntax Highlighting. The language used to syntax highlight active file is already preselected. Open the appropriate wordfile by clicking on button Open right to language drop down list. Close the configuration dialog with button Cancel. Now look on the line starting with /Delimiters = in the opened wordfile below the line containing the language name. This line should not contain character .

Further the name of the setting Do not auto-complete structure members (items following "." or "->") was wrong a very long time in many versions of UltraEdit and UEStudio. The correct name for this option is:

Do not auto-correct structure members (items following "." or "->")

It is an option of the auto-correction feature and not of the auto-completion feature. This mistake in name was finally corrected in UEStudio v12.10.0.1003 and in UltraEdit > v18.10.0.1016.
Hi Mofi,

so I think I have to live with this. It's only that I find auto-complete a little bit unhandy, compared with other popular editors. I.e. if you press "CTRL-SPACE" and AC finds nothing the frame opens and you have to close with ESC to get rid of it. But this is the only point with that software which is annoying sometimes.

Regards to Austria
Richard
I've set up an autocomplete file containing the names of all variables used in our application. Some of the variable names are similar and long so the idea is to reduce keystrokes and improve accuracy. The file contains upwards of 14,000 entries.

In the UltraEdit configuration settings I've got 'Show auto-complete dialog automatically' enabled after 3 characters are typed.

So, to give a rather simplified example, say I'm writing some code to access the invoice file INV.

Conveniently the variable names are always prefixed by the file identifier, so the INV file contains these variables -
INV-NUMBER
INV-CUST-TITLE
INV-CUST-FORENAME
INV-CUST-SURNAME
INV-DELIV-ADDRESS-LINE-1
INV-DELIV-ADDRESS-LINE-2
INV-GROSS-AMOUNT

etc

Typing INV brings up, as expected, a dialog box (with a scroll bar, because of the number of variables) containing -
INV-CUST-FORENAME
INV-CUST-SURNAME
INV-CUST-TITLE
INV-DELIV-ADDRESS-LINE-1
INV-DELIV-ADDRESS-LINE-2
INV-GROSS-AMOUNT
INV-NUMBER

etc

I can of course use the scroll bar to navigate to the required field and press tab to copy the value into the editor.

But I want to be able to continue typing, for example -CUST, and have the list automatically reduce to -
INV-CUST-FORENAME
INV-CUST-SURNAME
INV-CUST-TITLE

etc

But as soon as the hyphen (-) is typed the dialog closes.

As an experiment I edited the autocomplete file, changing all the hyphens to underscores.
Then, typing INV_CUST_ brings up
INV_CUST_FORENAME
INV_CUST_SURNAME
INV-CUST_TITLE

etc

which is exactly what I expect. But with hyphens - not underscores.

I've got this working in other editors but with UltraEdit the hyphen as delimiter seems to be set in stone.

Any ideas?
Hi noggin!

This is possible as you can see below on the collage.

auto_complete_delimiters.png
Collage showing configuration for strings with hyphens in auto-completion file being interpreted as word.
auto_complete_delimiters.png (8.93 KiB) Viewed 1379 times

It is important that the syntax highlighting language applied to active file does not contain the hyphen character as word delimiter for getting interpreted the strings in auto-completion file with hyphen characters inside as a word.
Best regards from Austria
Hi Mofi

Thanks for the quick reply.

The problem was in the syntax highlighting file (which you mention) so by disabling hyphen as a delimiter it now works.

A couple of other observations -

1) Autocomplete also checks keywords that are defined in the syntax highlighting file. To explain...in addition to the variable names I've now added language keywords to the autocomplete file. So these of course overlap with the keywords that I want highlighted. In my case I'm using Cobol (yeah yeah I know :cry: ) so for example I've got 'PERFORM' in the autocomplete file and 'perform' (lower-case) in the highlighting file. Typing perf now brings up in the dialog box -

PERFORM
perform

PERFORM comes from autocomplete - I know this because it has a single space at the end (as defined in the file, to save keystrokes)
perform must come from highlighting - there is no space at the end

Accident or by design?

There may be way around this but I can live with it.

2) Its probably obvious but if either of these files are changed then UltraEdit needs to be closed and reopened.
  1. The help page about Auto Completion lists the sources from which the strings are loaded for the auto completion window. Syntax highlighting wordfile is the first source.

  2. A restart of UltraEdit after editing words in the syntax highlighting wordfile or the auto-completion file is not necessary if the file is edited within same instance of UltraEdit. UltraEdit recognizes changes in files used as source for syntax highlighting and auto-completion on save. But if the wordfile or the auto-completion file is modified outside of the instance of UltraEdit using them with another text editor or with another instance of UltraEdit, then it is necessary to restart UltraEdit. UltraEdit does not periodically check last modification date in background for files used as source for syntax highlighting and auto-completion as it does by default for opened files for editing.
Best regards from Austria
Yes that explains it very well.

I always seem to need to reload UltraEdit to make configuration changes effective - and I am making those changes using UltraEdit itself, not via an external editor like NotePad.

But I suspect that I'm on an old version :(

Anyway thanks for your time
12 posts Page 1 of 1