User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

General and specific configuration/INI settings
8 posts Page 1 of 1
I would like to configure UE to always give the new files I create an extension of .txt.
Is this possible.
TIA
Chris
No and yes!

During "Save As" the created extension is defined by UltraEdit by the file type below the name field. If you select *.txt, it will be .txt. The current file type setting is always stored in the INI file of UltraEdit. So if you select once .txt and never change it, .txt will be used always for new file.

You can modify the list of file types at Advanced - Configuration - File Types. Bring file type .txt to top of the list. Of course, if you delete all file types except *.txt, new files will be always saved as .txt. But this "solution" is not very good, because opening files with different file extension then cannot be done easily anymore with the standard file open dialog.
Best regards from Austria
That's exactly what I want.
Many thanks for replying so promptly.
Regards
Chris
I'm using UE 12.20a+4 and am unable to make .txt my default. I've tried the posted suggestion of moving .txt up in the extension list but my new files always default to the second entry of *.*. Any advice would be appreciated.
I tested again what I have written with UE v12.20a+4 and the Save As dialog still uses by default the last used file extension. UltraEdit saves the last used file extension in uedit32.ini with

[Settings]
Save Filter=3

Value 3 means 3rd entry in the drop down list. In your case after moving up *.txt to top of the file extensions list this setting should have the value 1.

It's important for changing the file extension (= this setting) that you first select it from the extension list and then enter the file name WITHOUT dot and extension (name only) and then save the new file. Next time the default in the extensions list should be the extension you used before.
Best regards from Austria
Thanks, Mofi. Somehow my .ini file got corrupted. After uninstall/reinstall it's working perfectly.
When you open a new file and select Save As, how can you make UltraEdit automatically add the .txt file extension?
2rsd
Advanced->Configuration->File Types, move *.txt to the top of the list, press OK.
It's impossible to lead us astray for we don't care even to choose the way.
8 posts Page 1 of 1