User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Two- and three-way folder compare and merge issues.
6 posts Page 1 of 1
If I'm doing a folder compare between two read-only directories, is there a way to merge (overwrite/replace) them without having to manually go into explorer and uncheck the read-only flag?

c:\repository\foo\bar.c -> \\anotherPC\c$\foo\bar.c
Short answer for a short question: NO.
Best regards from Austria
I'll have to write to IDM and suggest it. Thanks.
I had send in a request asking for this also.
Then I noticed this was in the forum so there are at least two request.

This is what I send to IDM:
I am using UC Pro 6.10.

When in UC and doing a folder compare, and the replace file is read_only it would be nice to be able to make the replacement file not read_only without having to manually go into file manager and clear the read-only flag.

Being able to do a alternate (secondary) mouse click and show properties of the file would work.

Even better would be a message asking to replace the file even if it is read_only.
We use both UEStudio 12 and Compare 8 solutions with servers running Microsoft 2008 Enterprise and 2008 SQL.

We need to compare two or more folders. This works great. However, when we try and update the files from one panel to another panel - it seems to work but does not. The folders are read only and the files are not read only.

I have issues with both file saves and record saves within files?

When we merge the second panel to the first panel / copy the files, it seems to work. It asks "Do you really want to copy marked files?" We also get that the file that we are updating is read-only, Overwrite anyway? We answer yes.

However, it does not update the panel of files that we request and Save Merged Files is grayed out? How can we make save work?

Also,

When I edit a specific files and move specific records within a file from one panel to another panel, We get "Are you sure you want to merge the differences? It seems to work but when I save Merged Files, it asks left side/right side and errors out "Cannot save file. It may be locked by another application. Please close file and try again.

We have also tried closing everything and have even tried logging out and tried rebooting the server to clear any locks.

After closing or rebooting, we still get the same messages - locked by another application - ?

These files are not read only - but they will not save?
What do you mean with "The folders are read only and the files are not read only"?

We have to distinguish 3 reasons for files being not writable:

  1. A file has read-only attribute set. This cause for a write protection of a file can be easily detected by applications and UltraCompare recognize the read-only file attribute. Applications can also easily remove the read-only attribute from a file, modify it and set read-only attribute again. And copying a file over an existing file with read-only attribute is also easily possible.
  2. NTFS file permissions prevent applications modifying a file. This cause for a write protection of a file cannot be easily detected by applications. Normally applications can detect a deny on overwriting a file caused by NTFS permissions only when the application starts modifying the file. The permission to modify a file depends on current user privileges and the entire NTFS permissions heritage tree from drive down to the file. For example it is possible with NTFS permissions that a user can create a file and write to it in a directory, but cannot append something to an existing file in that directory, or modify the contents of an existing file in that directory. Yes, really, such fine differences in write access can be set up with NTFS permissions.
  3. Another application has a file currently open with file open respectively access flag shareDenyWrite set on opening the file. In this case any other application can read the contents of the file without any problem, but when it tries to modify the file, the write access is denied by the operating system. If you work with UEStudio without using temporary files, UEStudio opens all files with open flag shareDenyWrite. For more information about open flags see for example MSDN article about CFile::CFile.
I suggest to use free tool Process Monitor of Sysinternals (Microsoft) to find out the reason for write protection on files when you are working with UltraCompare. You have to start this tool as administrator as it needs administrator privileges to capture and log all file system accesses. On start of this tool a filter configuration dialog opens. I suggest to define Path contains directory name containing the write protected files then Include as filter option. After pressing button OK, you see main window of Process Monitor. On the toolbar on right side uncheck from the 5 symbols all except the second one being a filing cabinet with a magnifying glass. Then only file system activity is displayed in the log below. Start your work with UC and UES and when UltraCompare displays the error message, look on the log if you can see the reason.
6 posts Page 1 of 1