User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Help with setting up and configuring custom user tools in UltraEdit (based on command line input)
8 posts Page 1 of 1
When I created my first custom tool command the default key mapping is ctrl+shift+0 but that does not execute my custom tool command. If I click the custom command under Advanced then it works but I would like to have the keyboard shortcut to execute the command.

I am using UltraEdit 15.10.0.1026 registered version.

Please help!
I have the exact same problem on one of my PCs. I've reported it to IDM but they can't reproduce it. The problem seems to be that another application is stealing the Ctrl+Shift+0 mapping globally (i.e. even when it doesn't have focus) but I've never been able to figure out what.

What OS are you running on? My problem PC runs 64-bit Vista.
When Ctrl+Shift+0 does not work in the key mapping dialog, another program is capturing this key hit. That's correct.

I suggest following:

Close as much applications as possible, especially those in the system tray. Try if you can use now Ctrl+Shift+0.

If this hotkey is still captured by another application, click on Windows Start button, click on Run, enter msconfig and execute it, switch to the system start tab, uncheck all applications, click on button OK and restart your Windows. After restart you will see a reminder dialog that you have disabled applications to start on Windows start. Move that window into a corner and start UltraEdit. Check now in the key mapping configuration dialog of UltraEdit if you can use Ctrl+Shift+0.

If that works what I suppose and hope, close UltraEdit, move the reminder window of the Microsoft configuration tool back and open this tool again. Check again a few applications on the system start tab and restart Windows. Redo these steps until you could find out which application is capturing Ctrl+Shift+0.

By the way: Can you see in msconfig tool an application hkcmd. This is an application from your video driver which is for quick switching between monitors and rotating the display/monitors by hotkey. These hotkeys can be disabled on the Advanced Settings of the video driver when not really used. Interesting is that even when the monitor hotkeys are disabled this application is still started during Windows start for ??? (need some RAM, increase boot time, ...). That's the reason why this application is not started anymore automatically on my computer as many others too.

If after disabling all automatically started applications, the hotkey Ctrl+Shift+0 is still not working, it is possible that one of your shortcuts on the desktop or in the start menu has this key as hotkey, but the shortcut is for an application not installed anymore or already running. I have had in the past also the situation that after deleting a shortcut with a hotkey I could not re-assign that hotkey to a new shortcut immediately. I still don't know where Windows stores the shortcut keys in real. There must be a hidden database for all shortcut keys and I don't know when this database is updated by Windows.

BTW: If you have multiple GUI languages or multiple keyboard languages installed, check in the regional and language settings of Windows which hotkey is enabled for quick switching to another language. I have deleted all additional languages except the language I really need, so I can't look which key is the default.
I ran into this problem and had a difficult time figuring out what was going on, so I'm posting this here for posterity (which I'm sure will include me after some reinstall of Win7)...

Vista and Win7 by default will use the Ctrl-Shift-0 shortcut to switch input languages in the IME, making the keyboard shortcut unavailable for use by UE's Advanced/Tool configuration.

To fix this, remove the shortcut assignment to make the application work as expected. To do this, follow these steps:

1. Click Start, and then click Control Panel.
2. Double-click Regional and Language Options.
3. Click Keyboards and Languages, and then click Change keyboards.
4. Click Advanced Key Settings, and select Between input languages.
5. Click change Key Sequence.
6. For Switch Keyboard Layout, select Not Assigned.
7. Click OK to close each dialog box.

MS documents this here: http://support.microsoft.com/kb/967893

On Win7, step 2 was more like:

2. Click "Change keyboards or other input methods" under the "Clock, Language, and Region" heading

Note that the "Advanced Key Settings" dialog is quite confusing (to me anyway), because it doesn't show anything about "Ctrl-Shift" on the initial panel for the "Between input languages" hot key setting. So I initially thought that my system did not have Ctrl-Shift-0 configured as a system hot key. However, you must highlight the "Between input languages" setting (which said "Left Alt+Shift") and press the "Change Key Sequence..." button before you'll see anything about "Ctrl+Shift" (where it will be selected in the "Switch Keyboard Layout" column).

Also, Microsoft really should figure some way that users can discover what the heck a key combination might be configured to do. It's pretty disconcerting when a key doesn't respond as it's clearly configured to do in an application. And since a hotkey often has no visible effect (like this one for me), it's pretty hard to figure out what's going on unless you stumble by luck on the answer in an internet search.
mwb1100, thanks for posting the steps required on Windows 7 to disable keyboard layout change by hotkey for active application. I have posted that already several times for Windows XP.

On Windows XP there is on the Windows toolbar a small symbol left the system tray showing the 2 character language abbreviation of the keyboard layout for the ACTIVE application. This is the language bar. This bar indicates always which input language is set currently for the active application. Of course when English US and English UK keyboards are installed and the input language is changed, the 2 character language abbreviation in the Windows taskbar does not change because both keyboards are for English language and therefore EN is displayed for both in the Windows taskbar.

Right clicking on this language indicator symbol and clicking with left mouse button on Settings in the context menu of this symbol opens the Text Services and Input Languages settings dialog. The alternate method to open this settings dialog is Control Panel - Regional and Language Options - tab Languages - button Details.

The easiest method and the one I use always on every computer I get here in Austria is to simply delete all keyboard layouts except German (IBM) which is the best for users of a German keyboard. Alternatively the button Key Settings can be pressed to open the dialog for changing the shortcut keys.

Having only 1 keyboard layout installed, the one which fits to the keyboard, disables the hotkey and removes the language symbol from the Windows toolbar.

I think, the only Windows users who need more than 1 keyboard layout installed are translators and persons who write often something in a different language.

Further on tab Advanced there is also the System Configuration option to Turn off avanced text services needed for East Asian languages. Windows XP users never working with East Asian languages should check this option which also disables the language bar, but not the shortcut key to switch the input language.



Some Microsoft support articles about keyboard layouts:

Keyboard shortcuts for Windows
HOW TO: Use the Language Bar in Windows XP
List of the keyboard shortcuts that are available in Windows XP
How to change your keyboard layout (Windows XP, Vista, Windows 7)
Troubleshoot wired keyboards that don't respond or that type wrong characters
How to use the United States-International keyboard layout in Windows 7, in Windows Vista, and in Windows XP
I hate to bump such an old thread, but this one hit my pet-peeve nerve.

As a Admin and Developer in a large, global Enterprise, I have found a number of applications that hi-jack default key combinations used by Windows. In the case of UltraEdit (which I have been using for what seems like forever), Ctrl+Shift+0 is hi-jacked. Fortunately, the key combination can be customized in UE (Advanced > Configuration > KeyMapping | AdvancedUserToolx) and I typically re-map this to use Ctrl+1, Ctrl+2, etc., since these shortcuts are not used in Windows (at least not that I have found). These combinations are used in some versions of IE for navigating around tabs, but as long as UE is the active Window, no contention should happen.

IMHO, Developers should be intimately familiar with the keyboard shortcuts used in Windows and avoid (like the plague) hi-jacking those key combinations in the apps they write. If this isn't a best-practice for Developers, it should be. At the very least, provide a means of customizing those key combinations, as IDM has done in UE. I can tell you from personal experience, not all Developers are so kind and it really makes using some applications ... challenging.

One more point before I jump off my soap-box, English is not the only language used in the world and Windows supports many of them. I have discovered several instances where common Windows key combinations change between languages / UIs. If the app you are writing is going to support multiple languages, these differences need to be considered as well.
jnk_ue, I agree with most of what you have written. But from an applications developer point of view there is one problem: What should be done if an application developer has once defined a hotkey not predefined by operating system and later a new version of OS is supported which suddenly use that hotkey system wide? Exactly that happened here. Ctrl+Shift+0 existed in the default key mapping before Windows Vista introduced Ctrl+Shift+0 as hotkey to swap keyboard layout. Simply change default key mapping of the application? Could be done, but that could made many customers upgrading from a previous version of the application unhappy. To be honest, I have never understood why during Windows installation 2 keyboard layouts are installed although the normal user only use 1 keyboard in native language and why Microsoft has not defined a Win+X key for input language switch like for other system wide hotkeys.
Mofi, thank you for that insight and your point is well taken. Wow, I hadn't actually considered M$ changing things up and stepping all over a Developer's hard work. How dare they! :D

Kudos to IDM for continuing to make UE a great product to use.
8 posts Page 1 of 1