User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
6 posts Page 1 of 1
I have recently changed over from UltraEdit to UEStudio and am most pleased with it. However, starting just yesterday, and continuing today, it has been kinda freaking out on me. It seems to happen after using the replace command, but I've not yet identified any other conditions which must also be present. I have never seen this occur in UltraEdit, and not previously in UEStudio.

What happens is that the next command I try results in an error pop-up worded, "The parameter is incorrect." I click OK and the file does not refresh, or at least the lines are not visible. But if I try to select the text with the mouse, it shows up as selected. while that is displayed, any attempt to do anything else just brings back the error pop-up with the same message and nothing else happens.

Has anybody else seen this problem or have a fix for it?
I have never seen such an error message and also can't find this string in any of the files of UEStudio. I suggest to open Advanced - Configuration - Toolbars / Menus - Miscellaneous and press the button Clear History to clear all histories including all find and replace histories. Close UEStudio and restart it. Is the problem gone?
Best regards from Austria
Hi Mofi,

Thank you very much for the help. Your suggestion, by itself, didn't solve the problem, but in working with it, I found that the problem only happened with one particular file. Trying to fix the file, even with hex mode, was unsuccessful. When I finally deleted the file and recreated it, the problem was solved. Fortunately, it was a short file, a navigation block, one of several includes for a webpage, mostly xhtml, but with a php extension.

I'd say the error message likely originated from Windows XP trying to deal with an illegal byte/word value while read/writing the temp file.

I see you've been busy today, trying to help many others in alternate threads. It makes me happy to see that :) . I try to help others whenever I do have something to contribute.

Although the board lists me as a newbie, that's only to this board. I've worked with computers for over 40 years, programming in several languages from Fortran IV to PHP5, with both systems and applications focus. I'm retired from full-time now, but still do frequent webweaving in xhtml (thinking about trying HTML5), CSS, Javascript, and PHP.

I've used UltraEdit for several years, and upgraded myself to UEStudio last November. So far, I love it.

Have a great day!
Practically every time I enter any text or delete any text, the message "The parameter is incorrect" appears and UltraEdit makes a "ding" noise. I've tried uninstalling and reinstalling, it still happens. I saw the posts above about this problem, but the solution doesn't work for me. I saw that there was a fix in UltraEdit to address this problem when it was related to using automatic spell checker, but I don't use spell check (I have deselected this in configuration). I googled but there is nothing else about this problem. I even cleaned the Windows Registry between installs. I also searched the help and this forum but there is no information about it. It would be helpful if the error message itself was more informative! Please help. This problem is extremely annoying and it makes the program unusable. Please help.

I use version: 18.10.0.1018 on Windows 7 Professional, SP 1.
As I wrote above, this error message is definitely not anywhere inside of any file of UltraEdit. So the error message is not displayed by UltraEdit and the error sound is also not played by UltraEdit. Some DLLs of Microsoft in Windows system directory contain this error message text.

As the user reported, the issue was caused by the file itself. Most likely parts of the file were located in a bad sector of the hard disk or another problem with master file table (file system) was causing this mistake. In this case reading data from this part of the file does not work and one of the low level functions of Windows outputs the error message.

This issue is very interesting. I spent today some hours to fix a computer not starting anymore. The reason was that 4 sectors on disk became bad and therefore reading data from those sectors failed. In this case the 4 sectors belonged to a file required for Windows to boot successfully and fixing the issue was not simple, but I was finally successful.

I suggest following:

Open a command line window by running command cmd. Within the command line window type the command

chkdsk C: /F

and execute the command with key RETURN. This command runs Windows check disk tool on drive C: with searching for and fixing automatically errors on file system. If your files are stored on another drive, replace drive letter C: by the letter of the drive with the file.

As drive C: is currently in use by Windows, the execution of this command must be scheduled on next boot of Windows. Confirm the prompt to run this command on next Windows boot.

Now reboot Windows. On beginning of the Windows startup you will see a message that execution of chkdsk is scheduled and you have 10 seconds to skip execution of this command by pressing any key. Do not press any key and let the command run. Depending on how many thousands of files you have on drive C:, it can take from some minutes to even an hour until check disk tool has scanned the entire file system for errors and fixing them. Watch the messages displayed during execution, especially the summary at end which is unfortunately displayed for just a few seconds as Windows continues with startup after chkdsk finished.

If you can read during execution of chkdsk that bad sectors are also found, I suggest to run chkdsk again with command

chkdsk C: /F /R

The parameter /R results in testing every used and unused sector on hard disk for bad sectors which of course needs very long time (up to several hours depending on size of drive). Therefore I strongly recommend to run chkdsk first with just parameter /F and without parameter /R.

Also it could be that RAM of your computer or cache of your CPU is partly damaged resulting in damaging files when data is written back from RAM to hard disk. Running chkdsk with parameter /R on which file data on hard disk must be loaded to RAM temporarily to be able to test the hard disk sectors could easily result in lots of damaged files on disk after running chkdsk with parameter /R. I don't think that your problem is caused by a defect RAM, but for security run first chkdsk just with parameter /R to scan and fix just file system errors.

By the way: If you want more information about chkdsk tool and its parameters, run it in command line window with chkdsk /? as this shows the help for this command.

If the problem does not exist on a single file only, perhaps the INI file where the search/replace history is stored is corrupt because of bad sectors or errors in file allocation table. The error is definitely not caused by UltraEdit nor output by UltraEdit itself.

You can try renaming directory "%APPDATA%\IDMComp\UltraEdit" containing all user configuration files of UltraEdit not touched during an uninstall and reinstall while UltraEdit is not running and let UltraEdit create this directory and all configuration files again using default settings.

Also possible is that folder for temporary files is corrupt or there are too many files and subfolders in this folder. The number of entries in a folder is not unlimited. After checking disk use Windows Disk Clean Up utility from Start menu - Accessories - System Tools to clean up folder with temporary files.
I have seen this on my UltraEdit Portable, version 18.20.0.1017. It started popping-up "The parameter is incorrect" after I doubled clicked on a word and then clicked on the "Find Next" icon.

I tried clearing the history...and many other things, but I finally fixed the problem after I closed all of my opened files and then closed UE.
6 posts Page 1 of 1