User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

Two- and three-way folder compare and merge issues.
2 posts Page 1 of 1
I am having a problem comparing xml files from two directories. The folder compare shows some (but not all) of the files as different. When I double click on the one of the pair of files, the text compare (correctly) shows that both sides of the comparison are identical. There also pairs that show as different and that are in fact different.

I am using UltraCompare Professional, Version 7.00.0.1018, to compare the two folders containing xml files (which are showing the type as binary). I am using the smart folder compare with text mode in result, force load files in text mode, and force load undetected files in specified mode : text mode. My ignore options are white space and case for text.

What am I doing that causes this disparity between the folder comparison and the file comparison?

Jon Stonecash
For reproducing the behavior as you have written I did some tests with various folder compares and with various files. I detected that smart folder compare is working fine. It takes the file ignore options into account and displays files as equal even when file date or file size is different caused by differences which are ignored.

But as I set all the options (folder compare to smart, ignore whitespaces and line terminators) in the configuration dialog, I detected that smart folder compare is working correct only after restarting UltraCompare Professional and redoing the folder compare. It looks like changes done in the configuration dialog are not immediately applied on the folder comparing when re-running it or when refreshing. After restarting UC Prof. smart folder compare works.

Then I could see that changing the file ignore options directly in menu options result in activating green triangle arrow to run the smart folder compare again and the changed file ignore options are taken into account. But changing the file ignore options in the configuration dialog does not result in activating green triangle arrow after closing the configuration dialog with button OK and even when manually forcing a smart folder recompare the changed file ignore options done in the configuration dialog are ignored until UC is restarted.

I tested further and enabled Options - File Ignore Options - Ignore Whitespace. I opened the configuration dialog and looked on Ignore - Text and the options are set as displayed in the menu. I closed the configuration dialog with button Cancel and unchecked Ignore Whitespace in the menu. I re-opened the configuration dialog and again the text ignore options are set as shown in the menu. Now I enabled Ignore White Space (different spelling?) in the configuration dialog and closed it with button OK. I looked into the menu, but there Ignore Whitespace is still not enabled. Doing reverse results in same wrong behavior. It looks like changing the ignore options in the configuration dialog are not immediately applied to the active compare.

So there is definitely a problem with the settings changed in the configuration dialog which are not immediately applied after closing the dialog with button OK. Maybe the file ignore options in the menu are for the active compare while the file ignore options in the configuration dialog specify the defaults. And the defaults are only applied when starting a completely new compare by closing UC and restarting it. From my point of view this is really confusing although I would understand the behavior as is.

But there is no option to change the folder compare mode directly from a menu. So changing the folder compare mode in the configuration dialog should always result in activating green triangle arrow to re-run the active folder compare once again with the new mode. This does not happen always. I will report this issue by email to IDM when I have found out under which conditions changing the folder compare mode in the configuration dialog is not applied to active folder compare.

So my suggestion is, set smart folder compare and probably also the file ignore options in the configuration dialog as you want, exit UltraCompare, restart it and run the smart folder compare. You should get now the correct result. And verify the File Ignore Options in the menu when something is not correct.
Best regards from Austria
2 posts Page 1 of 1