User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

This forum is user-to-user based and not regularly monitored by IDM.
Please see technical support page on how to contact IDM.
13 posts Page 1 of 1
Hello,

I've upgraded from UEStudio v9.30.0.1002 to v10 and I am experiencing long delays in certain parts of the application. The super long slow delays are so bad and annoying that I've had to drop back to v9.3 because it's not usable. Downgrading to v9.3 solves all these issues and so I suspect there is a bug in v10. I am using Windows Vista Home Edition 32bit with all the latest patches.

At first I tried investigating why this is happening and so I disabled my anti-virus first and then began killing every other non important process in my system. Then I ran Sysinternals Process Monitor while uestudio was opened.

The first thing I noticed while using the IDE is when I have a project opened and right click to download a file from ftp UEStudio's cpu usage climbs to around 50% and it takes about 30-60 seconds to even start to do it's thing, basically what I am saying is it takes 60 seconds to see the little FTP Command Progress dialog window pop up, at which point when it finally comes up the actual download of the file is fast as normal. This seems to occur with many dialogs, for example File > FTP/Telnet > FTP Account Manager takes the same 60 seconds to even appear. Similarly while the project is open and I try to just 'Add folder' on the project it takes 40-60 seconds just to bring up the dialog window.

While in Sysinternals process monitor I see it hammering %APPDATA%\IDMComp\UEStudio\UEStudio.INI over and over during this waiting period, and the process looks very odd indeed. I do have a rather large .ini file (940 KB) but then again I've never had these issues before and downgrading to 9.3 works just fine. I also opened a 200MB text file and it opened extremely slowly, normally this is lightning fast, and I could see in processmonitor that it was hitting the temp folder and file it created a ton of times. Finally when the file was open navigating the file was speedy.

I also noticed that I/O actions were extremely high, take a look at these numbers, not even Microsoft's indexing service used this much.
Code: Select all
Process              UEStudio.exe
PID                     2564
CPU                     5.38
Private Bytes           36,512 K
Working Set             61,144 K
Description             UEStudio
Company Name            IDM Computer Solutions, Inc.
I/O Reads               47,654
I/O Read Bytes          37,081,849,622
I/O Writes              58,876
I/O Write Bytes         3,885,927
I/O Other               1,701,665
I/O Other Bytes         14,060,562

That's after having it open for about 20 minutes doing various tests mentioned above. If I close and open the application and do the add folder test the 'I/O other' jumps up to about 1.3 million where as v9.3 has been open longer put through it's paces and is roughly around 459,000.

Here's a few of the lines procmon captured where it was hammering uestudio.ini over and over
Code: Select all
"09:40:19.2150048","UEStudio.exe","2564","ReadFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Offset: 0, Length: 961,360, Priority: Normal"
"09:40:19.2161019","UEStudio.exe","2564","UnlockFileSingle","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Offset: 0, Length: 4,294,967,295"
"09:40:19.2161083","UEStudio.exe","2564","CloseFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS",""
"09:40:19.2161233","UEStudio.exe","2564","IRP_MJ_CLOSE","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS",""
"09:40:19.2162416","UEStudio.exe","2564","CreateFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a, OpenResult: Opened"
"09:40:19.2162634","UEStudio.exe","2564","LockFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Exclusive: False, Offset: 0, Length: 4,294,967,295, Fail Immediately: False"
"09:40:19.2162691","UEStudio.exe","2564","QueryStandardInformationFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","AllocationSize: 962,560, EndOfFile: 961,360, NumberOfLinks: 1, DeletePending: False, Directory: False"
"09:40:19.2166613","UEStudio.exe","2564","ReadFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Offset: 0, Length: 961,360, Priority: Normal"
"09:40:19.2177607","UEStudio.exe","2564","UnlockFileSingle","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Offset: 0, Length: 4,294,967,295"
"09:40:19.2177670","UEStudio.exe","2564","CloseFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS",""
"09:40:19.2177819","UEStudio.exe","2564","IRP_MJ_CLOSE","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS",""
"09:40:19.2178828","UEStudio.exe","2564","CreateFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a, OpenResult: Opened"
"09:40:19.2179045","UEStudio.exe","2564","LockFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Exclusive: False, Offset: 0, Length: 4,294,967,295, Fail Immediately: False"
"09:40:19.2179104","UEStudio.exe","2564","QueryStandardInformationFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","AllocationSize: 962,560, EndOfFile: 961,360, NumberOfLinks: 1, DeletePending: False, Directory: False"
"09:40:19.2182904","UEStudio.exe","2564","ReadFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Offset: 0, Length: 961,360, Priority: Normal"
"09:40:19.2194539","UEStudio.exe","2564","UnlockFileSingle","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Offset: 0, Length: 4,294,967,295"
"09:40:19.2194601","UEStudio.exe","2564","CloseFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS",""
"09:40:19.2194750","UEStudio.exe","2564","IRP_MJ_CLOSE","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS",""
"09:40:19.2195618","UEStudio.exe","2564","CreateFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a, OpenResult: Opened"
"09:40:19.2195963","UEStudio.exe","2564","LockFile","C:\Users\Anthony\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI","SUCCESS","Exclusive: False, Offset: 0, Length: 4,294,967,295, Fail Immediately: False"

To give you an example of how many times, from "09:37:23" to "09:48:40" which is only a little over 10 minutes, 57644 occurrences were found in the log for the string "2564","CreateFile","C:\Users\Entropy\AppData\Roaming\IDMComp\UEStudio\UEStudio.INI"

I tried uninstalling and turning off UAC, rebooting and reinstalling and also I tried to make sure I had write access to the ini file and the APPDATA folder contents nothing seems to help. Is anyone else experiencing this slow I/O behavior? Is this a known bug?

Let me know if I can provide additional info to help. Thanks for your time.
Your uestudio.ini has 940 KB, how have you make it?

You should copy your FTP account settings into a separate file and specify this file under Advanced - Configuration - FTP - Store FTP accounts and settings in user selected file.

Further you should click on button Clear History at Advanced - Configuration - Toolbars / Menus - Miscellaneous.

Finally you should open uestudio.ini with Notepad while UEStudio is not running and clear some sections like those remembering code foldings and bookmarks.
Best regards from Austria
That all sounds like sound advice to follow considering I have a large .INI file and I will try it and post back what I find. But like I said it works flawlessly in UEStudio v9.30.1002 without any issues. Your advice sounds like a work around rather than a solution. I find it rather odd and unbelievable that IDM is having trouble opening an INI file of a mere 940K seeing how they are know for their superior large file handling. I've been using UltraEdit since 2004 and have never seen this sort of issue.

Thanks. I'll post back when I've tried your suggestions.
I haven't dug into the issue like the original poster. But I've also found v10 to be unbearably slow in dealing with FTP actions.

The actual transfers themselves seem to be just as quick as before. But preparing for the transfers now freezes UES for 20-30 seconds before the transfer starts. In earlier versions I was able to switch to another file and work on that while I waited for a transfer, now UES just freezes and windows reports it as not responding greying out the entire application until the FTP transfer starts.

This is on Vista home basic.

I've always been dissapointed in the FTP account manager which has been horribly slow for a long time even in previous versions. I keep expecting it to be fixed but this time it seems even worse with very long delays when opening the account manager and even longer delays when saving an account.

Right now v10 is practically unusable for me it's so slow. My productivity has crashed and burned which is the exact opposite of what UES did for me when I switched to it as my primary editor.

I just checked my uestudio.ini file based on the conversation above and it's only 318k but I'm still seeing the kind of abysmal performance the original poster is reporting.
I'm not having any problems with slowness whatsoever with UEStudio 10. I do keep my FTP accounts in a separate file, if that counts.

My FTP is quick to connect and has always operated as fast as any other 3rd party program I use on my computer. Same with Telnet/SSH.

I also don't have the problem with the INI file causing slowness.

I notice both of you are running Vista. I'm running XP (refused to upgrade to Vista, waiting until all the issues are resolved with Windows 7 for a year or 2 before I upgrade to that.)

Perhaps you should contact support and let them know the issues you are having. They may be able to get this fixed for you. You've paid for support with your license, so feel free to access it.
“Don’t document the problem, fix it.” – Atli Björgvin Oddsson
I don't use the FTP feature of UltraEdit which is the reason why I have just written about how to make the INI file smaller. You should enable the configuration setting Show FTP log in output window at Advanced - Configuration - FTP, open the output window and look if you can see there the reason for the long delay.

Long delays are nearly always caused by network problems. Maybe a firewall is partly blocking new version of UEStudio because the new version of UES is not registered in the firewall for being a secure application. It could also help to enable passive mode for the FTP accounts.

As I can see on your process monitor log the large INI file is not the problem because it is processed by UEStudio in 4.5 ms.
Best regards from Austria
The actual network functions are just as fast as always.

It's preparing them and editing FTP accounts that's horribly slow. Just opening the FTP account manager can take over a minute. That's always been slow and is something I've been hoping would be fixed for about 3 upgrades now.

With FTP transfers it's once I hit the "Save to FTP" button that things freeze, instantly. Then once the transfer actually starts UES returns to normal and starts responding again while the transfer takes place.

I looked into moving FTP into a separate file, but have no idea how to get them in there. The layout of the .ini file does not make it readily apparent what needs to be moved into an external file. And with around 150 FTP accounts that I access re-entering them manually isn't much of an option.

Looks like this will require contacting support. I had hoped others in the community may have some helpful information first.
I went ahead and contacted support about the FTP issues. Unfortunately other than acknowledging that there is a problem no solution has been offered yet:

Thanks for your response and for sending your configuration directory. I did some testing here, and I do see a considerable decrease in performance during all FTP operations between v09.30 and v10.00. I will notify our developers and ask them to look further into this, and we will let you know when we have an update on this issue. I am very sorry for the inconvenience.

When a solution is found I'll share it here for anyone else having this problem.
I have the same problem on Windows 7.
Saving on ftp is very very slow.

Any solutions?
I've been in contact with IDM tech support about this issue and they are making progress. This was the last update I received from them:

Recently you had reported that UEStudio was very slow in handling many FTP accounts. One of our developers looked into this issue and replied with the following information:

**********************************************************
First off, the issue is not a problem with the actual FTP transfers of files. I was able to download and upload files with the original speed. Opening the FTP Save Dialog, FTP Browse dialog and FTP Open Dialog was very, very slow. Opening these dialogs was causing the FTP accounts to be reloaded from the file.

There are two problems here:
1.) It is not necessary to reload the accounts list every time these dialogs are opened.
2.) Account list Load and Save has become slower.

Problem #1 Solution:

I have made changes so that when the user opens FTP Save, FTP Open, FTP Browse and FTP Account Manager. If the account list is already loaded it will not be reloaded. This means it will come up immediately. If the account list has not been loaded then the dialog will have to load the list and that will take some time.

Problem #2 Solution:

Load - originally the load time for the users 157 accounts was around 30 sec. I made what changes I could to the Load function and have cut this time down to about 18 sec.

Save - I found I had an error where ALL accounts were being saved every time. I have changed this now to only save modified accounts. That has significantly reduced the time it takes to save the accounts.

The user will experience slowness in the FTP Account manager due to the Saving and Loading calls there. However in all the other dialogs he should be able to work at much faster speeds after the initial account list load takes place.
**********************************************************


We have an updated build here that we believe addresses this issue:

There was a new test build attached, I don't know if I'm allowed to share the link to it or not though so I didn't include it here.

The new test build did help a little bit with a few things, but the majority of issues still persisted. The only thing that seemed any quicker to me was opening the FTP Manager the second time, that did drop from 30+ seconds down to around 20+. However I'm still getting the 30 second pauses before the FTP transaction starts when doing a save, and it still takes 30+ seconds to open the properties of an FTP account to make changes.

I've sent them more information and a fresh copy of my config and have been told they are continuing to look into this. But at this point IMHO FTP is unusable in v10+ with more than a handful of accounts.
Is there an improvement on this issue with UEStudio v10.10.0.1010?

According to the list of fixes of UE v16.10.0.1035 which seems to be the base for UES v10.10 there should be a difference now.
Best regards from Austria
After my last post I sent IDM customer service another e-mail asking if they could give me an extension so I could try v10.10 to see if it had fixed the problems. The reply I got back was that no changes to the FTP problems I was experiencing had been made in v10.10 and that they were still looking into the problems.

However, they also said they would bring the situation to the attention of their Vice President, Richard Knott who responded shortly after and within 24 hours had got engineers looking into the problem and replied again saying they would have a user verification build ready shortly for me to try. This morning I received the UVB and just finished installing and testing it.

I'm very happy to report that the problem has been resolved in the UVB they sent me today. I don't believe I'm allowed to share the link to the UVB - but can confirm that it is a HUGE improvement and anyone else having this problem should contact IDM support if they need the UVB immediately or wait for the next update which should include these fixes.

The new build even fixed the problem with very slow text entry in the FTP manager dialog boxes that has been an issue since before V10 but wasn't costing me productivity so I never thought to mention it since it was merely annoying.

So a big thanks to IDM support and Richard Knott for getting this issue resolved. It took somewhat longer than I would have liked but once the severity of the problem was fully realized they were amazingly quick to get a team on it and get it fully resolved!
The hotfix download pages for UltraEdit v16.10.0.1036 and for UEStudio v10.10.0.1012 contained both the line

Significant performance improvements for FTP operations with large number of accounts (including editing accounts in FTP Account Manager)

So the problem discussed here is fixed with these versions of UE and UES.
Best regards from Austria
13 posts Page 1 of 1