User to user discussion and support for UltraEdit, UEStudio, UltraCompare, and other IDM applications.

FTP, SFTP, FTPS, and SSH/telnet console issues
11 posts Page 1 of 1
Is it in any way possible to view and load hidden files from an FTP site?

I use UE32 to change my .htaccess and I have to enter the filename manually to load it, it isn't visible...

Any help?

Thnx
I suspect that the fact you can't see the .htaccess file is a function of a setting on the FTP server. You could ask for your ISP or Web Host to change that.

I do know that when using WS_FTP, an FTP client I use most of the time, I can get around this problem, if it exists, by entering -a in the file mask area. Perhaps doing the same in the filter box in UltraEdit achieves the same result.

This is total conjecture on my part as I haven't tried that so I can't verify what I'm suggesting, but entering a -a in the filter box doesn't filter the contents so it may just work the same way.

Dan
Daniel Kirkdorffer
http://www.kirkdorffer.com/
Your so good ;-)

I new from ftp on the commandline that ls -latr works like a charm, I didn't know however that the Filter had that purpose, I thought more of it like *.html or so..

Nice!

Thnx
Good to hear it.

Now perhaps you or someone can tell me how to keep the FTP dialog up while editing files? There must be a way to keep this from going modal.

Anyone?

Dan
Daniel Kirkdorffer
http://www.kirkdorffer.com/
I think that's more some kind of a new thing to program...

Maybe an email to the develloper helps?

Good Luck
DanKirkd wrote: This is total conjecture on my part as I haven't tried that so I can't verify what I'm suggesting, but entering a -a in the filter box doesn't filter the contents so it may just work the same way.

Dan, you are soo right with your conjecture. I, too, always thought that the filter was supposed to be something like *.* or .* and I think it worked that way in earlier versions. This is awsome!

I just wished the docs were a little more explicit about the filter function.


Manni
Actually it doesn't surprise me that this works now. In fact, you can do both at the same time, enter an option and enter a filter. UltraEdit to a certain extent probably just takes what you enter verbatim and applies it within its FTP command.

Anyway, glad this trick works for a number of folks.

Dan
Daniel Kirkdorffer
http://www.kirkdorffer.com/
When UEStudio browse the FTP that runs on Linux, UEStudio cannot show all the folders.
For instance, I want to browse /home/.ssh UE cannot show it, but I use flashfxp that can show this folder.

I use UEStudio 06.40 hotfix 2 Chinese Version.
Hope it will be better. I'm Shanghaiese, haha, better ue, better work.
By default hidden folders are not shown when browsing an FTP account. But follow this instruction from the UE help:

UE Help wrote: LIST Command Filter
The LIST Command Filter determines what is retrieved from the server when a LIST command is issued. On most FTP servers if you pass "-al" you will receive a full listing including hidden files. You can also pass wildcards. For example "*.txt" would list all txt files. Note that some servers (VMS, MVS, etc) do not handle filter arguments like Unix/Linux servers.

The LIST Command Filter is on the Advanced tab in the FTP account manager of your account.

Edit: Since UE v14.20 the LIST Command Filter is on the Server tab in the FTP account manager of your account.
Thanks for your help! :oops:
I've known this issue.
When I connect to linux server by putty-telnet tool, the cmd of ls cannot show this folder as well.
I use "ls -a", so all folder can be shown...
Maybe it's the security of the system, but I don't like this filter.
Hello,

I have a similar problem but directly into the internal explorer of UE : I have a tree view of the files of my project, but the .htaccess and .htpassword files do not appear in this tree view... I've explored the help section but I didn't find a word about how to make these files appear. I use version 17.20.0.1016 on WinXP. If I remember well, previous versions were showing the files but didn't permit to open them from the tree view, we had to open them through the open dialog.
May I receive some help ?

Thanks in advance.

McBenny
11 posts Page 1 of 1