A file opened via Windows Explorer context menu is displayed minimized in started UltraEdit (fixed)

A file opened via Windows Explorer context menu is displayed minimized in started UltraEdit (fixed)

25
Basic UserBasic User
25

    Oct 13, 2021#1

    When using the Windows Explorer right click context menu on a file name to start UE and load that file for editing, UE does start and the edit window appears in its 'restored' state.

    But only for a split second. The edit window immediately minimizes. (Which then shows a short bar with only just the maximize and close action buttons.)

    Is there a setting I am overlooking?

    I meant to add that this issue started with (if I recall) the last version of the v28.10 family, and continues in v28.20.

    6,633551
    Grand MasterGrand Master
    6,633551

      Oct 13, 2021#2

      I can reproduce that behavior with UltraEdit 28.20.0.44 only under following conditions:
      1. There are checked the options Reload files previously open on startup and to saved files at Advanced - Settings or Configuration - File handling - Session options.
      2. A file like C:\Temp\Test.txt is opened in running UltraEdit and its document window is minimized.
      3. UltraEdit is exited with still opened and minimized file C:\Temp\Test.txt.
      4. In Windows File Explorer is made a right click on the file C:\Temp\Test.txt and a left click on context menu item UltraEdit.
      5. UltraEdit is started and opens first the files previously opened on last exit and next detects that the file C:\Temp\Test.txt should be also opened although being already opened with a minimized document window.
      There is nothing changed on window mode of the document window of the already opened file. It is kept minimized.

      The simple solution is closing the file C:\Temp\Test.txt or restoring its document window before exit.

      Well, there could be also other use cases as well depending on UltraEdit configuration. But I would need your configuration to find out what is causing this behavior on your machine.

      My suggestions without getting your configuration:
      1. Close the project/workspace if a project/workspace is currently opened. close all files, open Advanced - Settings or Configuration - Toolbars / menus - Miscellaneous, click on button Clear history to clear really all histories, close configuration and exit UltraEdit. Then open the file via context menu item UltraEdit and see if the behavior changed to normal. Yes, problem solved with clearing all histories.
      2. While no instance of UltraEdit is running rename in folder %APPDATA%\IDMComp\UltraEdit\volatile the file ue.vod for example to ue_bak.vod containing volatile data (most histories and all window settings). Then open the file via context menu item UltraEdit and see if the behavior changed to normal after UltraEdit started and opened the file. Yes, problem solved with deletion of ue_bak.vod and redefinition of the sizes and positions of the windows. Otherwise exit UltraEdit, delete newly created ue.vod and rename back ue_bak.vod to ue.vod to restore your histories and window settings.
      3. While no instance of UltraEdit is running rename in folder %APPDATA%\IDMComp\UltraEdit the file ue.ini for example to ue_bak.ini containing the configuration data, the scripts list, the user tools configuration, etc. Then open the file via context menu item UltraEdit and see if the behavior changed to normal. after UltraEdit started and opened the file Yes, then there is a configuration setting responsible as the behavior does not exist with the default settings. Exit UltraEdit, delete newly created ue.ini and rename ue_bak.ini back to ue.ini to restore your configuration.
      I would need your configuration as stored in ue.ini or even better the file created on using Backup/restore user customizations in UltraEdit with checking a check mark at Volatile data and Others with exception of the files storing FTP account data to further analyze what could be the reason for this file display behavior on your machine with your window and configuration settings.
      Best regards from an UC/UE/UES for Windows user from Austria

      25
      Basic UserBasic User
      25

        Oct 13, 2021#3

        The above is legitimate. Note: I have posted earlier commenting that "Reload files..." setting mysteriously gets checked through no action on my part. I have been routinely checking that setting to make sure it gets unchecked and stays unchecked.

        However, this issue happens on any file, including files UE has never seen before. This happens regardless whether there is a prior instance of UE already running or not running. (That is, 'Allow multiple instances' is enabled.)

          Oct 14, 2021#4

          Also, I see that if I open UE via the desktop icon, the initial default "Edit1" window is also minimized on start. I didn't catch this earlier because I rarely start UE without wanting to load a file in for editing.

          6,633551
          Grand MasterGrand Master
          6,633551

            Oct 15, 2021#5

            I took from your configuration the file ue.ini with the paths adjusted to my paths and ue.in0, ue.rb0 and ue.vod from your configuration. The new file was indeed displayed minimized on start of UltraEdit with those four files from your configuration. So I could immediately reproduce the unexpected file display behavior.

            I could also find out next why that happens and how to solve it. It is caused by a bug of UltraEdit which can be easily worked around.

            First the workaround for you:
            1. Start UltraEdit without or with a file.
            2. Restore the new or opened minimized displayed file to normal window mode or maximize it. The window mode you choose now will be used in future for files opened on startup of UltraEdit.
            3. Open Advanced - Settings or Configuration - File handling - Session options and check the setting Reload files previously open on startup.
            4. Close the configuration dialog and exit UltraEdit with active file with restored or maximized window.
            5. Start UltraEdit again without or with a file. It is opened in the normal (restored) or maximized window mode as the open file on previous exit.
            6. Open Advanced - Settings or Configuration - File handling - Session options and uncheck the setting Reload files previously open on startup as preferred by you (and me) and close the configuration.
            That solves the issue with always minimized document window on UltraEdit started without or with a file to open.

            The found bug is as follows:
            1. The issue occurs only with having Dockable tabs checked in configuration respectively the context menu item Dockable is checked in submenu File tabs in context menu of the file tabs. The issue is not visible with not dockable tabs as in this document window mode the document windows are always displayed maximized. The Window menu item Enable tiling / dockable tabs can be used also to change the dockable tabs mode. 
            2. UltraEdit v28.20.0.44 uses always on startup without a file (new edit window shown by default) or with a file to open the setting Active File Display Mode in section [Open Files] in file ue.vod to determine the window mode for the opened file(s). Value 1 is for normal (restored) window, value 2 for minimized window and value 3 for maximized window.
            3. The issue is that with setting Reload files previously open on startup not checked in configuration, the setting Active File Display Mode in section [Open Files] in file ue.vod is never updated on exit although this setting of section [Open Files] should be always updated on exit as it is read on next start and used for opened files on startup. Most other settings can be ignored on exit of UltraEdit on having the setting Reload files previously open on startup not checked in configuration.
            This issue exists since UltraEdit for Windows v28.10.0.26 as I found out next with the knowledge what causes the always minimized file display behavior and reported it to UltraEdit support by email.

            I deleted the post with the ZIP file as no longer needed.
            Best regards from an UC/UE/UES for Windows user from Austria

            25
            Basic UserBasic User
            25

              Oct 15, 2021#6

              Thank you, very much!

              Comment: While I was exploring why this "Reload files..." issue I was having (see my other post that I cannot locate), I noticed that the .vod file was getting updated but sometimes it took up to 5 minutes for the file to be written to disk. (It's been too long to remember if this was when the settings were changed, or when any one of the multiple instances of UE were closed, or when all instances were closed.)

              6,633551
              Grand MasterGrand Master
              6,633551

                Oct 30, 2021#7

                This bug is fixed with UltraEdit for Windows v28.20.0.70 and UEStudio v21.10.0.24.
                Best regards from an UC/UE/UES for Windows user from Austria